Aller au contenu


Debian corrompue ?


  • Vous ne pouvez pas répondre à ce sujet
92 replies to this topic

#1 Swoosh

Swoosh

    Touriste Martien

  • Zimien
  • PipPipPipPipPip
  • 142 Messages :
  • Gender:Female
  • Location:Bourgogne, France

Posté 18 février 2017 - 16:47

Bonjour,

J'en ai encore une bien bonne à vous sortir, paraît que ma Debian est corrompue :ouch:
C'est pas moi qui le dit, mais un utilisateur sur un forum d'aide parce que phpmyadmin ne m'est pas accessible, suite à l'installation de Xampp.

Réinstaller Debian ne me botte pas du tout - surtout que je viens à  peine d'installer les meubles et de me sentir passablement bien dans mon interface - donc je me demandai s'il n'y avait pas moyen de savoir si des choses déconnaient dans ma distri ?

Il y a en a déjà quelques unes qui vont mal, mais je ne pensais pas que c'était grave jusqu'à ce que l'utilisateur en question me dise "But i cannot help you fixing your corrupted Linux installation, that looks quite ugly and i have no idea what causes all these errors.". Ugly ! C'est comme un boucher qui ferait de la chirurgie, bref j'ai les boules.

Voici les quelques petites choses qui ne sont toujours pas réglées actuellement :
- Le driver propriétaire nvidia est bien installé, mais il faut 10 à 15 min à chaque démarrage pour que mon écran soit détecté et que je puisse mettre une résolution autre que 640xjesaisplusquoi.

- Sur Minetest j'avais installé worldeddit, mais je n'ai jamais pu accéder au menu ingame. Bon le problème ne se pose plus car depuis une maj, Minetest crash à chaque démarrage.

- Je vais me faire taper sur les doigts mais j'emploie toujours une session root et pas sudo quand je dois faire quelque chose, parce que sudo ne marche pas et que j'ai pas cherché plus loin (j'aurai dû).
- Quand je souhaite ouvrir un lien depuis un autre programme que Firefox, j'ai systématiquement le message "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.". Donc je ferme ma fenêtre en cours et seulement là, le lien s'ouvre dans le navigateur.
- Je n'ai pas de driver compatible entre mon imprimante et ma version de Debian mais ça je crois que c'est le seul problème qui ne viendrait pas de ma distro elle-même XD
- J'ai aussi une erreur récurrente avec Handbrake qui fait que je ne peux pas convertir des fichiers en masse, uniquement un à un.
- Récemment XBMC a cessé de fonctionner et j'ai toujours l'erreur "XBMC needs hardware accelerated OpenGL rendering. Install an apropriate graphic driver." alors que ça fonctionnait très bien avec le driver actuel.

Et puis il y a sans doute d'autres erreurs que je ne vois pas...

Est-ce que selon vous tout ce merdier est réparable sans tout réinstaller ?

D'avance je vous remercie pour votre aide et si vous avez envie de me jeter des cailloux parce que ce que vous lisez est digne d'un film d'horreur avec des pc maltraités et torturés, allez-y éclatez-vous je le mérite totalement :'(

Bonne journée.
Swoosh


Les grands esprits discutent des idées.
Les esprits moyens discutent des événements.
Les petits esprits discutent des gens.

Eleanor Roosvelt

#Vegan


#2 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 19 février 2017 - 00:34

..

 

Sous quelle version de Debian es-tu ?

 

Que fais-tu avec MySQL, phpMyAdmin et toute le clique qui va avec ?

J'avoue ne plus m'être intéressé à tout ceci depuis un bail.

 

As-tu suivi cette procédure ?

phpMyAdmin apache.png

As-tu configuré correctement le fichier « config.inc.php » (s'il y a encore ça) ?

 

Quel port utilise ton phpMyAdmin et ce qui va avec ? Quel autre logiciel sur ta bécane pourrait utiliser le même port et le bloquer ?

Firefox ("Firefox is already running, but is not responding'') ? Skype ?? Autre ?

​As-tu essayé de tuer tous les processus / threads des logiciels qui pourraient gêner ?

Lorsqu'un système d'exploitation a autant de problèmes que semble en avoir le tien, il est bien souvent plus rapide de recommencer depuis une base ''propre'' et stable que d'essayer de tout résoudre. Ceci est aussi vrai pour Linux que pour Windows.

 

N'avais-tu pas fait une sauvegarde du système et du reste quand tout fonctionnait bien ?

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#3 Swoosh

Swoosh

    Touriste Martien

  • Zimien
  • PipPipPipPipPip
  • 142 Messages :
  • Gender:Female
  • Location:Bourgogne, France

Posté 20 février 2017 - 10:03

Salut,

Voilà les versions des parties concernées :
XAMPP version: 5.6.30-0
Operating System: Debian 4.9.2-2

Alors je souhaite me faire une base de donnée, enfin plusieurs, pour un projet pro et aussi pour de la gestion perso. J'ai déjà fait de la base de donnée en cours mais c'était vraiment succinct, un ami m'a filé un MOOC pour que je revois tout ça et il m'a conseillé d'utiliser Xampp plutôt que Office base - il est web developper. Je compte créer un serveur multimédia avec un Rapsbian et du coup peut-être mettre ma base de donnée en accès à distance sur le serveur - mais ça c'est selon mon usage, j'en aura peut-être pas besoin.

En fait selon une personne qui m'a répondu en fonction du error_log d'Apache, le problème viendrait de Firefox...
 

La console :

root@Nostoc:/home/swoosh/Téléchargements# ./xampp-linux-x64-5.6.30-0-installer.run
bash: ./xampp-linux-x64-5.6.30-0-installer.run: Permission non accordée
root@Nostoc:/home/swoosh/Téléchargements# sh xampp-linux-x64-5.6.30-0-installer.run
xampp-linux-x64-5.6.30-0-installer.run: 1: xampp-linux-x64-5.6.30-0-installer.run: Syntax error: Unterminated quoted string
root@Nostoc:/home/swoosh/Téléchargements# ./ xampp-linux-x64-5.6.30-0-installer.run
bash: ./ : est un dossier
root@Nostoc:/home/swoosh/Téléchargements# ./xampp-linux-x64-5.6.30-0-installer.run
bash: ./xampp-linux-x64-5.6.30-0-installer.run: Permission non accordée
root@Nostoc:/home/swoosh/Téléchargements# chmod +x xampp-linux-x64-5.6.30-0-installer.run
root@Nostoc:/home/swoosh/Téléchargements# ./xampp-linux-x64-5.6.30-0-installer.run
root@Nostoc:/home/swoosh/Téléchargements#
(caja:9985): EggSMClient-WARNING **: Failed to connect to the session manager: None of the authentication protocols specified are supported

/usr/share/themes/shearwater/gtk-2.0/gtkrc:339: Incapable de localiser le fichier image dans le chemin des pixmaps : « panel-bg-dark.png »

(caja:9985): Unique-DBus-WARNING **: Unable to open a connection to the session bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(caja:9985): Unique-DBus-WARNING **: Unable to connect to the running instance, aborting.

(firefox-esr:10004): GnomeUI-WARNING **: While connecting to session manager:
None of the authentication protocols specified are supported.

(firefox-esr:10004): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(firefox-esr:10004): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(firefox-esr:10004): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(firefox-esr:10004): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
/usr/share/themes/shearwater/gtk-2.0/gtkrc:339: Incapable de localiser le fichier image dans le chemin des pixmaps : « panel-bg-dark.png »
1487346207884    addons.productaddons    ERROR    Request failed certificate checks: [Exception... "SSL is required and URI scheme is not https."  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 145"  data: no]

(firefox-esr:10507): GnomeUI-WARNING **: While connecting to session manager:
None of the authentication protocols specified are supported.

(firefox-esr:10507): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(firefox-esr:10507): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(firefox-esr:10507): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(firefox-esr:10507): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
/usr/share/themes/shearwater/gtk-2.0/gtkrc:339: Incapable de localiser le fichier image dans le chemin des pixmaps : « panel-bg-dark.png »
1487346572806    addons.productaddons    ERROR    Request failed certificate checks: [Exception... "SSL is required and URI scheme is not https."  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 145"  data: no]
/usr/share/themes/shearwater/gtk-2.0/gtkrc:339: Incapable de localiser le fichier image dans le chemin des pixmaps : « panel-bg-dark.png »
/usr/share/themes/shearwater/gtk-2.0/gtkrc:339: Incapable de localiser le fichier image dans le chemin des pixmaps : « panel-bg-dark.png »
:1: parser error : Document is empty
[Fri Feb 17 16:36:09.001058 2017] [ssl:warn] [pid 9469] AH01906: www.example.com
^
:1: parser error : Document is empty
[Fri Feb 17 16:36:09.001058 2017] [ssl:warn] [pid 9469] AH01906: www.example.com
^
:1: parser error : Document is empty
[Fri Feb 17 16:36:09.001058 2017] [ssl:warn] [pid 9469] AH01906: www.example.com
^

** (soffice:10722): CRITICAL **: void g_lo_menu_insert_section(GLOMenu*, gint, const gchar*, GMenuModel*): assertion 'G_IS_LO_MENU (menu)' failed

** (soffice:10722): CRITICAL **: void g_lo_menu_insert_section(GLOMenu*, gint, const gchar*, GMenuModel*): assertion 'G_IS_LO_MENU (menu)' failed
1487346632782    addons.productaddons    ERROR    Request failed certificate checks: [Exception... "SSL is required and URI scheme is not https."  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 145"  data: no]
1487346633554    addons.update-checker    WARN    Update manifest for langpack-fr@firefox-esr.mozilla.org did not contain an updates property
1487346633883    addons.update-checker    WARN    Update manifest for {972ce4c6-7e08-4474-a285-3208198ce6fd} did not contain an updates property

L'error_log d'Apache :

[Fri Feb 17 16:36:09.001058 2017] [ssl:warn] [pid 9469] AH01906: www.example.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Fri Feb 17 16:36:09.001141 2017] [ssl:warn] [pid 9469] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 17 16:36:09.001259 2017] [suexec:notice] [pid 9469] AH01232: suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Fri Feb 17 16:36:09.056256 2017] [auth_digest:notice] [pid 9470] AH01757: generating secret for digest authentication ...
[Fri Feb 17 16:36:10.001780 2017] [ssl:warn] [pid 9470] AH01906: www.example.com:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Fri Feb 17 16:36:10.001823 2017] [ssl:warn] [pid 9470] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Fri Feb 17 16:36:10.001956 2017] [lbmethod_heartbeat:notice] [pid 9470] AH02282: No slotmem from mod_heartmonitor
[Fri Feb 17 16:36:10.013030 2017] [mpm_prefork:notice] [pid 9470] AH00163: Apache/2.4.25 (Unix) OpenSSL/1.0.2j PHP/5.6.30 mod_perl/2.0.8-dev Perl/v5.16.3 configured -- resuming normal operations
[Fri Feb 17 16:36:10.013060 2017] [core:notice] [pid 9470] AH00094: Command line: '/opt/lampp/bin/httpd -E /opt/lampp/logs/error_log -D SSL -D PHP'

Du coup je n'ai pas configuré le fichier config d'Apache, car Apache est fonctionnel - voyant vert - mais pas le reste...

Je vais regarder pour les ports !

En fait j'ai ce message à chaque fois que je clique sur un lien dans un autre logiciel que Firefox et la seule chose qui est ouverte, c'est ma fenêtre de navigation. Si je la ferme et que je clique sur le lien, Firefox se lance et l'ouvre bien, mais si Firefox tourne déjà y'a pas moyen.

Non je n'ai pas fait de sauvegarde système, depuis le début j'ai des petits trucs qui déconnent et comme je mets du temps à les régler, d'autres petits problèmes surviennent entre temps, donc je ne sauvegarde pas etc Mais ce n'est pas très grave, je fais ça avec du papier pour noter les soft à réinstaller et mon HD externe pour les données XD

Je vais réfléchir à la réinstallation du bouzin, mais j'ai peur de retrouver tous mes précédents problèmes en réinstallant la même version de Debian : driver de carte graphique toujours pas opérationnel à fond, écran pas détecté, Minetest qui crash, Handbrake etc

Les grands esprits discutent des idées.
Les esprits moyens discutent des événements.
Les petits esprits discutent des gens.

Eleanor Roosvelt

#Vegan


#4 vigen

vigen

    Hardcore Papa

  • Tonton Flingueur
  • PipPipPipPipPipPipPipPipPip
  • 6 439 Messages :
  • Gender:Male
  • Location:Normandie

Posté 20 février 2017 - 11:43

Bonjour,

 

Pourquoi ne pas utiliser "Stretch" ? vu que tu utilises déjà le noyau 4.9?

 

Concernant le .run, au vu des messages d'erreurs, as-tu vérifier, via les propriétés, si une éventuelle option "d'executable" était présente?

 

A la lecture des autres message d'erreur, beaucoup sont générées par un soucis de certificat apparemment.

 

Après sous debian, je sais pas comment c'est foutu pour un serveur, sous Leap on as le meta-paquet qui va bien pour ça !!! :D

 

(yast2-HTTP- Server  https://fr.opensuse.org/Portal:YaST  http://opensuse-guide.org/yast.php  )

 

Vigen.



#5 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 20 février 2017 - 13:56

..

 

Ai-je bien compris ? Tu utiliserais une version de Debian pour processeur ARM sur un Rasberry Pi. Pourquoi n'es-tu pas parti d'une Raspbian spécialement adaptée à ce minuscule ordinateur ?

 

Des bases de données adaptées pour Raspberry Pi / Raspbian,il y en a de nombreuse parmi lesquelles « mysql »

Database Packages (Raspberry Connect)

Raspberry Pi MYSQL & PHPMyAdmin Tutorial (Gus .. PiMyLifeUp .. 18 octobre 2015)

 

D'autre part, je pense que l'ensemble MySQL, phpMyAdmin, Xampp .. est à réserver à ceux qui ont une bonne base de l'informatique, à des professionnels par exemple.

Pourquoi ne commences-tu pas par une gestion de base de données plus accessibles à tous ?

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#6 Swoosh

Swoosh

    Touriste Martien

  • Zimien
  • PipPipPipPipPip
  • 142 Messages :
  • Gender:Female
  • Location:Bourgogne, France

Posté 20 février 2017 - 15:46

Pourquoi ne pas utiliser "Stretch" ? vu que tu utilises déjà le noyau 4.9?

 

Salut,

Hm bah parce que j'avais pas vu qu'elle était sortie XD
Ça change la donne du coup !
 

Concernant le .run, au vu des messages d'erreurs, as-tu vérifier, via les propriétés, si une éventuelle option "d'executable" était présente?

Non, mais ça c'est pareil, c'est un problème que j'ai avec quasiment tous les .run, si je n'utilise pas chmod +x ça ne passe pas du premier coup.

 

Ai-je bien compris ? Tu utiliserais une version de Debian pour processeur ARM sur un Rasberry Pi. Pourquoi n'es-tu pas parti d'une Raspbian spécialement adaptée à ce minuscule ordinateur ?

Je ne suis partie de rien pour l'instant, je n'ai pas encore de Rapsberry Pi et je n'ai pas encore regardé ce qu'il me faudra comme OS dessus etc
L'idée c'est de l'utiliser en premier lieu comme serveur multimédia pour ma TV, puis comme noeud Tor, et éventuellement si le besoin s'en fait sentir de mettre mes bases de données dessus. Et encore plus tard, peut-être d'héberger un site ou un blog, mais ça ce sera bien plus tard.

 

D'autre part, je pense que l'ensemble MySQL, phpMyAdmin, Xampp .. est à réserver à ceux qui ont une bonne base de l'informatique, à des professionnels par exemple.

Pourquoi ne commences-tu pas par une gestion de base de données plus accessibles à tous ?

J'ai déjà fait de la base de données - très succinctement certes -, on a utilisé excel et access et je trouve ça horripilant à utiliser alors qu'avec mysql je saurai faire plus de choses différentes à la fin.
J'ai déjà utilisé php pour gérer des sites sous worpress et j'ai vraiment envie de comprendre ce qui se passe derrière le serveur avec mysql. J'aime apprendre et ça j'aimerai bien le maîtriser, qui plus est Xampp permet d'installer tout le bouzin d'un coup, je trouve ça plus accessible qu'Access en fait.

A la lumière de vos retours - merci pour vos précieux conseils - je vais certainement formater et repartir de zéro, en espérant que cette fois moins de choses déconnent XD


Les grands esprits discutent des idées.
Les esprits moyens discutent des événements.
Les petits esprits discutent des gens.

Eleanor Roosvelt

#Vegan


#7 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 20 février 2017 - 18:01

Pourquoi ne pas utiliser "Stretch" ? vu que tu utilises déjà le noyau 4.9?

​Stecht n'est pas encore vraiment stabilisé ! A vos risques et périls !

 

​@ Swoosh

Manifestement, je n'avais pas tout compris !

 

Sur quel ordinateur travailles-tu actuellement ce bel ensemble MySQL, phpMyAdmin, Xampp ..  ?

D'où vient ce noyau « Operating System: Debian 4.9.2-2 » que tu mentionnes plus haut ?

S'agit-il du récent noyau Linux 4.9.2 (mais le 4.10 est déjà sorti) ? Si oui, dans quelle version de Debian (ou distribution ''fille'') l'utilises-tu ?

 

As-tu trouvé le processus ou thread de Firefox qui pourrait provoquer tant de blocages ?

 

Bon courage, surtout si tu insistes à utiliser MySQL sans avoir vraiment toutes les bases nécessaires au préalable.

Quand tu passeras à un Raspberry Pi, je répète mon conseil d'utiliser Raspbian et tous les produits déjà adaptés.

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#8 Swoosh

Swoosh

    Touriste Martien

  • Zimien
  • PipPipPipPipPip
  • 142 Messages :
  • Gender:Female
  • Location:Bourgogne, France

Posté 20 février 2017 - 19:23

Bonjour depuis Stretch !!

J'ai installé KDE pour voir, je suis sur le cul tellement l'interface est chouette !
Oui j'ai vu que c'était une version testing du coup j'ai séparé /home, /var, /dev et /temp ça me paraît plus sûr pour des réparations ultérieures.

 @Txon
Je vais utiliser l'ensemble Xampp sur mon pc fixe pour le moment.

C'est ce que j'obtiens avec uname -a, enfin maintenant cela n'a plus d'importance.

Merci, les bases nécessaires peuvent s'apprendre aussi ;)
Voui ne t'inquiète pas, pour l'instant je n'ai rien consulté sur le sujet, je sais que les Raspberry Pi existent et vaguement ce qu'on peut en faire. Je creuserai le sujet quand j'y serai.


Les grands esprits discutent des idées.
Les esprits moyens discutent des événements.
Les petits esprits discutent des gens.

Eleanor Roosvelt

#Vegan


#9 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 21 février 2017 - 09:43

 @Txon
Je vais utiliser l'ensemble Xampp sur mon pc fixe pour le moment.

C'est ce que j'obtiens avec uname -a, enfin maintenant cela n'a plus d'importance.


Et, sur ta version Debian qui ne te donne pas satisfaction, si tu essayais .. '' lsb_release -ds ''.. '' lsb_release -a '' .. '' cat /etc/debian_version '' .. '' cat /etc/issue '' .. qu'est-ce que tu obtiendrais ?

De toutes façons, à moins d'avoir confié ton ordinateur à une tierce personne ou d'avoir la mémoire courte et perdu le support d'installation, tu devrais bien savoir quelle version de Debian est (était) en place .. non ?
Celle d'origine aurait-elle été modifiée pour mettre en place un noyau récent ? Si oui, pourquoi et comment ?

@+
 


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#10 vigen

vigen

    Hardcore Papa

  • Tonton Flingueur
  • PipPipPipPipPipPipPipPipPip
  • 6 439 Messages :
  • Gender:Male
  • Location:Normandie

Posté 21 février 2017 - 10:08

 

Pourquoi ne pas utiliser "Stretch" ? vu que tu utilises déjà le noyau 4.9?

​Stecht n'est pas encore vraiment stabilisé ! A vos risques et périls !

 

Oui tu as raison de le préciser.

 

Cependant, sur ma machine Stretch était déjà très très stable. Il n'y a que sur l'ordi de mon fils qu'elle as pose problème...Ou du moins c'est le chip audio qui n'est pas reconnu correctement.

Sinon pour le reste ça roulais bien ;)



#11 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 21 février 2017 - 12:17

Oui tu as raison de le préciser.

 

Cependant, sur ma machine Stretch était déjà très très stable. Il n'y a que sur l'ordi de mon fils qu'elle as pose problème...Ou du moins c'est le chip audio qui n'est pas reconnu correctement.

Sinon pour le reste ça roulait bien ;)

Utiliser une version non encore officiellement stabilisée comme Strecht actuellement, n'est-ce pas un peu hasardeux lorsqu'on se lance sans l'expérience de gens vraiment qualifiés dans l'installation de logiciels complexes comme le sont MySQL, phpMyAdmin, Xampp ..  ?

 

C'est un peu comme installer ces mêmes logiciels dans une version vraisemblablement ''bricolée'' (changement du noyau par un autre plus récent).

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#12 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 21 février 2017 - 17:54

 


Et, sur ta version Debian qui ne te donne pas satisfaction, si tu essayais .. '' lsb_release -ds ''.. '' lsb_release -a '' .. '' cat /etc/debian_version '' .. '' cat /etc/issue '' .. qu'est-ce que tu obtiendrais ?

De toutes façons, à moins d'avoir confié ton ordinateur à une tierce personne ou d'avoir la mémoire courte et perdu le support d'installation, tu devrais bien savoir quelle version de Debian est (était) en place .. non ?
Celle d'origine aurait-elle été modifiée pour mettre en place un noyau récent ? Si oui, pourquoi et comment ?

Je n'ai plus cette version de Debian, je suis passée sous Stretch hier soir !
Oui j'étais sous Jessie, je n'ai pas modifié le noyau ou alors je l'ai fait sans le savoir.

​C'est bien toi qui a déclaré .. "4.9.2-2'' .. et ce n'est pas le noyau d'origine d'une Debian 8 Jessie .. loin s'en faut.

​Pour que ce noyau 4.9 apparaisse soudain, il  a bien fallu que quelqu'un fasse une grosse bidouille. Ce n'est pas quelque chose qui se produit suite à un seul ''clic'' accidentel quelque part et le faire sans s'en rendre est énorme.

​Beaucoup de tes maux viennent peut-être de là.

​@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#13 Severian

Severian

    Plus riant que sévère

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 747 Messages :
  • Gender:Male

Posté 21 février 2017 - 17:59

c'était le noyau des backports

 

Suite à une maj mon écran n'a plus été détecté, j'ai eu beau tester les pilotes nouveaux puis les pilotes officiels, pas moyen d'avoir la bonne résolution à l'allumage

 

c'était sans doute du au passage du noyau 4.8 au 4.9, donc les drivers vidéos à réinstaller, c'est l’inconvénient avec les backports, à chaque changement majeur de noyau, les drivers proprio doivent être purgé / réinstallé


ob3-de10.pngbanner98x30.png


#14 Swoosh

Swoosh

    Touriste Martien

  • Zimien
  • PipPipPipPipPip
  • 142 Messages :
  • Gender:Female
  • Location:Bourgogne, France

Posté 21 février 2017 - 18:42

Ah fuck non ! Le pire c'est que du coup j'ai repris le wiki des drivers nvidia pour les réinstaller et à l'étape de l'installation de linux-header puis du redémarrage, je suis plantée sur l'écran juste avant ma page de login - l'écran qui dit que sdb est clean etc -, et pour l'instant pas moyen de retourner en arrière.


Les grands esprits discutent des idées.
Les esprits moyens discutent des événements.
Les petits esprits discutent des gens.

Eleanor Roosvelt

#Vegan


#15 vigen

vigen

    Hardcore Papa

  • Tonton Flingueur
  • PipPipPipPipPipPipPipPipPip
  • 6 439 Messages :
  • Gender:Male
  • Location:Normandie

Posté 21 février 2017 - 19:05

Dis moi, tu n'oublies pas de faire le fichier xorg.conf suite à l'installation des drivers nvidia? Juste qu'une fois cela m'est arrivé !!! :transpi:



#16 Swoosh

Swoosh

    Touriste Martien

  • Zimien
  • PipPipPipPipPip
  • 142 Messages :
  • Gender:Female
  • Location:Bourgogne, France

Posté 21 février 2017 - 19:12

Ah mais je n'ai pas pu aller jusque-là ! L'installation plante car nouveau n'est pas blacklisté, c'est là que j'ai redémarré - à la demande de la console - et que tout a planté.
Depuis j'essaie d'aller au bout du boot mais je n'y parviens pas et je n'ai pas de fichier xorg.conf...

Je suis en train de me faire une live USB pour aller chercher mes données et voir si je peux faire quelque chose avant réinstallation complète :fumer:

D'ailleurs je sais même pas si j'ai envie d'installer les drivers propriétaires parce que ça ne réglait pas mon problème d'écran sous Jessie...


Les grands esprits discutent des idées.
Les esprits moyens discutent des événements.
Les petits esprits discutent des gens.

Eleanor Roosvelt

#Vegan


#17 Severian

Severian

    Plus riant que sévère

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 747 Messages :
  • Gender:Male

Posté 21 février 2017 - 19:53

tu peux normalement accéder à la console avec Ctrl Alt F1 (ou F2 à F6)  quand tu arrive sur le curseur clignotant


ob3-de10.pngbanner98x30.png


#18 Swoosh

Swoosh

    Touriste Martien

  • Zimien
  • PipPipPipPipPip
  • 142 Messages :
  • Gender:Female
  • Location:Bourgogne, France

Posté 21 février 2017 - 20:39

Han j'ai pas essayé... Mais bon c'est tout l'écran qui clignote x)

Enfin c'est pas grave, j'ai pu booter avec une live usb, j'ai récup les quelques données qui traînaient et du coup j'ai un moyen supplémentaire de gérer le bouzin en cas de problème.

Je songe donc à réinstaller directement Stretch à nouveau ou Jessie, mais avant j'aimerais savoir comment je peux gérer cette histoire de driver graphique... Enlever nouveau est une plaie sans nom et la réinstallation de nvidia ne règle pas le souci d'écran non détecté, quelles pistes je peux creuser selon vous ?


Les grands esprits discutent des idées.
Les esprits moyens discutent des événements.
Les petits esprits discutent des gens.

Eleanor Roosvelt

#Vegan


#19 Darksky

Darksky

    Martien

  • Eminence Verte
  • PipPipPipPipPipPipPipPip
  • 1 212 Messages :
  • Gender:Male
  • Location:Belgique

Posté 21 février 2017 - 22:07

Ce qui me semble bizarre, c'est que sur strech, les pilotes graphiques Nvidia disponibles dans synaptic sont les derniers en date, justement.

Je m'étais renseigné avant (merci Vigen ^^) et ceux présents via synaptic sont les même que ceux présents sur le site Nvidia.

 

Ils supportent ma GTX 970 (ce qui n'était pas le cas sur Jessie, où je devais les installer moi-même).

As-tu essayé d'installer ces pilotes directement depuis synaptic?


"Ils ne savaient pas que c'était impossible, alors ils l'ont fait."

Mark Twain


#20 vigen

vigen

    Hardcore Papa

  • Tonton Flingueur
  • PipPipPipPipPipPipPipPipPip
  • 6 439 Messages :
  • Gender:Male
  • Location:Normandie

Posté 22 février 2017 - 07:27

Je suis du même avis que Darksky (mais de rien !! :D) Il dois juste avoir un soucis de fichier de config....Est-ce possible de nous rappelez les dessous de ta machine, que l'on jette un oeil?



#21 Darksky

Darksky

    Martien

  • Eminence Verte
  • PipPipPipPipPipPipPipPip
  • 1 212 Messages :
  • Gender:Male
  • Location:Belgique

Posté 22 février 2017 - 08:57

Hé oui :)

 

Parce qu'en théorie, le simple fait de redémarrer le PC blacklist le driver Nouveau.

 

Si l'on suit ce qui est indiqué ici (c'est pour Jessie, mais c'est pareil): https://wiki.debian....s#Configuration

 

- Après avoir installé les pilotes Nvidia présent dans synaptic, on redémarre la machine, ça blacklist le driver Nouveau

- On retourne dans synaptic, et on installe le paquet nvidia-xconfig, qui va lui s'occuper de mettre à jour le fichier de configuration de Xorg:

 

 

Installer le paquet nvidia-xconfig, puis lancez-le avec sudo. Cela génèrera automatiquement un fichier de configuration Xorg à cet emplacement /etc/X11/xorg.conf}

 

Cette page concernant le pilote Nvidia est "magique", parce qu'elle donne aussi les solutions en cas de problèmes.

 

Ceci-dit, j'avais eu moi aussi pas mal d'embrouilles avec les pilotes graphiques. C'est vraiment pas la panacée sur Debian.


"Ils ne savaient pas que c'était impossible, alors ils l'ont fait."

Mark Twain


#22 vigen

vigen

    Hardcore Papa

  • Tonton Flingueur
  • PipPipPipPipPipPipPipPipPip
  • 6 439 Messages :
  • Gender:Male
  • Location:Normandie

Posté 22 février 2017 - 09:55

Personnellement sous Stretch je ne procède pas de cette manière, car si tu redémarres sans avoir, au préalable, générer ton fichier xorg.conf, tu auras un joli écran noir :)

 

Le serveur X patineras dans la semoule ^^

 

Ce que je fais, et qui fonctionne bien, mais qui n'as pas vocation à être "la solution", installation du paquet nvidia-detect, un ptit coup de console pour le lancer.

sudo nvidia-detect

Cela va indiquer le pilote supportant la cg, on installe le pilote SANS redémarrer, on installe nvidia-xconfig, on le lance 

sudo nvidia-xconfig

Il va te générer le xorg.conf, là, tu peux redémarrer. Voir même éventuellement virer Nouveau.

 

;)



#23 Darksky

Darksky

    Martien

  • Eminence Verte
  • PipPipPipPipPipPipPipPip
  • 1 212 Messages :
  • Gender:Male
  • Location:Belgique

Posté 22 février 2017 - 09:57

Ah oui, c'est vrai!

J'avais du faire de cette manière à l'époque :D


"Ils ne savaient pas que c'était impossible, alors ils l'ont fait."

Mark Twain


#24 Swoosh

Swoosh

    Touriste Martien

  • Zimien
  • PipPipPipPipPip
  • 142 Messages :
  • Gender:Female
  • Location:Bourgogne, France

Posté 22 février 2017 - 10:04

Salut,

 

Ce qui me semble bizarre, c'est que sur strech, les pilotes graphiques Nvidia disponibles dans synaptic sont les derniers en date, justement.

Je m'étais renseigné avant (merci Vigen ^^) et ceux présents via synaptic sont les même que ceux présents sur le site Nvidia.

 

Ils supportent ma GTX 970 (ce qui n'était pas le cas sur Jessie, où je devais les installer moi-même).

As-tu essayé d'installer ces pilotes directement depuis synaptic?

Non j'avais fait ça en mode console, le problème actuellement c'est que je ne peux pas atteindre synaptic XD

 

Je suis du même avis que Darksky (mais de rien !! :D) Il dois juste avoir un soucis de fichier de config....Est-ce possible de nous rappelez les dessous de ta machine, que l'on jette un oeil?

 

Que souhaites-tu savoir précisément ?
 

Hé oui :)

 

Parce qu'en théorie, le simple fait de redémarrer le PC blacklist le driver Nouveau.

 

Si l'on suit ce qui est indiqué ici (c'est pour Jessie, mais c'est pareil): https://wiki.debian....s#Configuration

 

- Après avoir installé les pilotes Nvidia présent dans synaptic, on redémarre la machine, ça blacklist le driver Nouveau

- On retourne dans synaptic, et on installe le paquet nvidia-xconfig, qui va lui s'occuper de mettre à jour le fichier de configuration de Xorg:

 

 

Installer le paquet nvidia-xconfig, puis lancez-le avec sudo. Cela génèrera automatiquement un fichier de configuration Xorg à cet emplacement /etc/X11/xorg.conf}

 

Cette page concernant le pilote Nvidia est "magique", parce qu'elle donne aussi les solutions en cas de problèmes.

 

Ceci-dit, j'avais eu moi aussi pas mal d'embrouilles avec les pilotes graphiques. C'est vraiment pas la panacée sur Debian.

 

Oui c'est bien cette page que j'ai suivi et le redémarrage qui a tout planté devait blacklisté nouveau... Je vais essayer d'accéder à une console, sinon je ferai ça depuis le recovery mode. Je teste ça de suite :)
 

Personnellement sous Stretch je ne procède pas de cette manière, car si tu redémarres sans avoir, au préalable, générer ton fichier xorg.conf, tu auras un joli écran noir :)

 

Le serveur X patineras dans la semoule ^^

 

Ce que je fais, et qui fonctionne bien, mais qui n'as pas vocation à être "la solution", installation du paquet nvidia-detect, un ptit coup de console pour le lancer.

sudo nvidia-detect

Cela va indiquer le pilote supportant la cg, on installe le pilote SANS redémarrer, on installe nvidia-xconfig, on le lance 

sudo nvidia-xconfig

Il va te générer le xorg.conf, là, tu peux redémarrer. Voir même éventuellement virer Nouveau.

 

;)

J'avais fait ça effectivement, la console m'a renvoyé d'installer nvidia-driver, le problème c'est que je n'ai pas pu installer le driver tant que je n'avais pas redémarrer pour blacklisté nouveau, en fait j'ai pas eu vraiment le choix ><

Merci pour vos retours, je vais essayer :)
 

EDIT : Omg j'ai pu booter jusqu'au bout !! Merci Darksky !!

Donc j'ai fait ça :
 

Installer le paquet nvidia-xconfig, puis lancez-le avec sudo. Cela génèrera automatiquement un fichier de configuration Xorg à cet emplacement /etc/X11/xorg.conf}

Et ça a lancé l'installation du driver Legacy 340, par contre j'ai pu constater que ma résolution n'était toujours pas détectée.
Ca me chiffonne un peu que ce soit le driver Legacy, ce n'est pas le pilote propriétaire, si j'essaie de l'installer là j'vais tout planter à nouveau ?


Ce message a été modifié par Swoosh - 22 février 2017 - 10:22 .

Les grands esprits discutent des idées.
Les esprits moyens discutent des événements.
Les petits esprits discutent des gens.

Eleanor Roosvelt

#Vegan


#25 Darksky

Darksky

    Martien

  • Eminence Verte
  • PipPipPipPipPipPipPipPip
  • 1 212 Messages :
  • Gender:Male
  • Location:Belgique

Posté 22 février 2017 - 10:13

Je vais essayer de mettre la main sur un HDD, débrancher tout mes systèmes et tenter une installation de Strech, pour voir ;)


"Ils ne savaient pas que c'était impossible, alors ils l'ont fait."

Mark Twain


#26 Swoosh

Swoosh

    Touriste Martien

  • Zimien
  • PipPipPipPipPip
  • 142 Messages :
  • Gender:Female
  • Location:Bourgogne, France

Posté 22 février 2017 - 10:23

Je vais essayer de mettre la main sur un HDD, débrancher tout mes systèmes et tenter une installation de Strech, pour voir ;)

Ah carrément ? XD

Ta solution a fonctionné en tout cas - cf. edit ci-dessus - merci :)

Maintenant ce problème de config...


Les grands esprits discutent des idées.
Les esprits moyens discutent des événements.
Les petits esprits discutent des gens.

Eleanor Roosvelt

#Vegan


#27 Darksky

Darksky

    Martien

  • Eminence Verte
  • PipPipPipPipPipPipPipPip
  • 1 212 Messages :
  • Gender:Male
  • Location:Belgique

Posté 22 février 2017 - 10:40

Ah on avance!

Oui, je suis en train de graver la rc2 de stretch. J'ai aussi un hdd

Me reste plus qu'à ouvrir la tour et débrancher mes 4 disques pour ne brancher que celui sue lequel je vais tester.

"Ils ne savaient pas que c'était impossible, alors ils l'ont fait."

Mark Twain


#28 vigen

vigen

    Hardcore Papa

  • Tonton Flingueur
  • PipPipPipPipPipPipPipPipPip
  • 6 439 Messages :
  • Gender:Male
  • Location:Normandie

Posté 22 février 2017 - 10:46

@Swoosh

 

"Oui c'est bien cette page que j'ai suivi et le redémarrage qui a tout planté devait blacklisté nouveau... Je vais essayer d'accéder à une console, sinon je ferai ça depuis le recovery mode. Je teste ça de suite"

 

Si tu généres pas le fichier xorg.conf, nouveau ne seras pas "blacklisté", ce n'est pas une action automatique lors de l'installation du pilote nvidia, tout est dans les xorg.conf :)

 

"je n'ai pas pu installer le driver tant que je n'avais pas redémarrer pour blacklisté nouveau" Pas normal, tu avais eu une instructions dans ce sens?

 

Concernant ce que je souhaitais savoir, c'est ce que tu as comme Hardware... :)


Ah on avance!

Oui, je suis en train de graver la rc2 de stretch. J'ai aussi un hdd

Me reste plus qu'à ouvrir la tour et débrancher mes 4 disques pour ne brancher que celui sue lequel je vais tester.

 

J'espère que c'est le "non-free.iso"?? :D

 

https://cdimage.debi...stretch_di_rc2/



#29 Darksky

Darksky

    Martien

  • Eminence Verte
  • PipPipPipPipPipPipPipPip
  • 1 212 Messages :
  • Gender:Male
  • Location:Belgique

Posté 22 février 2017 - 11:15

Même pas :D

Mais j'aurai dû. Au passage, je pense que ce sera une installation "legacy" car pas eu le temps de voir pour l'installer en uefi.

C'est en progression, on verra si j'arrive au bout de l'installation.

"Ils ne savaient pas que c'était impossible, alors ils l'ont fait."

Mark Twain


#30 vigen

vigen

    Hardcore Papa

  • Tonton Flingueur
  • PipPipPipPipPipPipPipPipPip
  • 6 439 Messages :
  • Gender:Male
  • Location:Normandie

Posté 22 février 2017 - 11:29

Même pas :D

Mais j'aurai dû. Au passage, je pense que ce sera une installation "legacy" car pas eu le temps de voir pour l'installer en uefi.

C'est en progression, on verra si j'arrive au bout de l'installation.

 

Croise les doigts pour la carte réseau :transpi:





0 utilisateur(s) en train de lire ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)