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PRÉSENTATION DE V IRTUALDUB

VirtualDub est un logiciel de traitement et de capture vidéo pour les plates-formes Windows 32 et 64 bits 
(98/ME/NT4/2000/XP/Vista/7) sous licence GNU General Public License (GPL) créé par Avery Lee. 

VirtualDub est principalement orienté vers le traitement fichiers AVI.

Voici quelques possibilités de ce puissant outil :

– Acquérir des vidéos.

– Ouvrir des fichiers vidéos.

– Coder des vidéos (Décompresse, compresse le son et l'image via des codecs).

– Appliquer des effets au travers de filtres.

– Faire du montage (couper des portions de vidéos, assembler des vidéos).

– Redimensionner des vidéos ( réduire ou agrandir la taille des images, découper une partie de l'image).

– Faire des traitements par lots.

– Assembler des séquences d'images BMP ou TGA (Il a des difficultés à traiter les PNG issues de Gimp).

– Visualiser le résultat via un système à 2 fenêtres.

– Convertir des fichiers Quicktime, Realvideo, Windows Media , etc.

– Réaliser des traitements par lot (Queue batch operation).

– Etc.

Le site de Virtualdub : http://www.virtualdub.org/

Wikipédia : http://en.wikipedia.org/wiki/VirtualDub   

http://fr.wikipedia.org/wiki/VirtualDub   

Remarque : VirtualDub n'est pas un logiciel de montage vidéo comme Adobe® Premiere®. 

Les tests décrits dans cette documentations sont réalisés avec :

– Windows 7 64 bits.

– VirtualDub 1.9.8 (stable), 32-bit version.

– Codecs K-Lite Mega Codec Pack. http://codecpackguide.com/klmcodec.htm  

– AviSynth 2.5.8 http://avisynth.org/ 

– Greffons des sites http://www.virtualdub.org , http://neuron2.net , http://www.thedeemon.com/VDFilterPack/  

– QuickTime Alternative http://www.codecguide.com/about_qt.htm  

– Real Alternative http://www.codecguide.com/about_real.htm  

http://www.virtualdub.org/
http://www.codecguide.com/about_real.htm
http://www.codecguide.com/about_qt.htm
http://www.thedeemon.com/VDFilterPack/
http://neuron2.net/
http://www.virtualdub.org/
http://avisynth.org/
http://codecpackguide.com/klmcodec.htm
http://fr.wikipedia.org/wiki/VirtualDub
http://en.wikipedia.org/wiki/VirtualDub
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M ISE EN ROUTE DES PROGRAMMES , CODECS ET GREFFONS

Voici la chronologie des opérations pour installer un ensemble relativement complet pour traiter des vidéos avec 
une très bonne qualité d'encodage.

Cette liste est à jour au 27 février 2010.

V IRTUALDUB

Virtualdub est un programme qui fonctionne sous Windows et dont beaucoup de greffons ou plugins sont 
compilés en version 32 bits. 

Pour obtenir le maximum de possibilités il faut donc installer la version 32 bits (y compris pour les versions  64 
bits de Windows)  disponible à la page : http://virtualdub.sourceforge.net/   lien direct : 
http://prdownloads.sourceforge.net/virtualdub/VirtualDub-1.9.8.zip?download 

Créer un répertoire ou dossier, par exemple C:\VirtualDub 

Placer le fichier d'archive téléchargé VirtualDub-1.9.8.zip dans C:\VirtualDub et décompresser par clic droit sur le 
dossier > Extraire tout > la fenêtre s'affiche > Extraire. 

http://prdownloads.sourceforge.net/virtualdub/VirtualDub-1.9.8.zip?download
http://virtualdub.sourceforge.net/
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Le sous-répertoire C:\VirtualDub\VirtualDub-1.9.8 est créé, voici son contenu

Pour démarrer VirtualDub il suffit de cliquer sur   VirtualDub.exe     . L'aide en anglais est le fichier VirtualDub.chm  

Ci-dessous, la fenêtre VirtualDub. Pour fermer le programme File > Quit ou clic sur le X sur fond rouge. 
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CODECS

Les codecs sont des logiciels qui compressent les images et le son selon des normes, par exemple X264,  XVID 
(vidéo), MP3 (son), etc. http://fr.wikipedia.org/wiki/Codec .

PACK  DE  CODECS

Se rendre à la page http://codecpackguide.com/klmcodec.htm  pour télécharger K-Lite Mega Codec Pack. Lien 
direct http://dl.codecpackguide.com/dl/klcodec416f.exe . Lancer le programme d'installation klcodec416f.exe.

Appuyer sur Next

Appuyer sur Next

Appuyer sur Next  

http://dl.codecpackguide.com/dl/klcodec416f.exe
http://codecpackguide.com/klmcodec.htm
http://fr.wikipedia.org/wiki/Codec
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Choisir Profile 7 : Lots of stuff et appuyer sur Next (ici, Media Player Classic sera installé). 

Appuyer sur Next  
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Appuyer sur Next  

Appuyer sur Install et attendre 

Appuyer sur Finish . L'installation des codecs est terminée

Remarque : La désinstallation de ce pack se fait par Panneau de configuration > Programmes et fonctionnalités > 
K-Lite Mega Codec Pack 4.1.6 (Full)  



Débuter avec Virtualdub  -  Mise en route des programmes, codecs et greffons   -  jeudi 8 avril 2010  -  Page 8 / 181

CODEC  AC-3 ACM CODEC  BY  FCCHANDLER

Page : http://fcchandler.home.comcast.net/~fcchandler/AC3ACM/index.html 

Télécharger http://fcchandler.home.comcast.net/~fcchandler/AC3ACM/AC3ACM.zip 

Décompresser AC3ACM.zip . Dans le dossier \x86 faire un clic droit sur le fichier AC3ACM.inf et clic sur Installer.

Cette action va placer AC3ACM.acm dans le répertoire C:\Windows\System32 et modifier la base de registres 
selon le contenu du fichier AC3ACM.inf .

Remarque : La désinstallation de ce codec AC-3 ACM se fait par Panneau de configuration > Programmes et 
fonctionnalités >  AC-3 ACM codec 

http://fcchandler.home.comcast.net/~fcchandler/AC3ACM/AC3ACM.zip
http://fcchandler.home.comcast.net/~fcchandler/AC3ACM/index.html
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AVISYNTH

Télécharger AviSynth à partir de ce lien http://sourceforge.net/projects/avisynth2/files/AviSynth
%202.5/AviSynth%202.5.8/Avisynth_258.exe/download  

La liste des téléchargements est à la page http://sourceforge.net/projects/avisynth2/files/ 

Lancer Avisynth_258.exe 

Appuyer sur OK   

Appuyer sur J'accepte   

Appuyer sur Suivant   

http://sourceforge.net/projects/avisynth2/files/
http://sourceforge.net/projects/avisynth2/files/AviSynth%202.5/AviSynth%202.5.8/Avisynth_258.exe/download
http://sourceforge.net/projects/avisynth2/files/AviSynth%202.5/AviSynth%202.5.8/Avisynth_258.exe/download
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Appuyer sur Installer   

Appuyer sur Suivant   

Appuyer sur Fermer . L'installation des codecs est terminée

Remarque : La désinstallation d'AviSynth se fait par Panneau de configuration > Programmes et fonctionnalités 
>  AviSynth 2.5  
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REAL ALTERNATIVE ET  QUICKT IME  ALTERNATIVE

Ces 2 logiciels sont des alternatives aux lecteurs d'Apple et Real. Ils sont utiles pour importer des vidéos de ces 
formats dans VirtualDub via Direct Show input driver.

Exemple d'un fichier RMVB (Real Media Variable Bitrate) :

REAL ALTERNATIVE

Aller à la page http://www.codecguide.com/download_real.htm , sélectionner [ Version 2.0.2 | 6.6 MB | February 
19th 2010 ] et choisir un site de téléchargement.

Lancer Real_Alternative_202.exe et suivre la procédure normale d'installation.

Remarque : La désinstallation de Real Alternative se fait par Panneau de configuration > Programmes et 
fonctionnalités >  Real Alternative 2.0.2  

QUICKT IME  ALTERNATIVE

Aller à la page http://www.codecguide.com/download_qt.htm  , sélectionner [ Version 3.1.1 | 18.1 MB | February 
15th 2009 ] et choisir un site de téléchargement.

Lancer quicktimealt311.exe et suivre la procédure normale d'installation.

Remarque : La désinstallation de QuickTime Alternative se fait par Panneau de configuration > Programmes et 
fonctionnalités >  QuickTime Alternative 3.1.1   

  

F ILTRES V IRTUALDUB AJOUTÉS

De nombreux filtres existent pour VirtualDub. Les développeurs peuvent trouver des informations à la page 
http://virtualdub.org/filtersdk.html 

Voici la liste des filtres utilisés dans cette documentation. Il faut décompresser les archives .zip et installer les 
fichiers .vdf dans le répertoire ou dossier C:\outils\virtualdub\plugins :

2DCLEAN.vdf                ACOBW.VDF
AsvzzzDeinterlace.vdf      Bob.vdf
BoxBlur.vdf                BrdCntrl235.vdf
Bright.vdf                 Colorize.vdf
Decimate.vdf               Deflick.vdf
Deinterlace.vdf            DeinterlaceAreaBased.vdf
dnr2.vdf                   fxVHS.vdf
Histo.vdf                  hotspot.vdf
Hue.vdf                    Logo.vdf

http://virtualdub.org/filtersdk.html
http://www.codecguide.com/download_qt.htm
http://www.codecguide.com/download_real.htm
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logoaway.vdf               MSharpen.vdf
MSU_Cartoonizer.vdf        msu_oldcinema_20.vdf
msu_sharpen.vdf            MSU_SmartDeblock_0.8.vdf
Pan.vdf                    Pseudocolor.vdf
Resize.vdf                 Reverse.vdf
Rgb.vdf                    rgbeq.vdf
Smart.vdf                  Smooth.vdf
Subtitler.vdf              Telecide.vdf
Tint.vdf                   Unsharp.vdf
UnViewFields12.vdf         ViewFields12.vdf
warpsharp.vdf              wimgfilter.vdf
Winhisto.vdf               xsharpen.vdf
Zoom.vdf 

DÉFINIT IONS  ET TÉLÉCHARGEMENTS

Fonction : Applies Sub Station Alpha v2.x/4.x scripts to video.
Page : http://virtualdub.org/virtualdub_filters.html 

Lien : http://www.virtualdub.org/downloads/subtitler-2_4.zip

Fonction : Removed dependency on BitBlt function.
Page : http://virtualdub.org/virtualdub_filters.html 

Lien : http://www.virtualdub.org/downloads/warpsharp-1_2.zip 

Fonction : Box Blur Filter (Original by Avery Lee)
Page : http://neuron2.net/boxblur/boxblur.html 

Lien : http://neuron2.net/boxblur/boxblur15.zip 

Fonction : Brightness/Contrast (UI Enhanced) Filter
Page : http://neuron2.net/bright.html 

Lien : http://neuron2.net/bright10.zip 

Fonction : Colorize Filter
Page : http://neuron2.net/colorize.html 

Lien : http://neuron2.net/colorize11b1.zip 

Fonction : Decimate Filter
Page : http://neuron2.net/decimate.html 

Lien : http://neuron2.net/decimate12.zip 

http://neuron2.net/decimate12.zip
http://neuron2.net/decimate.html
http://neuron2.net/colorize11b1.zip
http://neuron2.net/colorize.html
http://neuron2.net/bright10.zip
http://neuron2.net/bright.html
http://neuron2.net/boxblur/boxblur15.zip
http://neuron2.net/boxblur/boxblur.html
http://www.virtualdub.org/downloads/warpsharp-1_2.zip
http://virtualdub.org/virtualdub_filters.html
http://www.virtualdub.org/downloads/subtitler-2_4.zip
http://virtualdub.org/virtualdub_filters.html
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Fonction : Deflicker Filter
Page : http://neuron2.net/deflick/flick.html 

Lien : http://neuron2.net/deflick/deflick13b1.zip 

Fonction : Histogram Equalization Filter
Page : http://neuron2.net/histogram.html 

Lien : http://neuron2.net/histo11.zip 

Fonction : Hotspot Filter
Page : http://neuron2.net/hotspot/hotspot.html 

Lien : http://neuron2.net/hotspot/hotspot10.zip 

Fonction : Hue/Saturation/Intensity Filter
Page : http://neuron2.net/hue.html 

Lien : http://neuron2.net/hue12.zip 

Fonction : Logo Filter
Page : http://neuron2.net/logo/logo.html 

Lien : http://neuron2.net/logo/logo17b2.zip 

Fonction : MSharpen Filter (Andreas Ludwig co-author)
Page : http://neuron2.net/msharpen/msharpen-vdub.html 

Lien : http://neuron2.net/msharpen/msharpen121-vdub.zip 

Fonction : Pan Filter
Page : http://neuron2.net/pan.html 

Lien : http://neuron2.net/pan.zip 

Fonction : Pseudocolor Filter
Page : http://neuron2.net/pseudocolor/pseudocolor.html 

Lien : http://neuron2.net/pseudocolor/pseudocolor10.zip 

Fonction : Red/Green/Blue Adjustment Filter
Page : http://neuron2.net/rgb.html 

Lien : http://neuron2.net/rgb10.zip 

http://neuron2.net/rgb10.zip
http://neuron2.net/rgb.html
http://neuron2.net/pseudocolor/pseudocolor10.zip
http://neuron2.net/pseudocolor/pseudocolor.html
http://neuron2.net/pan.zip
http://neuron2.net/pan.html
http://neuron2.net/msharpen/msharpen121-vdub.zip
http://neuron2.net/msharpen/msharpen-vdub.html
http://neuron2.net/logo/logo17b2.zip
http://neuron2.net/logo/logo.html
http://neuron2.net/hue12.zip
http://neuron2.net/hue.html
http://neuron2.net/hotspot/hotspot10.zip
http://neuron2.net/hotspot/hotspot.html
http://neuron2.net/histo11.zip
http://neuron2.net/histogram.html
http://neuron2.net/deflick/deflick13b1.zip
http://neuron2.net/deflick/flick.html
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Fonction : Reverse Field Dominance Filter
Page : http://neuron2.net/reverse/reverse.html 

Lien : http://neuron2.net/reverse/reverse10.zip 

Fonction : Smart Bob Filter
Page : http://neuron2.net/bob.html 

Lien : http://neuron2.net/bob11b2.zip 

Fonction : Smart Deinterlacer Filter
Page : http://neuron2.net/smart/smart.html 

Lien : http://neuron2.net/smart/smart28b1.zip 

Fonction : Smart Resize Filter
Page : http://neuron2.net/resize.html 

Lien : http://neuron2.net/resize11.zip 

Fonction : Smart Smoother Filter
Page : http://neuron2.net/smooth.html 

Lien : http://neuron2.net/smooth11.zip 

Fonction : Telecide Filter
Page : http://neuron2.net/telecide.html 

Lien : http://neuron2.net/telecide130.zip 

Fonction : Tint Filter
Page : http://neuron2.net/tint/tint.html 

Lien : http://neuron2.net/tint/tint10.zip 

Fonction : Unsharp Mask Filter
Page : http://neuron2.net/unsharp/unsharp.html 

Lien : http://neuron2.net/unsharp/unsharp14.zip 

Fonction : Windowed Histogram Equalization Filter
Page : http://neuron2.net/winhistogram.html 

Lien : http://neuron2.net/winhisto10.zip 

http://neuron2.net/winhisto10.zip
http://neuron2.net/winhistogram.html
http://neuron2.net/unsharp/unsharp14.zip
http://neuron2.net/unsharp/unsharp.html
http://neuron2.net/tint/tint10.zip
http://neuron2.net/tint/tint.html
http://neuron2.net/telecide130.zip
http://neuron2.net/telecide.html
http://neuron2.net/smooth11.zip
http://neuron2.net/smooth.html
http://neuron2.net/resize11.zip
http://neuron2.net/resize.html
http://neuron2.net/smart/smart28b1.zip
http://neuron2.net/smart/smart.html
http://neuron2.net/bob11b2.zip
http://neuron2.net/bob.html
http://neuron2.net/reverse/reverse10.zip
http://neuron2.net/reverse/reverse.html
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Fonction : Xsharpen Filter
Page : http://neuron2.net/xsharp.html 

Lien : http://neuron2.net/xsharpen10b2.zip 

Fonction : Zoom Filter (Avery Lee co-author)
Page : http://neuron2.net/zoom.html 

Lien : http://neuron2.net/zoom12.zip 

Fonction : VirtualDub Filter Pac
Page : http://www.thedeemon.com/VDFilterPack/ 

Lien : http://www.thedeemon.com/VDFilterPack/VDFilterPackSetup.exe 

Lancer VDFilterPackSetup.exe et choisir un bon répertoire d'installation 

Remarque : La désinstallation de VirtualDub Filter Pac se fait par Panneau de configuration > Programmes et 
fonctionnalités >  VirtualDub Filter Pac 1.1   

Copier tous les fichiers   .vdf   du répertoire   C:\VirtualDub\VirtualDub-1.9.8\plugins\VD Filter Pack   et les coller dans   
C:\VirtualDub\VirtualDub-1.9.8\plugins     

Désinstaller ce pack.

http://www.thedeemon.com/VDFilterPack/VDFilterPackSetup.exe
http://www.thedeemon.com/VDFilterPack/
http://neuron2.net/zoom12.zip
http://neuron2.net/zoom.html
http://neuron2.net/xsharpen10b2.zip
http://neuron2.net/xsharp.html
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GREFFONS  DE V IRTUALDUB

Ces greffons permettent d'importer différents types de fichiers vidéo. Ils ont pour extension .vdplugin et se 
placent dans le répertoire Plugins32, dans notre exemple : C:\VirtualDub\VirtualDub-1.9.8\Plugins32 

Fonction : MPEG-2 plugin by fccHandler Version 3.8 (February 13, 2010)

Page : http://fcchandler.home.comcast.net/~fcchandler/Plugins/MPEG2/index.html 

Lien : http://fcchandler.home.comcast.net/~fcchandler/Plugins/MPEG2/MPEG2.zip 

Fonction : WMV plugin by fccHandler Version 2.0 (February 13, 2010)  

Page : http://fcchandler.home.comcast.net/~fcchandler/Plugins/WMV/index.html   

Lien : http://fcchandler.home.comcast.net/~fcchandler/Plugins/WMV/WMV.zip   

Fonction : AC-3 plugin by fccHandler Version 1.5 (February 13, 2010)  

Page : http://fcchandler.home.comcast.net/~fcchandler/Plugins/AC3/index.html   

Lien : http://fcchandler.home.comcast.net/~fcchandler/Plugins/AC3/AC3.zip   

Fonction : FLIC plugin by fccHandler Version 1.2 (February 14, 2010)  

Page : http://fcchandler.home.comcast.net/~fcchandler/Plugins/FLIC/index.html   

Lien : http://fcchandler.home.comcast.net/~fcchandler/Plugins/FLIC/FLIC.zip   

Fonction : Quicktime Import v0.2.0.0  

Page : http://www.tateu.net/software/    

Lien :  http://www.tateu.net/software/dl.php?f=qtvd_bin  

Fonction : FLV Input Plugin v1.1.0 

Page : http://www.moitah.net/   

Lien : http://www.moitah.net/download/latest/FLV_Input_Driver.zip   

Fonction : Directshow 0.4  

Page : http://forums.virtualdub.org/index.php?act=ST&f=7&t=15093&st=0   

Lien : http://www.virtualdub.org/beta/DShowInputDriver-0.4.zip   

Liste des greffons installés :
AC3.vdplugin                AC364.vdplugin DShowInputDriver.vdplugin   
FLIC.vdplugin FLIC64.vdplugin       FLVInputDriver.vdplugin
MPEG2.vdplugin              MPEG264.vdplugin Quicktime.vdplugin          
WMV.vdplugin WMV64.vdplugin

http://www.virtualdub.org/beta/DShowInputDriver-0.4.zip
http://forums.virtualdub.org/index.php?act=ST&f=7&t=15093&st=0
http://www.moitah.net/download/latest/FLV_Input_Driver.zip
http://www.moitah.net/
http://www.tateu.net/software/dl.php?f=qtvd_bin
http://www.tateu.net/software/
http://fcchandler.home.comcast.net/~fcchandler/Plugins/FLIC/FLIC.zip
http://fcchandler.home.comcast.net/~fcchandler/Plugins/FLIC/index.html
http://fcchandler.home.comcast.net/~fcchandler/Plugins/AC3/AC3.zip
http://fcchandler.home.comcast.net/~fcchandler/Plugins/AC3/index.html
http://fcchandler.home.comcast.net/~fcchandler/Plugins/WMV/WMV.zip
http://fcchandler.home.comcast.net/~fcchandler/Plugins/WMV/index.html
http://fcchandler.home.comcast.net/~fcchandler/Plugins/MPEG2/MPEG2.zip
http://fcchandler.home.comcast.net/~fcchandler/Plugins/MPEG2/index.html
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INSTALLATION SIMPLIFIÉE DE LA VERSION DE FÉVRIER  2010
 qui contient tous les programmes de cette documentation.

Il suffit de décompresser dans C:\ .

Les programmes d'installation .exe sont dans C:\VirtualDub\programmes_et_sources 

À PROPOS DE LA VERSION 64 BITS DE V IRTUALDUB

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Différences entre les versions x86 (32bits) et AMD64 (64bits)

Toutes les fonctionnalités n'ont pas été reportées dans la version 64-bit, et la sélection des filtres vidéo est donc  
réduite par rapport à la version 32-bit. De plus, certaines fonctionnalités prises en charge ne sont pas entièrement  
optimisées par rapport à leur équivalent de la version 32-bit, et ainsi la version 64-bit peut être ou ne pas être  
plus rapide que la version 32-bit dans votre scénario.

Du fait de la limitation de l'OS, les programmes 64-bit ne peuvent pas charger les DLL 32-bit, et vice-versa. Il en  
résulte que l'utilisation de la version 64-bit de VirtualDub nécessite les codecs vidéo 64-bit et les filtres vidéo 64-
bit; Les codecs vidéo 32-bit n'apparaîtront pas dans la liste des codecs vidéo ou ne seront pas disponibles pour  
l'ouverture des fichiers AVI, et les filtres vidéo 32-bit ne seront pas chargés. De plus, les pilotes AVIFile doivent  
être en 64-bit pour être utilisés lors du chargement; en particulier, VirtualDub pour AMD64 ne peut pas être  
utilisé avec la version 32-bit normale d'Avisynth.

http://philou-traductions.fr/
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L' INTERFACE DE V IRTUALDUB

L'interface de VirtualDub est en anglais. 

Cette interface se décompose principalement en 7 parties (selon les options d'affichage définies au chapitre « Le 
menu View  » à la page 35      )  :

Les menus         La source vidéo                                    La vidéo modifiée par les filtres

Le curseur sur la ligne de temps     Les boutons  L'indicateur de position    Barre d'états

( Image de la vidéo http://www.youtube.com/watch?v=IkU158B5VzQ Céline Dion & Garou - Sous Le Vent )

Traduction adaptée (où frame ≈ image) de l'aide par les Manuels d'Aide en Français sur manuelsdaide.com :

Panneaux d'affichage 
Deux panneaux rectangulaires occupent la presque totalité de l'interface de VirtualDub; celui de gauche  

représente le panneau d'entrée et celui de droite la panneau de sortie. A mesure du déplacement de la position  
vidéo en cours, les panneaux sont réactualisés avec l'original et le résultat du filtrage de l'image. Ce qui est  
pratique pour effectuer une comparaison entre la vidéo "avant" et la vidéo "après".

http://www.youtube.com/watch?v=IkU158B5VzQ
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La position et la taille des panneaux d'affichage sont réglables...

Curseur de position 
Faites glisser le curseur situé sous les panneaux pour changer la position actuelle de la vidéo. Si l'option est  

activée, les panneaux d'affichage seront actualisés pour montrer l'image sélectionnée. Maintenir enfoncée la  
touche Maj lors du déplacement oblige la position en cours à être placée sur les images cléf seulement. Utiliser le 
bouton droit de la souris au lieu du bouton gauche entraîne un déplacement plus lent pour un positionnement plus  
précis.

Chaque position du curseur de positionnement correspond au début de chaque image sur la ligne des temps de la  
vidéo. Ce qui fait qu'il existe une autre position à la fin, correspondant à la fin de la vidéo. Par exemple, avec une  
vidéo de 2280 images, le curseur peut être positionné de 0 à 2280.

Contrôles de la lecture 
Ces boutons permettent de démarrer et d'arrêter la lecture de l'aperçu de la vidéo. Le bouton de lecture  

symbolisé par un petit "I" ne lit que la vidéo source; celui qui porte un petit "O" lit les aperçus de la vidéo source  
et la vidéo de sortie filtrée. Lire l'aperçu de la vidéo de sortie demande beaucoup plus de puissance CPU et cette  
lecture peut ne pas s'effectuer en temps réel si l'image vidéo est grande ou que les filtres vidéo utilisés sont  
complexes. 

Contrôle des images  

Ces boutons permettent d'atteindre respectivement le début de la vidéo, l'image précédente, l'image suivante, et  
la fin de la vidéo. Ces actions peuvent aussi s'effectuer via le clavier à l'aide des combinaisons Ctrl+Flèche 
gauche, Flèche gauche, Flèche droite, et Ctrl+Flèche droite. 

Contrôle des images clef    
Ces boutons permettent d'atteindre l'image clef précédente ou suivante de la vidéo. Une image clef est une image  

enregistrée dans le fichier vidéo avec la totalité de son contenu et qui ne dépend pas des autres images pour le  
décodage; elles constituent des points de recherche rapide au sein de la vidéo et sont souvent aussi de qualité  
légèrement supérieure. Naviguer d'image clef en image clef est souvent sensiblement plus rapide et s'avère très  
pratique pour parcourir la vidéo. De plus, les images clef représentent des points de coupure appropriés lors  
d'une édition en mode Direct.

Le contrôle des images clef peut aussi s'effectuer via le clavier à l'aide des combinaisons   Maj  +  Flèche gauche   et   
Maj  +  Flèche droite  .  

Contrôle des scènes 
Ces boutons permettent d'atteindre la scène précédente ou suivante de la vidéo. La détection des scènes  

s'effectue par l'analyse heuristique des images (méthode approximative), en recherchant les modifications  
importantes de l'image qui indiquent les coupures ou fondues possibles de la vidéo. Les facteurs qui déterminent  
une fondue ou une coupure sont réglables dans la boîte de dialogue « Preferences » : Options > Preferences > 
Scene.

Lors de l'examen d'une vidéo volumineuse, les panneaux d'affichage s'actualiseront, au début, à une fréquence  
plus lente, ce qui est normal. L'actualisation sera réduite après une courte période de façon à réduire l'utilisation  
du CPU et d'accélérer l'examen.
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Contrôle des marquages d'entrée et de sortie  
Ces boutons permettent de régler les points du début et de la fin de la sélection à la position en cours. La 

sélection est utilisée par les commandes du menu édition (Edit) pour modifier les portions de la vidéo à restituer.  
Ainsi, si une portion de la vidéo est sélectionnée lorsque les commandes « File > Save ... » sont utilisées, seule  
cette portion de vidéo sera traitée.

Début    Sélection    Fin

Les touches Home et Fin sont également utilisables pour sélectionner la vidéo.

Remarque  :  Du fait que la position du curseur se déplace au début des images, le point de marquage de sortie  
doit être placé une image après la dernière image à sélectionner. Ce qui signifie que si 300 images sont à  
supprimer à partir de l'image 100, la sélection devra commencer (marquage d'entrée)  à l'image100 et se terminer  
(marquage de sortie) à l'image 100+300 = 400, et non pas à l'image 399. Ce qui fait référence au point de fin  
exclusif de la sélection. 

Affichage du temps écoulé  

Affiche le numéro, le temps écoulé, le type d'image à la position actuelle du curseur. Les types d'images sont les  
suivants:

• [K] : une image clef. (AVI) 

• [ ] : une image delta - enregistré comme la différence d'une image précédente. (AVI) 

• [D] : une image perdue ou nulle qui répète l'image précédente. On les trouve plus souvent dans les fichiers de  
capture. (AVI) 

• [I] : une frame I; similaire à une image clef. (MPEG-1) 

• [P]: une image P, ou image suivante extrapolée. Ces images sont enregistrées comme la différence d'une  
image plus récente. (MPEG-1) 

• [B] : une « frame  B, ou bidirectionnelle extrapolée. Ces images sont enregistrées comme la différence d'une  
image plus récente et d'une image future. (MPEG-1) 

• [M] : une image masquée. Ces images ont été marquées sur la ligne des temps de VirtualDub comme étant à  
ne pas traiter; l'image précédente sera utilisée à la place. Ce qui est le plus souvent utilisé pour contourner les  
erreurs de la source. L'image de fin sera aussi considérée comme l'une d'entre elles. 

Le format d'affichage du temps écoulé est personnalisable dans la boîte de dialogue « Preferences » : Options > 
Preferences > Timeline.
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LE MENU F ILE (F ICHIER)

OUVRIR  UN  FICHIER ,  UNE  SÉQUENCE

Par File > Open Video File  ou utiliser le raccourci Ctrl+0 

Cette action permet d'ouvrir des fichier vidéo, des séquence d'images, sons.

Certains types de fichiers demandent de paramétrer le nom de fichier puis le type d'importation, par exemple les 
fichiers RMVB (Real Media Variable Bitrate) :

Ouverture d'une séquence d'images :
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RÉ-OUVRIR  LE  FICHIER  
File > Reopen video file ou raccourci touche de fonction F2.

Ré-ouvrir le fichier vidéo.

AJOUTER  UNE  SÉQUENCE  AVI 
File > Append AVI segment 

Ajouter une séquence AVI (fichier avec les mêmes caractéristiques de format) à un fichier déjà ouvert.

V ISUALISER  LA  VIDÉO  D 'ENTRÉE (SOURCE)
File > Preview input ou  raccourci Barre d'espacement.

Lancer la lecture de la source à partir de la position du curseur.

V ISUALISER  LA  VIDÉO  FILTRÉE  (ACTION  DES  FILTRES)
File > Preview filtered ou  raccourci touche Entrée.

Lancer la lecture de la source et du côté filtres à partir de la position du curseur ().

V ISUALISER  LE  RÉSULTAT  DEPUIS  LE DÉBUT

File > Preview output from start ou  raccourci touche de fonction F5.

Lancer la lecture de la source et du côté filtres à partir du début avec affichage des caractéristiques sans action sur 
le curseur. 

Voir aide CHM de VirtualDub au chapitre Video Filters > Rendering/saving. 

Traduction de l'aide par les Manuels d'Aide en Français sur manuelsdaide.com :

La commande File > Preview output from start débute par la restitution de la ligne des temps pour la lecture de  
la vidéo de façon a en afficher l'aperçu. La plupart des opérations de traitement vidéo et audio sont actifs dans ce  
mode, sauf en ce qui concerne la compression vidéo et audio qui est désactivée. Le résultat qui apparaît dans le  
panneau d'affichage et audible depuis les haut-parleurs du système est la représentation du système de filtrage  
vidéo et audio des données émises, mais peut être de qualité supérieure à un enregistrement sous forme  
compressée.
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ANALYSE  VIDÉO

File > Run video analysis pass  

Traduction de l'aide par les Manuels d'Aide en Français sur manuelsdaide.com :

Certains filtres et codecs vidéo peuvent nécessiter des passes d'analyse dans la but de filtrer ou compresser la  
vidéo de façon efficace. Au cours des passes d'analyse, la vidéo est examinée pour déterminer les zones de  
mouvement difficile ou autres fonctions; la connaissance de la vidéo entière sera alors utilisée pour optimiser la  
sortie finale. Cette fonction est connue sous le nom de Run video analysis pass  .

Pour différentes raisons, VirtualDub ne sait pas si une opération multi-passes est nécessaire par un filtre ou un  
codec vidéo et ne peut pas automatiser le processus. Cependant, l'option File > Run video analysis pass  aide à 
l'exécution des passes d'analyse en exécutant le pipeline vidéo sans écrire un fichier maquette sur le disque. Le  
pipeline audio est également désactivé pour augmenter la vitesse.

SAUVEGARDE  AU  FORMAT  AVI
File > Save as AVI ou raccourci touche de fonction F7.

Sauvegarde (ou enregistrement) de la vidéo au format AVI en fonction des paramètres d'encodage vidéo et audio 
(compression, formats) et des filtres utilisés.

Voir aide CHM de VirtualDub  au chapitre Video Filters > Rendering/saving. 

Traduction de l'aide par les Manuels d'Aide en Français sur manuelsdaide.com :

VirtualDub peut normalement écrire des fichiers AVI supérieurs à 2Go en utilisant une extension pour le format  
de fichier AVI nommée l'index hiérarchique OpenDML. Ce qui se fait de façon à ce que les anciennes applications  
qui ne peuvent pas interpréter l'index hiérarchique peuvent tout de même ouvrir les deux premiers Giga-octets du  
fichier. Cependant, une application sera parfois incapable d'ouvrir de tels fichiers.

SAUVEGARDE  À L 'ANCIEN FORMAT  AVI
File > Save old format AVI ou raccourci Maj + F7.

Sauvegarde (ou enregistrement) de la vidéo à l'ancien format AVI en fonction des filtres utilisés, l'ensemble 
sauvegardé doit avoir un volume inférieur à 2Go.

Ce format peut être ouvert dans Gimp, exemple :
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Voir aide CHM de VirtualDub  au chapitre Video Filters > Rendering/saving. 

Traduction de l'aide par les Manuels d'Aide en Français sur manuelsdaide.com :

La commande Save old format AVI désactive l'utilisation par VirtualDub de cette extension de sorte que seul un  
format de fichier AVI original sera écrit. Notez que ce format ne prend pas en charge les fichiers AVI supérieurs à  
2Go. Pensez alors à réduire ou à compresser la vidéo de façon appropriée pour rester en-dessous de ce seuil.

SAUVEGARDE  D 'UN  AVI SEGMENTÉ  (OU  FRACTIONNÉ)
File > Save segmented AVI.

FERMER  LE FICHIER  OUVERT

File > Close video file ou raccourci Crtl + W.

Fermeture du fichier ouvert sans quitter Virtualdub. 

 EXPORTER  UNE  SÉQUENCE  D ' IMAGES

File > Export > Image sequence 

Exporter une vidéo en une séquence d'images. Ci-dessous, un exemple d'une exportation au format jpeg avec une 
qualité de 25. Les fichiers sont export_sequence_file0000.jpeg à export_sequence_filexxxx.jpeg. Dans Gimp, il est 
possible de récupérer cette séquence via GAP (Gimp Animation Package).

STRIPE  MASTER  
File > Export > Stripe master 

Option valide après une capture AVI, à voir... 
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STRIPED  AVI
File > Export > Striped AVI 

Option valide après une capture AVI, à voir...

EXPORT  AU  FORMAT  F I LMSTRIP  D 'ADOBE  
File > Export > Adobe Filmstrip (*.flm)

Adobe Filmstrip sequences for rotoscoping in Photoshop...

À propos du format Adobe Filmstrip : http://livedocs.adobe.com/en_US/PremierePro/3.0/help.html?
content=WSbaf9cd7d26a2eabf53ab041041081290f-7fc6.html  

EXPORT  DE  L 'AUDIO  AU  FORMAT  RAW
File > Export > Raw audio

Export du son au format Brut.

EXPORT  EN  GIF ANIMÉ

File > Export > Animated gif

Export de la vidéo au format GIF animé (réservé aux petites animations).

Exemple d'un gif animé dont la lecture est répétée 5 fois :

METTRE  UNE  TÂCHE  EN  ATTENTE  (QUEUE BATCH  OPERATION)
Mémorisation des opérations à effectuer, par exemple un codage d'une vidéo en plusieurs passes. 

Principe : On active les options de « Queue batch opération » qui sont mémorisées. Entre chaque action on 
modifie les paramètres. Lorsque tout est prêt, le traitement est activé par File > Job control ou touche de fonction 
F4. Une fenêtre s'affiche. On sélectionne le travail (job x) à effectuer puis on appuie sur le bouton Start.

http://livedocs.adobe.com/en_US/PremierePro/3.0/help.html?content=WSbaf9cd7d26a2eabf53ab041041081290f-7fc6.html
http://livedocs.adobe.com/en_US/PremierePro/3.0/help.html?content=WSbaf9cd7d26a2eabf53ab041041081290f-7fc6.html
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  Voir aide CHM de VirtualDub  au chapitre Batch operation.

ANALYSE  VIDÉO  DIFFÉRÉE  (RUN  VIDEO  ANALYSIS  PASS)
File > Queue batch operation > Run video analysis pass

Activer le démarrage de l'analyse par File > Job control ou touche de fonction F4. La fenêtre «  VirtualDub Job 
Control » s'affiche, on sélectionne le travail (job x) à effectuer puis on appuie sur le bouton Start. L'analyse 
commence :
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SAUVEGARDE  DIFFÉRÉE  AU  FORMAT  AVI
File > Queue batch operation > Save as AVI ou raccourci Ctrl+Maj+F7

Activer le démarrage de la sauvegarde (ou enregistrement)  par File > Job control ou touche de fonction F4. La 
fenêtre «  VirtualDub Job Control » s'affiche, on sélectionne le travail (job x) à effectuer puis on appuie sur le 
bouton Start. La sauvegarde commence.

Voir « Sauvegarde au format AVI » page 23.

SAUVEGARDE  DIFFÉRÉE  À L 'ANCIEN FORMAT  AVI
File > Queue batch operation > Save old format AVI 

Activation de la sauvegarde (ou enregistrement)  par la fenêtre «  VirtualDub Job Control » par la touche de 
fonction F4 puis appui sur le bouton Start.

Voir « Sauvegarde à l'ancien format AVI » page 23.

SAUVEGARDE  DIFFÉRÉE  D 'UN  AVI SEGMENTÉ  (OU  FRACTIONNÉ)
File > Queue batch operation > Save segmented AVI

Activation de la sauvegarde (ou enregistrement) d'un AVI segmenté par la fenêtre «  VirtualDub Job Control » 
par la touche de fonction F4 puis appui sur le bouton Start.

SAUVEGARDE  DIFFÉRÉE  D 'UNE  SÉQUENCE  D ' IMAGES

File > Queue batch operation > Save image sequence

Activation de la sauvegarde (ou enregistrement) d'une séquence d'images «  VirtualDub Job Control » par la 
touche de fonction F4 puis appui sur le bouton Start.

SAUVEGARDE  DIFFÉRÉE  DU  SON  AU  FORMAT  WAV
File > Queue batch operation > Save WAV

Activation de la sauvegarde (ou enregistrement) de l'audio au format WAV «  VirtualDub Job Control » par la 
touche de fonction F4 puis appui sur le bouton Start.

EXPORT  DIFFÉRÉ  DU  SON  AU  FORMAT  RAW (FORMAT  BRUT)
File > Queue batch operation > Export raw audio

Activation de l'export de l'audio au format RAW «  VirtualDub Job Control » par la touche de fonction F4 puis 
appui sur le bouton Start.

INFORMATI ONS  SUR  LE  FICHIER

File > File information 

Voir « Fichiers vidéo ( vidéo seule ou vidéo + audio) » page 80.
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DÉFINIR  LES  INFORMATIONS  TEXTE

File > Set text information 

Permet d'ajouter des informations sur le fichier qui seront visible lors d'une sauvegarde ou enregistrement :

Éviter les caractères accentués dans le champ « Field » car ils ne seront pas 
visualisés correctement sur des systèmes dont la langue sera différente.

Résultat (caractéristiques du fichier sauvegardé via l'explorateur Windows) :
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SAUVEGARDE  DU  SON  AU  FORMAT  WAV
File > Save WAV 

Sauvegarde ou enregistre le son de la vidéo au format WAV.

CHARGER  LES  PARAMÈTRES  DU  TRAITEMENT

File > Load processing settings ou raccourci Ctrl+L 

Charger un fichier de traitement au format .vcf  (VirtualDub configuration). Ce fichier est un fichier texte.

 

SAUVEGARDER  LES PARAMÈTRES  DU  TRAITEMENT

File > Save processing settings ou raccourci Ctrl+S  

Sauvegarder un fichier de traitement au format .vcf  (VirtualDub configuration). Ce fichier est un fichier texte :

LANCER  LE  SERVEUR  D ' IMAGES

File > Start frame server 

Démarre le serveur d'images de Virtualdub, informations page  http://www.virtualdub.org/docs_frameserver.html 

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Aide de VirtualDub - Traitement: Frameserver
La fonction frameserver permet aux autres programmes d'extraire la vidéo directement à partir du pipeline de  

restitution de VirtualDub. Ce qui permet à la vidéo d'être filtrée via VirtualDub puis d'être traitée par une autre  
application sans avoir à écrire un fichier intermédiaire sur le disque.

Démarrer le frameserver
Le frameserver est intégré à VirtualDub et accessible via la commande de menu File > Start frame server . Cette  

commande lance un frameserver dans le système avec la vidéo et les réglages du filtrage actuellement chargés.  
Après le lancement du frameserver, les autres applications peuvent s'y connecter.

http://philou-traductions.fr/
http://www.virtualdub.org/docs_frameserver.html
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Toutes les fonctions de VirtualDub ne fonctionnent pas avec le frameserver actif. Les fonctions de traitement  
suivantes fonctionnent:

• La plupart des filtres vidéo. 

• Le réglage de la fréquence d'images vidéo. 

• La conversion de la fréquence d'images vidéo. 

• La sélection d'une plage et la liste d'édition. 

Les fonctions suivantes sont désactivées lorsque le frameserver est actif:

• Les filtres vidéo qui ont un décalage - plus particulièrement le lissage temporel. Le filtre fonctionnera,  
mais il y aura un délai dans la vidéo. 

• La compression vidéo. 

• Le télécinéma inverse (3:2 pulldown removal). 

• La compression audio. 

• Les filtres audio. 

• La conversion audio. 

• L'ajustement du volume audio. 

• Les entrelacements audio (la plupart ne sont pas applicables). 

La vidéo est toujours envoyée à partir du frameserver au format 24-bit RGB pour une compatibilité maximum.

Quand le frameserver est lancé, VirtualDub vous demande un nom à utiliser pour le nouveau frameserver, ainsi  
que d'enregistrer un fichier signpost. Le nom est utilisé pour distinguer les frameservers du système; le fichier  
signpost indique au pilote client à quel frameserver se connecter. Le fichier signpost, qui utilise normalement  
l'extension de nom de fichier .vdr, est utilisé comme entrée pour l'application cliente et contient le nom du  
frameserver.

Remarque  : Bien que le nom du frameserver contienne le nom de l'ordinateur, les connexions à travers le réseau  
ne sont pas actuellement prises en charge. 

Connecter une application cliente via le pilote AVIFile
Le meilleur moyen de connecter un client au frameserver de VirtualDub est d'utiliser le pilote AVIFile. AVIFile  

est une ancienne API de programmation sous Windows qui permet aux programmes d'extraire l'audio et la vidéo  
de fichiers multimédias, comme AVI. Comme il est extensible, VirtualDub compose avec le pilote AVIFile qui  
étend de tels programmes pour lire leurs données directement à partir du frameserver plutôt que d'un fichier du  
disque.

Remarque  Il peut être souvent difficile ou impossible de dire si l'application utilise les API de AVIFile pour lire  
les fichiers multimédias, s'il y a compatibilité avec la méthode de connexion; la seule façon de l'affirmer est  
d'essayer. Cependant, cette méthode est très similaire à la méthode de connexion utilisée par l'outil de traitement  
vidéo inscriptible Avisynth, de sorte que les applications compatibles Avisynth fonctionneront aussi avec le  
frameserver de VirtualDub. 

Pour installer le frameserver, utilisez le programme auxsetup.exe  fourni avec VirtualDub. Le pilote sera alors  
copié dans le dossier système de Windows et une entrée sera ajoutée à la Base de Registre de Windows pour
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activer son utilisation dans AVIFile. Cet outil peut aussi être utilisé pour supprimer le pilote. Sous Windows  
NT/2000/XP, vous devez avoir les droits administrateur local pour installer ou désinstaller le pilote AVIFile.

Une fois le pilote AVIFile installé, les applications basées sur AVIFile pourront se connecter au frameserver en  
ouvrant simplement le fichier .vdr créé lors du démarrage du frameserver. VirtualDub peut lui-même le faire, et  
ouvrir une seconde instance est un moyen de tester la connexion au frameserver.

Après la connexion d'une application et son démarrage de la récupération des données audio et vidéo, la totalité  
de l'activité du frameserver évoluera à mesure que les données sont transférées.

Installer le pilote AVIFile en mode proxy
Certaines applications qui utilisent l'API de AVIFile ne peuvent toujours pas utiliser le frameserver car elles  

nécessitent l'extension du nom de fichier .avi ou sinon elles empêchent l'utilisation des pilotes non AVI. Dans ce  
cas, l'activation d'un mode spécial du pilote AVIFile de VirtualDub nommé mode proxy peut aider. Pour ce faire,  
installez le fichier \aviproxy\proxyon.reg fourni avec VirtualDub; ce qui ajoutera d'autres entrées à la Base de  
Registre de Windows pour remapper l'entrée AVI. Utilisez le fichier \aviproxy\proxyoff.reg pour annuler ceci. Lire  
le fichier \aviproxy\reademe.txt 

Remarque  Le mode proxy fonctionne en forçant tous les fichiers AVI via le pilote de VirtualDub. Bien que des  
tentatives aient été faites pour assurer une compatibilité maximum, certaines applications peuvent ne pas  
fonctionner correctement si le mode proxy est activé. Il est conseillé d'activer le mode proxy que si c'est  
nécessaire pour utiliser le frameserver, et de le désactiver dans les autres cas. 

Une fois le mode proxy activé, renommer le fichier signpost .vdr pour utiliser l'extension de nom de fichier .avi 
permettra à d'autres applications de fonctionner.

Comme bonus supplémentaire, lorsque le mode proxy est activé, le pilote AVIFile passera par tout fichier qui  
débute par les neuf caractères #avisynth via l'outil de traitement vidéo inscriptible Avisynth. Les comptabilités  
supplémentaires déverrouillées par le mode proxy sont celles qui s'étendent aussi à Avisynth.

Installer et utiliser le frameserver et le frameclient 64-bit
Utiliser le frameserver et le frameclient avec des programmes 64-bit, y compris la version 64-bit de VirtualDub,  

nécessite des procédures spéciales.

La version 32-bit de VirtualDub, et les bibliothèques frameserver/frameclient 32-bit fonctionneront sans  
modification sous Windows Edition x64. Cependant, le frameserving avec les programmes 64-bit impliqués  
nécessite l'installation des versions 64-bit des bibliothèques frameserver/frameclient. Pour ce faire, vous devez  
suivre des étapes manuelles:

Copiez vdsvrlnk64.dll et vdremote64.dll dans le dossier Windows\System32. 

Installez le correctif frameserver64.reg dans le Base de Registre.

Quand c'est fait, les programmes 64-bit peuvent interagir avec le système frameserver. Ce qui inclut le  
croisement des données entre les applications 32-bit et 64-bit. En plus du frameserving entre les applications 64-
bit, il est également possible l'utiliser depuis VirtualDub 64-bit vers une application 32-bit, et inversement. 
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CAPTURE VIDÉO  FORMAT  AVI
File > Capture AVI 

Passe VirtualDub en mode capture, voir chapitre « Le mode capture vidéo » page 62.

Pour sortir du mode capture : File > Exit capture mode .  

LANCER  UN  SCRIPT

File > Run script 

Lance un script aux  formats                                                         

Voir la chapitre « Le langage de scripts de Virtualdub » page 151.

CENTRE  DE  GESTION  DES TÂCHES DIFFÉRÉES

File > Job control ou raccourci touche de fonction F4  

OK = Sortie

Monter

Descendre

Différer

Supprimer

Recharger

Démarrage auto.

Démarrer

Abandonner
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Dans cette fenêtre nous retrouvons tous les travaux en attente. Les boutons du côté droit permettent différentes 
actions sur le travail sélectionné : 

• Monter  le travail sélectionné.

• Descendre  le travail sélectionné.

• Différer  le travail sélectionné.

• Supprimer  le travail sélectionné.

• Démarrer  le travail sélectionné.

• Abandonner  le travail en cours.

•

Le menu «     File     » de la fenêtre «     VirtualDub Job Control     » permet :  

• Charger une liste des tâches : File > Load job list

• Sauvegarder ou enregistrer une liste des tâches : File > Save job list

• Utiliser une liste locale des tâches : File > Use local job list

• Utiliser une liste partagée des tâches : File > Use shared job list

Les fichiers des tâches sauvegardées (.jobs) sont des fichiers texte, exemple :

Le menu «     Edit     » de la fenêtre «     VirtualDub Job Control     » permet :  

• Vider la liste : Edit > Clear list

• Effacer les tâches effectuées : Edit > Delete completed jobs

• Tout en attente => Reporté : Edit > All Waiting => Postponed

• Tout reporté => En attente : Edit > All Postponed => Waiting

• Tout effectué => En attente : Edit > All Done => Waiting

• Tout échoué => En attente : Edit > All Failed => Waiting

• Chois du répertoire de traitement : Edit > Process Directory
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Quand tout est terminé, le menu «     Options     » de la fenêtre «     VirtualDub Job Control     » permet un choix parmi ces   
4 options:

• Ne rien faire quand tout est terminé : Options > When Finished > Do Nothing   

• Mettre en veille quand tout est terminé : Options > When Finished > Sleep   

• Éteindre quand tout est terminé : Options > When Finished > Shut down   

• Mettre en veille prolongée quand tout est terminé : Options > When Finished > Hibernate   

LE MENU EDIT (ÉDITION)

Ce menu est très classique et on y trouve :

• Annuler : Edit > Undo ou Ctrl+Z

• Répéter : Edit > Redo ou Ctrl+Y

• Couper : Edit > Cut ou Ctrl+X

• Copier : Edit > Copy ou Ctrl+C

• Coller : Edit > Paste ou Ctrl+V

• Supprimer : Edit > Delete ou touche Suppr

• Vider la sélection : Edit > Clear selection ou Ctrl+D

• Tout sélectionner : Edit > Select all ou Ctrl+A

• Couper et retenir que la sélection : Edit > Crop to selection

• Indiquer le début de la sélection en fonction de la position du 
curseur, identique au bouton              : Edit > Set selection start 
ou touche Début

• Indiquer la fin de la sélection en fonction de la position du 
curseur, identique au bouton              : Edit > Set selection start 
ou touche Fin  

• Masquer les images de la sélection : Edit > Mask selected frames 

• Afficher les images de la sélection : Edit > Unmask selected frames

• Annuler toutes les modifications : Edit > Revert all edits  
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LE MENU V IEW (AFFICHAGE)
On retrouve dans ce menu toutes les options d'affichage de Virtualdub.

• Activation ou désactivation de l'affichage du curseur, de la ligne de temps, des boutons, de l'indicateur de 
position : View > Position control 

•  Activation ou désactivation de l'affichage de la barre d'états au bas de la fenêtre : View > Status bar 

• Activation ou désactivation de l'affichage de l'éditeur de courbes   (utile pour régler l'opacité en continu avec les 
filtres vidéo en validant avec le bouton   Blend     voir page 136)  : View > Curve editor 

• Activation ou désactivation de l'affichage de(s) piste(s) audio au dessous de la visualisation vidéo : View > 
Audio Display    

• Valider la possibilité d'afficher uniquement la vidéo en entrée : View > Pane layout > Input pane only       

• Valider la possibilité d'afficher uniquement la vidéo filtrée de sortie : View > Pane layout > Output pane only 

• Valider la possibilité d'afficher les vidéos en entrée et en sortie : View > Pane layout > Both panes     

• Adapter l'affichage des vidéos aux dimensions de la fenêtre VirtualDub : View > Pane layout > Auto-size 
panes       

• Valider l''affichage de la vidéo en entrée : View > Input video pane ou raccourci touche F9   

• Valider l''affichage de la vidéo filtrée en sortie : View > Output video pane ou raccourci touche F10  

• Positionner les fenêtres d'affichage entrée et sortie vidéo verticalement : View > Arrange video panes vertically

• Permuter (inverser) les positions des fenêtres d'affichage entrée et sortie vidéo : View > Swap input/output 
panes     

• Afficher la vidéo décompressée en sortie : View > Display decompressed output ou raccourci Maj+F10

• Afficher la fenêtre de statut : View > Shoe status window   

• Afficher le compte-rendu : View > Log ou raccourci F8  
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•  Afficher le « profiler » temps réel : 
View > Real time profiler ou raccourci 
Maj+F8 

LE MENU GO (ALLER À)
Ce menu permet de se déplacer rapidement dans la 

vidéo.

• Aller au début : Go > Beginning ou raccourci 
Ctrl+Gauche 

• Aller à la fin : Go > End ou raccourci Ctrl+Droite 

• Aller à l'image précédente : Go > Prev frame ou 
raccourci Gauche 

• Aller à l'image suivante : Go > Next frame ou 
raccourci Droite 

• Aller à l'image clef précédente : Go > Prev keyframe 
ou raccourci Maj+Gauche 

• Aller à l'image clef suivante : Go > Next keyframe ou 
raccourci Maj+Droite 

• Reculer de 50 images : Go > Back 50 frames ou 
raccourci Alt+Gauche 

• Avancer de 50 images : Go > Foward 50 frames ou 
raccourci Page Suivante 

• Aller à l'image perdue précédente : Go > Prev drop 
frame ou raccourci Maj+Accent circonflexe 

• Aller à l'image perdue suivante : Go > Next drop 
frame ou raccourci Maj+Cédille 

• Aller à la séquence précédente : Go > Prev range ou raccourci Maj+, 

• Aller à la séquence suivante : Go > Next range ou raccourci Maj+. 

• Aller au début de la sélection : Go > Selection start ou raccourci Accent circonflexe 

• Aller à la fin de la sélection : Go > Selection end ou raccourci Cédille 

• Aller à la scène précédente : Go > Prev scene ou raccourci 
Ctrl+Maj+Gauche 

• Aller à la scène suivante : Go > Next scene ou raccourci 
Ctrl+Maj+Droite 

• Aller à l'image xxx  : Go > Go to frame ou raccourci Ctrl+G 
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LE MENU V IDEO

C'est à partir de ce menu que se feront les traitements de la vidéo : Mode de traitement, application de filtre(s), 
sélection des codecs de compression pour la sauvegarde ou enregistrement, choix du débit (nombre d'images par 
seconde), codage des couleurs, etc. 

ACTIVER  UN  OU  PLUSIEURS  FILTRES  VIDÉO

Les filtres permettent de modifier le rendu d'une vidéo : ajouter du flou (blur) , recadrer, retourner (flip, rotate), 
modifier les dimensions (resize), ajouter un texte ou un logo, modifier les couleurs (convert, colors, levels...), 
modifier la luminosité et les contrastes (brightness/contrasts), désentrelacer (deinterlace), estamper (emboss), 
donner de la perspective, etc.

Les effets des filtres sont décrits au chapitre « Les filtres vidéo » page 87.

Pour mieux voir l'effet des filtres il est possible de :

– Faire un clic droit sur les vidéos entrée et sortie et de choisir différents paramètres d'affichage.

– De redimensionner directement les fenêtres avec la souris (clic gauche maintenu enfoncé sur le coin droit 
inférieur bas et déplacement de la souris).

– D'utiliser les options du menu View (Affichage).

Pour accéder au menu des filtres (Filters) faire : Video > Filters ou raccourci Ctrl+F , cette fenêtre s'affiche (ici 
avec un filtre grayscale déjà activé) :

         Entrée                 Sortie                                Filtre(s)

OK

Annuler

Ajouter un filtre

Supprimer un filtre

Monter un filtre

Descendre un filtre

Rogner

Configurer un filtre

Mélanger filtre+courbe
(voir page 136)

Afficher format d'image     Afficher rapport dimensions      Afficher débit en images par seconde

Voir aide CHM de VirtualDub  au chapitre Processing > Video filters > Video filter reference. 
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Le bouton Add :

Pour ajouter un filtre, appuyer sur le bouton « Add ».

La fenêtre « Add Filter » des filtres vidéo s'affiche. Les filtres marqués « internal » sont fournis avec VirtualDub, 
les autres sont ajoutés (voir paragraphe « Filtres VirtualDub ajoutés » page 11     ).  Une courte description du filtre 
est au bas de la fenêtre. Lorsque le filtre est choisi, appuyer sur le bouton OK. Souvent une fenêtre de paramétrage 
s'affiche avec un bouton de prévisualisation (Show preview). Pour faire varier l'effet du filtre dans le temps voir 
page 136. 

Le bouton Cropping (rogner) :  

Pour « cadrer » l'effet du filtre sur 
une partie de la fenêtre de 
visualisation (on découpe la partie 
que l'on souhaite conservée), appuyer 
sur le bouton « Cropping ». La fenêtre 
« Filter input cropping » s'affiche.

Il suffit de régler la partie que l'on 
souhaite conservée, ici la partie haute 
à gauche, en déplaçant les « lignes de 
découpe » avec la souris par exemple, 
ou en modifiant toutes les valeurs X 
et Y.

Le découpage paramétré, valider par 
le bouton OK.

Image : Charline Labonté

http://fr.wikipedia.org/wiki/Charline_Labont%C3%A9
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DÉBIT DE  LA  VIDÉO  EN  IMAGES  PAR SECONDES

Pour modifier le débit de la vidéo faire : Video > Frame Rate ou raccourci Ctrl+R , cette fenêtre s'affiche :

Pour l'utilisation, un exemple (Modification de la durée de l'animation) est donné page 143. 

CODAGE  DES COULEURS

Pour modifier le mode de codage des couleurs faire : Video > Color depth , cette fenêtre s'affiche :
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La fenêtre est en deux parties :

– Le côté gauche correspond au codage de l'entrée.

– Le côté droit correspond au codage de la sortie.

Voir aide CHM de VirtualDub  au chapitre Dialogs > Video color depth. 

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Sélectionnez les formats d'image désiré pour la décompression vidéo et la compression vidéo.

Format de décompression (Decompression format) 
Sélectionnez un format de couleur cible lors de la décompression de la vidéo entrante.

Pour une source compressée, ce format est requis directement à partir du codec vidéo. "Autoselect" choisira un 
format RGB répandu et sûr, comme le RGB 24-bit, 32-bit, ou 16-bit.

Pour une source non compressée (ou un script Avisynth), le format souhaité est produit via la conversion de  
l'image s'il n'est pas le même que la source. Les conversions YcbCr vers YCbCr ne circulent pas en rond via le  
RGB. "Autoselect" choisit le format source de telle sorte qu'aucune conversion ne soit nécessaire.

Si le codec vidéo ne peut pas produire le format sélectionné, VirtualDub tentera automatiquement de rétrograder  
le format vidéo pour un format similaire pris en charge. Par exemple, si le 16-bit RGB échoue, le 24-bit RGB sera  
tenté. Le code de retrait en cas d'échec évite les conversions des espaces de couleurs si possible; si un format  
YCbCr échoue, les autres formats YCbCr seront testés avant d'avoir recours au RGB.

Format de sortie (Output format to compressor/display) 
Choisissez un format de couleur pour la sortie. Au cours de la prévisualisation, c'est le format diffusé vers les  

fenêtres de visualisation. Si la compression vidéo est active, ceci sélectionne le format reçu par le compresseur  
vidéo.

Le format de sortie est produit par la conversion du format d'entrée. Si les filtres vidéo sont utilisés, le format  
d'entrée est converti en 32-bit RGB, traité, et le résultat converti au format de sortie. Si les filtres vidéo ne sont  
pas utilisés, le format d'entrée est converti directement au format de sortie.

Remarques :

Comme en standard pour les bitmaps GDI, le format 32-bit possède un canal alpha factice, utilisé  
seulement pour remplissage. Actuellement VirtualDub ne peut pas cibler un format 32-bit avec alpha  
étendu. 

La taille du format de sortie ne rend pas nécessairement compte si la compression de sortie via le  
codec vidéo s'effectue correctement. Par exemple, la conversion de 24-bit RGB en 16-bit RGB peut  
entraver la compression car elle augmente le bruit de quantification (effet de bande) de l'image. 

Description des formats
16-bit RGB (555) 

Il s'agit d'un format comprenant cinq bits par canal (32 niveaux) pour chacun des rouge, vert et bleu.  
C'est un format d'une précision relativement basse et sujet à certains artéfacts d'effets de bande, mais  
qui est courant pour les anciens matériels vidéo, car il est plus rapide et consomme moins de mémoire  
que le 24-bit RGB. Ce format est parfois connu sous le nom de HiColor. 

http://en.wikipedia.org/wiki/Highcolor
http://fr.wikipedia.org/wiki/Quantification_(signal)
http://philou-traductions.fr/
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16-bit RGB (565) 

Il s'agit d'une version légèrement améliorée du 16-bit RGB (555), car il utilise les bits inutilisés pour  
améliorer la précision du vert. 

24-bit RGB (888) 

Il s'agit d'un format comprenant huit bits par canal (256 niveaux) pour chacun des rouge, vert et  
bleu. Il est courant pour les images photographiques et est souvent connu sous le nom de Couleurs  
Vraies (ou TrueColor). Il s'agit du format le plus sûr et le plus fiable à utiliser pour l'échange vidéo. 

32-bit RGB (8888) (canal alpha factice) 

Similaire au 24-bit RGB, mais il possède huit bits supplémentaires inutilisés par pixel. La qualité des  
images est identique au 24-bit, mais le remplissage supplémentaire fait que la taille conviendra mieux  
pour le calcul. Ce format est parfois légèrement plus rapide que le 24-bit pour le traitement, mais est à  
éviter pour le stockage car il gaspille un tiers d'espace en plus. 

4:2:2 YCbCr (UYVY) 

Il s'agit d'un format qui utilise l'espace de couleur YCbCr (luminance, bleu chromatique, rouge  
chromatique), et qui se rapproche le plus de la façon dont les images couleur sont perçues par le  
cerveau humain. Il ne prend en moyenne que 16 bits par pixel avec une qualité de perception similaire  
au 24-bit RGB en n'enregistrant les informations de couleur qu'à la moitié de la résolution  
horizontale, ne prenant que les deux tiers de l'espace. 

Ce format, comme le font tous les autres formats YCbCr énumérés ci-dessous, encode la luminance  
(Y) selon une plage de [16, 235] et la chrominance (Cb/Cr, ou U/V) selon une plage de [16, 240]. 

UYVY est accepté directement par beaucoup de codecs vidéo. Du fait que beaucoup de codecs vidéo  
utilisent en interne les espaces de couleurs similaires au YCbCr, l'utilisation de ce format avec les  
codecs vidéo peut accélérer la restitution.

4:2:2 YCbCr (YUY2) 

Même chose que le 4:2:2 YCbCr (UYVY), mais pour un mélange des octets de données. Il offre les  
mêmes avantages de qualité et de performance que le UYVY. 

4:2:0 YCbCr uni (YV12) 

Il s'agit d'un format YCbCr avec une moyenne de 12 bits par pixel et une demi résolution horizontale  
et verticale dans les informations de couleur. Ce qui fait qu'il occupe 25% d'espace en moins que le  
UYVY ou le YUY2, mais présente un certain débordement vertical. "Uni" fait référence à  
l'organisation des données dans le format, avec séparation des stockages luminance, bleu chromatique  
et rouge chromatique. 

Certains codecs acceptent ce format directement pour une amélioration de la performance au-delà  
des formats 4:2:2. Il est cependant à éviter pour la vidéo entrelacée, où la perte de résolution de  
couleur verticale peut entraîner des artéfacts de mouvements entre les champs. Bien que les formats  
4:2:0 YCbCr existent, pour accommoder l'entrelacement, le code YV12 à quatre caractères  
(FOURCC) dénote un encodage 4:2:0 spécifique non entrelacé.

4:2:2 YCbCr uni (YV16) 

Il s'agit d'un format YCbCr avec une moyenne de 16 bits par pixel et d'une demi résolution  
horizontale dans les informations de couleur. 

Le format YV16 est rare et n'est pas bien pris en charge par les codecs vidéo et les applications de  
lecture, mais il est pris en charge par VirtualDub dans un soucis de complétude.
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4:1:0 YCbCr uni (YVU9) 

Il s'agit d'un format YCbCr avec une moyenne de 9 bits par pixel et d'une résolution horizontale et  
verticale dans les informations de couleur. YVU9 occupe ainsi 43% d'espace en moins que le  
UYVY/YUY2 et 62% d'espace en moins que le 24-bit RGB, mais au prix d'un débordement de couleurs.  

Luminance uniquement (Y8) 

Le Y8 est un format monochrome, et sa sélection entraînera la conversion de la vidéo en échelles de  
gris. Il ne nécessite cependant que la moitié de l'espace du UYVY ou du YUY2 à 8 bits par pixel. 

Le Y8 utilise la même échelle de luminance que le YCbCr, 16-240, avec une très faible perte de  
précision de luminance par rapport au 24-bit RGB. Par contre, la conversion entre le Y8 et le YCbCr  
est sans perte en luminance et extrêmement rapide.

COMPRESSION  VIDÉO ,  CHOIX  DES CODECS

Pour modifier le mode de codage des couleurs faire : Video > Compression ou raccourci Ctrl+P, cette fenêtre 
s'affiche :

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Utiliser la compression vidéo
La vidéo brute est très volumineuse et consomme beaucoup d'espace disque, et la compression vidéo est donc  

normalement utilisée pour réduire la taille du fichier vidéo. Pour activer la compression vidéo, le mode vidéo doit  
être défini sous un autre mode que celui de la copie directe du flux, un codec doit être choisi dans la boîte de  
dialogue « Select video compression ». Ce codec est alors utilisé pour compresser la vidéo.

Il existe deux types de compression vidéo, avec perte et sans perte. Une compression sans perte signifie que la  
vidéo compressée est exactement de la même qualité que l'originale, car la compression sans perte supprime des  
portions moins importantes de la vidéo pour en réduire la taille. L'avantage de la compression sans perte est  
qu'elle préserve la vidéo de façon précise; la compression avec perte réduit un peu la qualité, mais produit  
normalement une meilleure compression. Normalement, un codec sans perte ne compressera la vidéo que dans la  
proportion 3:1, alors que le codec avec perte peut atteindre 100:1.

http://philou-traductions.fr/
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Lors d'une création vidéo intermédiaire(vidéo en plusieurs passes), préférez utiliser la compression vidéo sans  
perte ou la compression vidéo qui permet son édition, c'est-à-dire l'image clé seule et la qualité la plus élevée en  
fonction du taux de compression. Il est préférable de travailler sur une vidéo de qualité supérieure et d'attendre la  
fin pour appliquer le codec vidéo final selon le taux de compression souhaité. Par exemple, vous pourriez utiliser  
une vidéo compressée 720x480 avec DV au cours de la production, et au dernier passage, la réduire à 320x240 et  
encoder avec un codec de base MPEG-4.

Pensez que pour que les vidéos que vous créez puissent être lues, un codec vidéo doit être présent pour les  
décompresser. Par exemple, si vous utiliser Huffyuv pour encoder, le destinataire de la vidéo doit posséder le  
Huffyuv ou autre codec compatible pour lire la vidéo. Il est ainsi préférable de rester sur des codecs vidéo qui  
sont installés sur la plupart des systèmes ou qui sont faciles à obtenir. Vous pouvez aussi utiliser un outil externe  
pour encoder en MPEG, lisible sur la plupart des systèmes modernes, même ceux qui ne tournent pas sous  
Microsoft Windows.

Si vous possédez un matériel vidéo fourni avec un codec vidéo, les films que vous aurez créés par son  
intermédiaire ne seront vraisemblablement pas lisibles par ceux qui ne possèdent pas le même matériel. Par  
exemple, si vous utilisez une carte vidéo FooBar pour capturer une vidéo au format FooBar Motion, seuls ceux  
qui possèdent une carte vidéo FooBar pourront la lire. Le vendeur du matériel met peut-être à disposition un  
décodeur logiciel téléchargeable sur son site web et utilisable pour ceux qui ne possèdent pas ce matériel sur leur  
système.

Bouton Configure :

Ce bouton donne accès au paramètres du codec vidéo, par exemple le codec x264vfw ou le codec XviD :

Le site x264vfw : http://sourceforge.net/projects/x264vfw/files/    

Plus d'informations sur le codec XviD à :  http://www.divx-digest.com/articles/xvid_setup.html 

http://www.divx-digest.com/articles/xvid_setup.html
http://sourceforge.net/projects/x264vfw/files/
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Option Force Keyframe every xxx frames :

Permet de forcer la création d'images clef toutes les xxx images.

Option Use target data data rate of yyy kilobytes/second :

Permet de forcer le débit à yyy Kilobytes par seconde

Curseur Quality :

Permet d'ajuster la qualité de la compression sur certains codecs.

Bouton About :

Donne dans certains cas les informations sur le codec sélectionné.

Bouton OK :

Valide les options choisies.

SÉLECTION D 'UN INTERVALLE  DE LA VIDÉO

Pour modifier le mode de codage des couleurs faire : Video > Select range, cette fenêtre s'affiche :

La sélection est identique à la méthode de la page 20.

Début [temps en ms] ou [N° d'image]

Longueur [temps en ms] ou [N° d'image]

Fin de la séquence [temps en ms] ou [N° d'image]

Adapter l'audio pour maintenir la synchronisation audio/vidéo

Couper le flux audio lorsque le flux vidéo se termine
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COPIE DIRECTE  DU  FLUX  (P IPEL INE  VIDÉO)
Pour activer ou désactiver le mode « Copie directe du flux » faire : Video > Direct stream copy. 

  Voir aide CHM de VirtualDub  au chapitre Dialogs > Video filters > The pipeline. 

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Sous ce mode, les images vidéo sont copiées directement de la source à la destination. Aucune recompression  
n'est utilisée, ce qui fait qu'aucune perte de qualité ne peut se produire. C'est la mode le plus rapide possible pour  
éditer une vidéo avec VirtualDub.

Du fait que la vidéo n'est pas recompressée, la compression vidéo impose des restrictions sur la façon dont elle  
peut être éditée.

RE-COMPRESSION  RAPIDE  (P IPEL INE  VIDÉO)
Pour activer la « Re-compression rapide » faire : Video > Fast recompress. 

  Voir aide CHM de VirtualDub  au chapitre Dialogs > Video filters > The pipeline. 

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Re-compression rapide: La vidéo est décompressée puis recompressée à l'aide du codec de sortie souhaité.  
VirtualDub choisit automatiquement un format vidéo intermédiaire à utiliser parmi les codecs pour le critère  
qualité et la vitesse.

Un codec vidéo de sortie doit être choisi dans ce mode.

RE-COMPRESSION  NORMALE  (P IPEL INE  VIDÉO)
Pour activer la « Re-compression normale » faire : Video > Normal recompress. 

  Voir aide CHM de VirtualDub  au chapitre Dialogs > Video filters > The pipeline. 

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

La vidéo est décompressée puis recompressée à l'aide du codec de sortie souhaité. Ce qui ressemble à Fast  
recompress (Re-compression rapide) sauf que les formats d'entrée et de sortie peuvent être choisis dans la boîte  
de dialogue Color depth (Codage des couleurs), et que les deux peuvent être différents, nécessitant une conversion  
entre les deux.

Si aucun codec vidéo d'entrée n'est choisi, la vidéo est écrite sur le disque au format de sortie non compressé.

TRAITEMENT  COMPLET  (P IPEL INE  VIDÉO)
Pour activer  le mode « Traitement complet » faire : Video > Full processins mode. 

Toutes les phases et fonctions du pipeline sont activées.

  Voir aide CHM de VirtualDub  au chapitre Dialogs > Video filters > The pipeline. 

P IPEL INE  VIDÉO

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Le traitement audio et vidéo de VirtualDub au cours d'une opération de restitution sur le disque est fractionné en  
plusieurs phases de pipeline. Certaines de ces phases sont activées ou désactivées en fonction du mode  
audio/vidéo actuellement sélectionné.

http://philou-traductions.fr/
http://philou-traductions.fr/
http://philou-traductions.fr/
http://philou-traductions.fr/
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Voici à quoi ressemble le pipeline vidéo:

Direct Re-compression Traitement complet 
Séquençage d'images 

Lecture d'image 
Décompression d'image 

Télécinéma inverse 
Conversion en 32-bit RGB  
Exécution des filtres vidéo 

 
Conversion au format de 

sortie  
Compression d'image 

Écriture de la vidéo 
Voici ce que font les différentes phases du tableau ci-dessus :

Séquençage d'images 
Les images vidéo (frames) sont sélectionnées depuis les sources et classées. C'est ici que prennent place toutes  

les éditions effectuées sur la ligne des temps, en parallèle avec les options de fréquence d'images, incluant le  
réglage des fréquence, conversion et décimation.

Si le mode direct est sélectionné , certaines restrictions existent comme la façon dont les images peuvent être  
insérées ou supprimées. Toute édition de la ligne des temps qui viole ces restrictions est réglée ici pour  
conformité.

Lecture d'image 

Les images (frames) vidéo sont lues à partir du disque.

Décompression d'image  
Les images vidéo (frames) compressées sont exécutées via un codec vidéo pour produire des images vidéo non  

compressées. Le format est sélectionné dans la boîte de dialogue Color depth.

En mode Fast recompress (Re-compression rapide), le format est automatiquement sélectionné en fonction de la  
compatibilité entre les codecs d'entrée et de sortie.

Par défaut, toutes les images vides ("perdues") de la source sont simplement dupliquées ici. Ce comportement  
peut être modifié via l'option Video > Preserve empty frames, ce qui entrainera la copie directe de chaque image  
vide directement à la sortie, peu importe la chaîne du filtre vidéo ou le codec de sortie. Ce qui est utile si  
l'échantillonnage du flux vidéo a été remplacé par une fréquence d'image supérieure en utilisant des images vides.  

Télécinéma inverse 
Si le Télécinéma Inverse (3:2 pulldown removal) est activé dans Frame Rate (Contrôle de la fréquence d'images  

de la vidéo), les champs sont réorganisés et la fréquence d'images du flux vidéo est réduite de 25%.

Conversion en 32-bit RGB 
Les filtres vidéo de VirtualDub s'exécutent en principe en 32-bit RGB, et les images vidéo sont donc converties  

en 32-bit RGB .

http://en.wikipedia.org/wiki/Telecine
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Remarque : Dans les précédentes versions de VirtualDub, l'activation du mode de traitement complet forçait  
toujours la conversion en 32-bit RGB. Ce qui n'est plus le cas - si aucun filtre vidéo n'est utilisé, cette phase de  
conversion est ignorée et la vidéo est convertie directement au format de sortie comme dans le mode  Normal  
recompress (Recompression normale). 

  

Exécution des filtres vidéo 

Tous les filtres vidéo sont exécutés.

Conversion au format de sortie 
Les images vidéo (frames) sont converties depuis leur format actuel dans le format de sortie spécifié dans la  

boîte de dialogue Color depth. Si les formats sont les mêmes, aucune conversion n'aura lieu.

Les conversions entre les formats YCbCr sont effectués directement dans l'espace YCbCr sans étape RGB  
intermédiaire. La saturation est sous-échantillonnée ou sur-échantillonnée si nécessaire à l'aide du filtrage bi-
linéaire.

Compression d'image  
Si un codec de compression vidéo est sélectionné, il est alors utilisé pour compresser l'image vidéo.

Écriture de la vidéo 
L'image vidéo est écrit maintenant sur le disque.

RENDU  INTELLIGENT

Pour activer ou désactiver  le « Rendu intelligente » faire : Video > Smart rendering. 

  Voir aide CHM de VirtualDub  au chapitre Dialogs > Video filters > Smart rendering. 

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Que fait le rendu intelligent?
Le rendu intelligent essaie d'identifier les portions d'un flux vidéo qui sont à ré-encoder et qui peuvent être  

copiées mot pour mot à partir du fichier source. Ce qui peut économiser beaucoup de temps, car seules les  
régions proches d'une édition sont à ré-encoder. Il conserve aussi la qualité de la plupart des vidéos non éditées.

Comme exemple, prenons cette édition :

 K              K              K              K             

Les images rouges indiquent les images qui sont sensés être gardées, mais qui ne peuvent pas être conservées  
sous leur forme originale du fait de leurs dépendances qui ne peuvent pas être supprimées. Sans les précédentes, il  
est impossible de décoder ces images miroir avant l'image clef suivante. Normalement, quand le mode copie de  
flux direct est utilisé, VirtualDub ajoute les deux images précédentes après, dans le fichier de sortie pour  
satisfaire les restrictions de la compression vidéo.

Le rendu intelligent ré-encode de préférence les images affectées. Il en résulte qu'en échange d'une faible  
dégradation de ces trois images, l'édition se produit à l'emplacement précis désiré et le reste des images reste  
intact.

http://philou-traductions.fr/
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Configuration nécessaire pour le rendu intelligent
L'utilisation du rendu intelligent nécessite ce qui suit :

• La vidéo doit être compressée. 

• Un codec vidéo doit être installé pour pouvoir produire le même format que celui de la source. Notez  
que certains codecs vidéo peuvent décoder davantage de formats qu'ils ne peuvent encoder, ce qui  
signifie que vous devez pouvoir ouvrir un fichier vidéo à l'aide de ce codec, et l'encoder avec ce même  
codec, mais ne pas encoder au même format que la source. 

• Le télécinéma inversé doit être désactivé. 

De plus, le codec vidéo doit être configuré pour correspondre à la source. Il existe souvent des paramètres dans  
la boîte de dialogue de configuration du codec auquel VirtualDub ne peut pas accéder et qui peuvent affecter  
l'encodage de façon incompatible. En cas de doute, essayez de faire correspondre la source; ce qui comprend les  
paramètres comme l'encodage B-frame, le packed bitstream, et l'espace de couleur. Par exemple, avec Huffyuv, le  
mode prédiction doit correspondre.

Si le codec vidéo utilisé propose une option pour le rendu multi-passes, elle doit être désactivée pour le rendu  
intelligent.

Filtrer la vidéo lors du rendu intelligent
Pour utiliser les filtres vidéo lorsque le rendu intelligent est actif, tous les filtres vidéo doivent être réglés de  

façon appropriée à l'aide des courbes d'opacité. Toutes les images dont les filtres ont une opacité supérieure à  
zéro seront soumises à la reconversion.

Toute instance de filtre vidéo qui ne présente pas de courbe d'opacité liée forcera le rendu de toutes les images,  
car tous les images doivent être traitées. Comme les filtres qui changent la taille des images ne peuvent pas  
posséder de courbe d'opacité, tout changement de taille de la liste des filtres rejettera le rendu intelligent.

Mises en garde pour le rendu intelligent
Notez que tous les codecs vidéo fonctionneront avec le rendu intelligent, même s'ils fonctionnent normalement  

pour l"encodage régulier. Si vous pouver encoder deux vidéos avec le même codec vidéo, et que vous pouvez lire  
le résultat après les avoir unies, le fonctionnement du rendu intelligent sera plus vraisemblable. Il n'y a  
généralement aucun problème avec les algorithmes de compression vidéo qui utilisent les images delta; Motion  
JPEG, par exemple, doit fonctionner sans problème.

La qualité au point de jonction peut être un problème. Le codec vidéo ne sait pas que VirtualDub l'utilise pour le  
rendu intelligent des transitions, et peut donc ne pas être capable de bien faire correspondre la qualité aux images  
copiées. Ce qui est surtout un problème avec les traitements courts car le codec peut avoir besoin de quelques  
images pour "atteindre" la fréquence d'images. Si cela se produit, pensez à réduire la fréquence d'images lors de  
l'utilisation du rendu intelligent.

Détails techniques
lorsque le rendu intelligent est actif, VirtualDub essaie de copier toutes les images mot pour mot; dès qu'il  

détecte une violation dans les dépendances des images, il ignore la recompression des images et continue à faire  
ainsi jusqu'à l'image clef suivante à partir de laquelle il reprend la copie directe. La recompression des segments  
nécessaires est effectuée par "démarrage à chaud" du codec vidéo pour chaque segment; du point de vue du codec  
vidéo, chaque plage à recompresser représente une vidéo distincte. Les sections copiées et ré-encodées sont alors  
réunies sans heurt au cours du processus de sortie.
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PRÉSERVER  LES  IMAGES  VIDES

Pour activer ou désactiver « Préserver les images vides » faire : Video > Preserve empty frames. 

Voir « Décompression d'image 3 » page  46. 

COPIER  L ' IMAGE  SOURCE  DANS LE PRESSE-PAPIERS

Pour copier l'image source faire : Video > Copy source frame to clipboard ou raccourci Ctrl+1 

COPIER  L ' IMAGE  FILTRÉE  DE  SORTIE  DANS LE PRESSE-PAPIERS

Pour copier l'image filtrée de sortie faire : Video > Copy output frame to clipboard ou raccourci Ctrl+2

SCANNER  LE  FLUX  VIDÉO  POUR  VÉRIFIER  LES  ERREURS

Pour démarrer la vérification faire : Video > Scan video stream for errors. 

LE  MODE  D 'ERREUR

Pour choisir un des 3 modes de rapport d'erreur faire : Video > Error mode. 

Rapporter toutes les erreurs

Cacher les erreurs et reprendre à l'image clef suivante

Décoder même si le résultat peut être détérioré

Remarque : Certaines erreurs ne peuvent pas être 
cachées ou ignorées incluant, entre autre, le plantage 
dû à un pilote externe.

Sauvegarder comme choix par défaut

http://fr.wikipedia.org/wiki/Plantage
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LE MENU AUDIO

C'est à partir de ce menu que se feront les traitements sur la bande sonore.

ENTRELACEMENT

Pour activer ces paramètres faire : Audio > Interleaving ou raccourci Ctrl+I 

  Voir aide CHM de VirtualDub  au chapitre Dialogs > Audio Interleaving. 

Enable audio/video interleaving : Si cette option est sélectionnée, les blocs audio sont entrelacés entre les trames 
vidéo dans le fichier, sinon l'audio est placé à la fin.

Preload xxx ms : À quel point est placé le début du fichier audio avant la première image vidéo, en millisecondes. 
Les valeurs usuelles sont 500ms ou 1000 ms . Si ce paramètre est mal ajusté, le son ne sera pas correctement 
diffusé sur les ordinateurs ou périphériques lents. Sur les ordinateurs récents, c'est moins un problème.

Interleave audio every xxx : Contrôle la manière dont l'audio est reparti.  Les valeurs habituelles pour cette option 
sont une fois par trame (1 frame) ou toutes les demi-seconde (500ms).

Audio skew correction (Delay audio track by xxx ms) : Ce n'est pas vraiment une option d'entrelacement, cette 
option touche la synchronisation audio. Ce décalage en ms déplace essentiellement la piste audio d'avant en 
arrière, que ce soit en laissant tomber des échantillons audio à partir du début ou en ajoutant des échantillons au 
départ (zéro pour le PCM, en double pour le premier échantillon audio compressés). Utilisez cette option pour 
transférer une piste audio en place si elle semble désynchronisée.
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COMPRESSION  AUDIO ,  CHOIX  DES CODECS

Pour activer la compression audio faire : Audio > Compression.

La fenêtre « Select audio compression » s'affiche :

Ici le codage de l'audio se fait en MP3, en stéréo avec la meilleure qualité (320 kbps). Valider par OK.

Une mauvaise compression audio occasionne des problèmes. ADCPM qui utilise des grands blocs limite les 
ajustements. MP3 utilisé dans un AVI a un « hack » dans son format qui empêche les applications de voir la 
"vraie" taille de bloc du format. Le résultat peut être mauvais au début du flux MP3 selon le lecteur utilisé. 
L'utilisation d'un éditeur audio spécialement conçu pour modifier le flux MPEG audio spécifique est nécessaire 
dans ce cas.

Deux formats performants associables avec les vidéos

• MP3   : Petits fichiers, utilise peu de ressource,  son stéreo/prologic.

• AC3 Dolby Digital   : Gros fichiers, canaux 5.1, bonne qualité du rendu, nécessite un décodeur (carte 
son et ordi. rapide) avec toutes les sorties vers les haut-parleurs pour obtenir le meilleur rendu.

À propos de l'encodage audio : http://forum.doom9.org/forumdisplay.php?f=11  
 http://www.virtualdub.org/blog/pivot/entry.php?id=16 

http://www.virtualdub.org/blog/pivot/entry.php?id=16
http://forum.doom9.org/forumdisplay.php?f=11
http://fr.wikipedia.org/wiki/Dolby_Digital
http://fr.wikipedia.org/wiki/MPEG-1/2_Audio_Layer_3
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UTIL ISER LE FILTRAGE  AVANCÉ

Pour valider ou pas le filtrage avancé pour l'audio faire : Audio > Use advanced filtering pour autoriser ou pas 
l'utilisation des filtres audio.

Si cette option n'est pas validée, utiliser  Audio > Audio conversion et  Audio > Volume.

F I LTRES

Pour activer un ou plusieurs filtres audio faire : Audio > Filters. 

  Voir aide CHM de VirtualDub, rechercher  Audio filter reference et consulter le chapitre Dialogs > Audio filters. 

  

Le choix des filtres est similaire au choix des filtres vidéo mais la mise en œuvre est totalement différente, elle se 
fait d'une manière graphique en connectant des entrées à gauche et des sorties à droite (un peu à la façon d'un 
schéma électrique ou des logiciels de création audio Pure Data ou Max ).

http://fr.wikipedia.org/wiki/Max/MSP
http://puredata.info/
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Exemple d'un schéma avec un filtre passe-bas (coupe les sons supérieurs à la valeur de paramétrage donnée en 
hertz) et un réglage de volume.

OK

Annuler

Effacer

Ajouter

Supprimer

Tester

Classer

Configurer

La connexion entre les « boîtes » se fait par clic. Il faut une boîte d'entrée (  input  ) et de sortie (  output  ) pour faire   
des tests (bouton Test). Pour configurer les filtres il faut faire un double clic sur les boîtes ( ici lowpass ou gain).

Auto-connect : Connecte ou pas les boîtes au fur et à mesure de l'addition des filtres.

Auto-arrange : Arrange automatiquement ou pas la représentation du schéma.

Les effets des filtres sont décrits au chapitre « Les filtres audio » page 82.

Remarque : Pour que les filtres soient disponibles il faut que Use advanced filtering et Full procesing mode soient 
validés dans le menu Audio.
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CONVERSION

Pour choisir les paramètres de conversion audio 
faire : Audio > Conversion ou raccourci Ctrl+N.

 Voir aide CHM de VirtualDub au chapitre 
Dialogs > Audio conversion. 

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

La boîte de dialogue  Audio Conversion permet la conversion entre différents formats audio PCM, y compris les  
modifications de la fréquence d'échantillonnage, de la Précision des échantillons (codage sur 8 ou 16 bits), et des  
Canaux.

Remarque : La conversion Audio n'est permise que si le filtrage avancé est désactivé  (Use advanced filtering). 
        Si le filtrage audio avancé est activé, utilisez le filtre resample. 

Conversions du taux d'échantillonnage (Sampling rate) 
Permet les changements des fréquences d'échantillonnage (ou taux) du flux audio, sans changer la hauteur de  

l'audio lui-même (rééchantillonnage). Vous pouvez sélectionner l'un des taux d'échantillonnage courants, ou  
personnaliser le rééchantillonnage à n'importe quel autre taux. Les taux d'échantillonnage les plus élevés  
représentent les fréquences les plus élevées et procurent un audio "brillant", mais consomment plus d'espace. 

Haute qualité (High quality)  : Fait basculer le filtre de rééchantillonnage du point d'échantillonnage à un filtre  
triangulaire pour une meilleure qualité. Ce qui réduit le crénelage, lequel génère du bruit ou un halo en sortie. 

Remarque :  Le convertisseur de taux d'échantillonnage contrôlé par cette boîte de dialogue est plutôt ancien et  
pas de très haute qualité pour les standards actuels. Le filtre   resample   (page   85  ) introduit dans VirtualDub 1.5   
utilise un filtre windowed-sinc 65-point et procure une meilleure qualité que le filtre ayant cours ici. Il est destiné  
à remplacer ce rééchantillonneur comme rééchantillonneur principal dans une prochaine version. 

Précision 
Contrôle la fidélité des échantillons audio.L'échantillon 8-bit ne prend que moitié moins de place que le 16-bit,  

mais ne peut restituer de sons en douceur avec précision et présente un bruit de fond plus élevé. Remarque  Le 8-
bit ne devrait être utilisé que si vous devez procurez un PCM non compressé à un autre programme pour lequel il  
est nécessaire, ou que vous ne changez pas le PCM 8-bit existant. Sinon, choisissez instinctivement le 16-bit. Les  
codecs audio modernes fonctionnent sous des représentations audio différentes, comme les subbands ou cosines,  
et la compression n'est pas meilleure avec une source 8-bit que 16-bit. 

http://philou-traductions.fr/
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VOLUME

Pour régler le volume audio faire : Audio > Volume si Use advanced filtering n'est pas activé.

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Permet les ajustements du volume audio, pour augmenter ou diminuer le son.

Remarques :  VirtualDub rogne fermement lors de l'amplification audio, et trop forcer sur le volume aura ainsi  
pour conséquence une distorsion.

Il est plus facile d'augmenter un son bas que de le diminuer . Si la source audio est trop élevée  
elle sera rognée au cours de l'enregistrement, introduisant une distorsion, réduire le volume après coup  
n'éliminera donc  pas cette distorsion. D'autre part, amplifier un son bas amplifie aussi la quantification du bruit,  
qui est particulièrement mauvaise avec une source 8-bits. N'essayez pas d'ajuster le volume plus que nécessaire;  
c'est mieux d'enregistrer l'audio au bon volume dès le début. 

NO AUDIO

Pour ne pas valider l'audio faire : Audio > No audio.

SOURCE  AUDIO

Pour choisir la source des sons faire : Audio > Source audio.

IMPORTER  UN  FICHIER  AUDIO

Pour importer un fichier audio faire : Audio > Audio from other file.

COPIE DE  FLUX  DIRECT

Pour copier directement l'audio faire : Audio > Direct stream copy.

TRAITEMENT  COMPLET

Pour traiter l'audio faire : Audio > Full processing mode.

MODE  D 'ERREUR

Choisir le mode du report d'erreur par Audio > Error mode.

http://philou-traductions.fr/
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LE MENU OPTIONS

PERFORMANCE

Optimise la gestion de la mémoire tampon.

Accès par : Options > Performance  

Mémoire tampon sortie Avi.

VirtualDub utilisera xxx Mb de mémoire 
tampon pour la sortie.

Mémoire tampon d'entrée Wave.

VirtualDub utilisera xxx Kb de mémoire 
tampon.

Rendu.

Tampon vidéo xxx tampons

Tampon audio xxx secondes

COMPILATION  DYNAMIQUE

Accès par : Options > Dynamic compilation  

Autoriser la compilation dynamique.

Afficher le code généré.
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PRÉFÉRENCES

Accès par : Options > Preferences  

 Voir aide CHM de VirtualDub au chapitre Dialogs > Preferences. 

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Onglet Main (Principal) :
Output color depth (Profondeur de couleur en sortie) 

Sélectionnez la couleur par défaut pour l'affichage vidéo. Le 24-bit semble le mieux, mais le  
16-bit est généralement plus rapide. Ceci n'affecte pas le fichier de sortie. 

Process priority  (Niveau de priorité) 
Oblige VirtualDub à être plus ou moins prioritaire par rapport à d'autres applications lors  

du traitement des fichiers. VirtualDub utilisera toujours la période d'inoccupation du CPU par  
les autres programmes, mais vous pouvez utiliser ce réglage pour l'obliger à s'accaparer plus  
ou moins le CPU quand d'autres applications en ont aussi besoin. 

Automatically add extension to filenames when saving  (Ajouter automatiquement une  
extension lors de l'enregistrement des fichiers) 

Contrôle si l'extension du fichier (.avi) est ajoutée automatiquement quand vous entrez un  
nom de fichier dans la boîte de dialogue d'enregistrement. 

http://philou-traductions.fr/
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Onglet Display (Affichage). Aucune de ces options n'affecte la sortie du fichier :
Enable 16-bit dithering  (Activer la réduction des couleurs pour les bureaux 16-bit) 
Si cette option est activée, les images 24-bit seront réduites lorsque l'affichage en 16-bit pour  

réduire la bande passante, au détriment d'un peu de la vitesse. 

Use DirectX for display panes  (Utiliser DirectX pour les panneaux d'affichage )
Active l'affichage vidéo accéléré pour les fenêtres d'affichage. Il en résulte une meilleure  

performance d'affichage ainsi qu'un meilleur aspect, une image plus fluide (interpolée).  
Désactiver cette option est plus sûr mais ralentit le mécanisme d'affichage qui utilise la GDI  
de Windows pour la restitution des images vidéo. 

Use DirectX when Terminal Services is active  (Utiliser DirectX même quand le Terminal Service  
est actif )

Active l'affichage vidéo accélérée pour une session distante en utilisant le Terminal Service  
de Windows ou le Bureau Distant. Du fait de bogues apparents dans l'implémentation du  
Terminal Server, autoriser l'accélération DirectX dans ce mode peut entraîner un affichage  
systématiquement en haut à gauche du bureau, ce qui fait que VirtualDub désactive par défaut  
l'accélération quand il détecte une session distante. Ce qui est de toute façon plus rapide. 

Use Direct3D  (Utiliser Direct3D) 
Active l'API graphique 3D accéléré de Direct3D 9.0c pour afficher la vidéo. Ce qui permet  

l'utilisation des options de filtrage pour les fenêtres d'affichage pour choisir entre un  
échantillonnage point et un filtrage bilinéaire, et si le périphérique 3D est assez puissant, le  
filtrage bicubique. 

Use effect file  (Fichier d'effet) 
Active l'utilisation d'un fichier d'effets D3DX (.fx) pour définir des vertex shaders et des pixel  

shaders Direct3D personnalisés pour l'affichage vidéo. Ce qui nécessite une DLL système  
DirectX supplémentaire et une connaissance du format de fichier effets pour créer les effets  
souhaités. Consultez l'aide CHM de VirtualDub au chapitre  Video filters > Video display 
shader support pour en savoir plus. 

Use OpenGL  (Utiliser OpenGL) 
Active l'API graphique 3D accéléré d'OpenGL pour l'affichage vidéo. Ce qui permet  

l'utilisation des options de filtrage pour les fenêtres d'affichage pour choisir entre un  
échantillonnage point et un filtrage bilinéaire. Notez que l'utilisation d'OpenGL, lorsqu'un  
périphérique 3D n'est pas présent, peut entraîner une dégradation importante de la  
performance. 

Onglet Scene (Scène) :

Interframe (cut) and intraframe (fade) thresholds  (Seuils image inter [coupe] et image intra  
[effacement])

Contrôle la sensibilité des boutons de scène avant/arrière pour la barre de progression. Un  
"changement de scène" est détecté dès qu'il existe un changement significatif dans une image (coupe),  
ou une perte de détails de la scène au dessous d'un certain seuil (effacement ou fondu). 
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Onglet CPU :
Use default optimizations, or force specific optimizations  (Utiliser toutes les optimisations par  

défaut, ou uniquement certaines extensions) 
Par défaut, VirtualDub détecte automatiquement votre CPU et choisit les chemins de codes optimisés  

de façon appropriée. Si vous rencontrez des problèmes dus à une détection non correcte, vous pouvez  
forcer les chemins de codes spécifiques dans cet onglet. Notez que l'activation d'une optimisation non  
supportée par votre CPU entraînera un blocage ou une exécution non correcte. Remarque  Les codecs  
vidéo et audio effectuent leurs propres réglages CPU spécifiques, et ne sont pas contrôlables par ces  
paramètres. Si vous rencontrez des problèmes avec un codec qui ne détecte pas correctement votre  
CPU, il vous faudra contacter le fabricant du codec pour obtenir de l'aide. 

Onglet AVI :
Restrict legacy AVI support to 1 gigabyte  (Limiter l'indexation OpenDML à 1 Go) 
Les fichiers AVI étendus (AVI 2.0 ou AVI OpenDML) sont composés de deux parties: une portion AVI  

héritée, et des blocs AVI étendus. Cette option abaisse la limite de la portion de 2Go à 1Go, pour les  
applications qui ne peuvent pas manipuler les fichiers AVI entre 1 et 2Go, et peut être utile si vous  
avez exécuté des applications qui examinent les fichiers AVI et s'engorgent pour ceux qui sont  
volumineux. Ceci n'a aucun effet sur les programmes qui manipulent les fichiers AVI étendus. 

Do not correct MPEG layer III audio streams  (Désactiver l'auto-correction des flux audio MPEG  
layer III )

Certains codecs MP3 ne génèrent pas de flux MP3 exactement à la même fréquence que celle  
spécifiée pour leur format audio quand les taux d'échantillonnage à 44.1KHz sont utilisés -- ce qui  
crée un léger désaccord au niveau de la synchro audio d'environ 0.5%. Par défaut, VirtualDub  
recalcule le taux de données et corrige automatiquement l'en-tête audio quand la compression MP3  
est active. Cette option vous permet de désactiver la correction si elle entraîne des problèmes, comme  
un flux MP3 généré dans un format que VirtualDub ne peut pas analyser correctement. 

Directly decode YCbCr (YUV) sources  (Décoder directement les sources YCbCr [YUV]) 
Par défaut, VirtualDub décodera directement les flux vidéo AVI avec des formats YCbCr non  

compressés qu'il reconnaît, incluant UYVY, YUY2, YV16, YV12, I420, IYUV, Y41P, YVU9, Y8, et Y800,  
même si un codec vidéo externe pourrait être utilisé. Il peut en résulter une meilleure qualité du fait  
que VirtualDub utilise l'interpolation bilinéaire lors de l'échantillonnage chromatique. Désactiver  
cette option désactivera la prise en charge du décodage YCbCr et permettra l'utilisation des codecs  
vidéo pour manipuler de telles données. 

Align large uncompressed frames to sector boundary  (Aligner les grandes images non-
compressées sur les limites de secteur) 

Certains périphériques de lecture matériels au contenu autonome et de niveau professionnel  
atteignent des performances supérieures lorsqu'ils fonctionnent avec des AVI dont les cadres vidéo  
sont alignés avec les limites des secteurs du disque plutôt qu'un simple alignement à deux octets requis  
par le format AVI. Activer cette option implique l'utilisation de l'alignement sur les secteurs, au prix de  
fichiers AVI légèrement plus volumineux. L'alignement supplémentaire ne prend effet que si un format  
vidéo non compressé reconnu est utilisé et que la taille du cadre vidéo dépasse la taille limite  
spécifiée. 
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Onglet Timeline (Ligne Temporelle) :
Timeline format  (Format de la Timeline) 
Cette option permet de personnaliser les indicateurs de l'horodatage sur l'interface utilisateur  

principale de VirtualDub. Les spécificateurs de formatage - un % suivi d'une lettre - permettent le  
remplacement de différents éléments d'informations au sein d'une chaîne donnée. Les spécificateurs de  
formatage autorisés sont énumérés sous le champ d'édition de chaîne. 

Options de Render (rendu) :
Confirm when abort button is pressed  (Demander confirmation de l'Abandon) 
Si cette option est activée, vous devrez confirmer l'abandon d'une prévisualisation ou d'une opération  

d'enregistrement pour que cette annulation prenne effet. 

Options Threading (multi-tâche) :
Video compression threads  (Nombre de tâches de compression vidéo) 
Contrôle le nombre de tâches (threads) utilisés pour la compression vidéo; zéro désactive la  

compression vidéo multi-tâche. Consultez la rubrique Processing: Compression de l'aide CHM de 
Virtualdub pour en savoir plus.

AUTRES  OPTIONS

Les 4 options à valider :

Traduction
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LE MENU TOOLS (OUTILS)
Donne accès à différents outils comme :

• Un éditeur héxa.

• Créer un AVI fractionné.

• Assembler un AVI fractionné.

• Performances de l'échantillonneur.

• Créer un AVI palettisé.

• Créer une vidéo de tests.

LE MENU HELP (A IDE)
Donne accès à l'aide CHM ou par la touche de fonction F1.
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LE MODE CAPTURE VIDÉO (CAPTURE MODE)
L'information en anglais est donnée à la page http://www.virtualdub.org/docs_capture.html  

VirtualDub permet de capturer plusieurs types de vidéo :

– La copie d'écran.

– Des flux vidéo venant de sources extérieures comme des webcams, des cartes d'acquisition vidéo, etc.

Le mode « Capture vidéo » est une couche logicielle ajoutée à Virtualdub. Cette couche logicielle a sa propre 
interface, ses raccourcis. 

Pour accéder à ce mode faire File > Capture AVI à partir de la fenêtre Virtualdub, pour revenir au mode normal 
faire File > Exit capture mode à partir de la fenêtre « Capture mode ».

Remarque au sujet de la capture d'écran : 

Nous avons eu quelques difficultés à faire fonctionner la capture d'écran . Chez nous, sur deux ordinateurs 
équipés de Windows 7, il ne faut pas valider l'option   Use OpenGl hardware acceleration   dans Video > 
Source ou raccourci S lorsque Device > Screen capture est validé. 

http://fr.wikipedia.org/wiki/Webcam
http://www.virtualdub.org/docs_capture.html
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DÉFINITIONS

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr : 

La capture vidéo est le processus qui consiste à extraire la vidéo d'un source matérielle externe, comme une  
vidéo analogique, et à la numériser sous une forme utilisable par un ordinateur. VirtualDub permet l'utilisation de  
plusieurs catégories de matériel de capture vidéo pour effectuer cette conversion, délivrant le résultat sous la  
forme d'un fichier .avi sur le disque.

Ce dont vous avez besoin pour utiliser le mode capture vidéo de VirtualDub, il vous faut:

• Un périphérique de capture vidéo. 

• Une source vidéo externe.

Le mode de capture vidéo ne peut être utilisé pour capturer les flux vidéo d'un réseau ou d'images de votre  
propre machine locale (sauf à récupérer la TV dans un périphérique de capture vidéo).

CONFIGURATION  MATÉRIELLE

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr : 

Voici certains connecteurs que vous devriez avoir sur votre système:
• Entrée coaxiale de carte de capture d'entrée coaxiale: Un connecteur arrondi avec un petit orifice au centre  

qui reçoit les signaux audio modulés (canaux multiples). 

• Entrée composite de carte de capture: Un connecteur RCA avec un large orifice au centre. Ce connecteur  
reçoit une seule entrée vidéo sans audio. Le câble vidéo composite, ou la partie vidéo composite d'un câble  
pieuvre possède habituellement un connecteur jaune. 

• Entrée S-Video de carte de capture: Une prise ronde à quatre orifices et une fente rectangulaire (DIN-4). Ce  
connecteur reçoit une seule entrée vidéo sans audio, mais avec des informations de luminosité et de couleur  
séparées. Il en résulte une vidéo de qualité supérieure à l'entrée composite. Les câbles S-Video possèdent  
habituellement un connecteur noir. 

• Entrée ligne de carte de capture: Une mini prise mono ou stéréo dont la taille st d'environ 1/8". Il s'agit de  
l'entrée audio des entrées vidéo composite et S-Video. 

• Sortie ligne de carte de capture: Une mini prise mono ou stéréo dont la taille st d'environ 1/8". Il s'agit de la  
sortie audio d'une carte de capture. 

• Entrée ligne de carte son: Une troisième mini prise sonore. Il s'agit de l'entrée d'une carte son pour  
l'enregistrement. Avec les cartes son dont les entrées sont colorées, cette prise apparaît en bleu. 

Si vous possédez un périphérique de capture style tout en un qui traite la vidéo et l'audio, plus particulièrement  
sur port USB, la capture s'effectuera sans souci: il vous suffit de tout relier au périphérique de capture. Vous  
n'avez pas d'autre choix. Si vous possédez un "tuner TV", certains traitements de capture seront aussi effectués  
par la carte son, et vous devrez brancher deux câbles pour que tout fonctionne correctement.

Capture à partir d'un câble (entrée coaxiale)
Dans ce scénario, vous possédez une carte de capture de type tuner TV et vous souhaitez effectuer la capture  

d'un canal TV.

• Connectez le câble coaxial rond à la carte de capture. 

• Connectez la sortie de la carte de capture à l'entrée de la carte son. 

La carte tuner TV accepte l'entrée du câble, sélectionne et décode le canal désiré, capture la vidéo, et sépare  
l'audio pour être capturé par votre carte son. 

http://philou-traductions.fr/
http://philou-traductions.fr/


Débuter avec Virtualdub  -  Le mode capture vidéo (Capture mode)   -  jeudi 8 avril 2010  -  Page 64 / 181

Capture à partir de sorties audio/vidéo
Dans ce scénario, vous possédez une carte de capture de type tuner TV et vous souhaitez effectuer la capture  

d'un autre périphérique qui présente des sorties audio et vidéo distinctes, comme une console de jeu vidéo ou un  
VCR.

• Connectez la sortie vidéo composite ou S-Video à la même entrée vidéo de la carte de capture. 

• Connectez la sortie audio du périphérique de sortie à l'entrée de la carte de capture. 

• Connectez la sortie de la carte de capture à l'entrée de la carte son. 

Le problème que vous rencontrerez souvent ici est que le périphérique de sortie possédera une paire de  
connecteurs ronds RCA, un pour chaque canal stéréo gauche/droit (rouge et blanc), alors que la carte de capture  
et la carte son présenteront des entrées mini-stéréo 1/8". Un câble possédant une prise mâle 1/8" à l'une de ses  
extrémités avec des connecteurs mâles RCA stéréo à l'autre, ainsi qu'une paire d'adaptateurs femelles RCA vous  
aideront à gérer tous vos branchements.

Tout ceci suppose que vous ayez une carte de capture qui possède la capture audio intégrée. Si votre carte ne  
traite que la vidéo, il est préférable de connecter simplement la sortie audio directement à votre carte son:

• Connectez la sortie vidéo composite ou S-Video à la même entrée vidéo de la carte de capture. 

• Connectez la sortie audio du périphérique de sortie à l'entrée de la carte son. 

Ce qui court-circuite le chemin audio pour une meilleure qualité, et vous évite de vous soucier des réglages au  
bon niveau du mixer audio de la carte de capture ou de l'entrée adéquate.

SÉLECTION DES PILOTES

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr : 

Pour utiliser un périphérique matériel de capture vidéo, il vous faut un pilote de capture pour faire  
communiquer VirtualDub avec le matériel. Ce logiciel est fourni avec votre périphérique et doit être installé dans  
Windows à partir du package logiciel fourni. Si vous n'avez pas ce pilote, consultez le site web du vendeur ou  
contactez le service après vente pour un remplacement, sinon, vous ne pourrez pas utiliser votre matériel avec  
VirtualDub.

Tous les périphériques de capture détectés par VirtualDub sont affichés à la fin du menu   Device   (Périphérique) .   
La sélection de l'entrée d'un pilote entraîne l'arrêt du pilote de la capture en cours et le démarrage du nouveau  
pilote de capture.

Il existe deux types de pilotes de capture vidéo sous Windows, dont les possibilités de comportement sont  
différentes. Il est important de connaître le type de pilote de capture vidéo que vous avez installé car différents  
effets selon les fonctions de mode de capture de VirtualDub seront utilisables. VirtualDub peut utiliser des pilotes  
écrits selon un modèle de pilote.

Pilotes de capture Video for Windows (VFW)
Vidéo for Windows est l'API vidéo original pour Windows, et est le plus ancien des deux types de pilote. Ces  

pilotes peuvent parfois être trouvés sous des versions de Windows aussi anciennes que Windows 95, et il est même  
possible d'utiliser un pilote de capture écrit pour Windows 3.1 (qui n'est vraiment pas recommandé). Ces pilotes  
présentent plusieurs limitations : 

http://philou-traductions.fr/
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• La capture audio est toujours effectuée via la carte son, ou un pilote effectue la capture du chemin audio d'un  
périphérique de type carte son. 

• Les pilotes de type VFW proposent peu de réglages configurables; les réglages comme le contrôle audio, la  
sélection du canal, le standard vidéo, le paramétrage de l'image vidéo, etc. ne sont proposés que dans la  
propre boîte de dialogue du pilote lui-même. Ils sont accessibles via les commandes Affichage vidéo, Format  
vidéo, et Réglages vidéo du menu Vidéo. Malheureusement, cela signifie que VirtualDub ne peut pas  
enregistrer ou restaurer ces réglages, ou les contrôler directement. 

Un des avantages des pilotes de type VFW est qu'ils sont souvent matures et bien débogués, et donc fiables. Un  
autre avantage est que les pilotes VFW sont pris en charge par les API de capture VFW et DirectShow sous  
Windows, les rendant utilisables par une vaste variété d'applications de capture.

Les pilotes VFW peuvent être trouvés pour toutes les versions de Windows, depuis Windows 95 jusqu'à Windows  
XP. Cependant, à partir de Windows 2000, beaucoup de fabricants ont imposé leurs modèles de pilotes WDM.  
Quelques périphériques de capture vidéo prennent les deux en charge.

Un pilote de type VFW est identifiable par l'indicateur (VFW) après son entrée dans le menu Périphériques.

Pilotes de capture Windows Driver Model (WDM) (basés sur DirectShow)
Le type de pilote de capture vidéo le plus récent sous Windows utilise le Windows Driver Model (WDM),  

introduit sous Windows 98 et 2000. L'API DirectShow de Microsoft est la première API à utiliser ces pilotes. Du  
fait que l'API de DirectShow prend en charge une plus grande variété de commandes et de réglages que VFW, le  
jeu de fonctionnalité d'un pilote WDM est sensiblement amélioré :

• Les périphériques WDM peuvent initier directement des captures audio intégrées. 

• Presque tous les réglages proposés dans l'IU, comme la saturation vidéo, sont aussi proposés par voie de  
programme pour un contrôle sans surveillance. 

• S'il est disponible, VirtualDub peut contrôler directement le canal du tuner TV, ainsi que la sélection de la  
source audio/vidéo. 

DirectShow est cependant une API beaucoup plus complexe que VFW, et les pilotes de type WDM ont été  
historiquement beaucoup moins stables que leurs homologues VFW. Il n'est pas inhabituel de rencontrer des  
problèmes tels que des applications de capture qui ne peuvent pas être fermées, car l'exécution de leur  
programme est bloquée dans le pilote de capture. WDM est le modèle de pilote proscrit qui va de l'avant, et la  
situation devrait s'améliorer au fil du temps.

Un pilote WDM qui nécessite l'utilisation de DirectShow aura un indicateur (DirectShow) avec son entrée dans  
le menu Périphériques.

Les boîtes de dialogue Video display (Affichage vidéo), Video format (Format vidéo), et Video settings (Réglages  
vidéo) ne seront pas disponibles lorsque DirectShow est utilisé. Les réglages de ces boîtes de dialogue sont plutôt  
disponibles dans les boîtes de dialogue du pilote Pin de capture et Filtre de capture, sauf si un pilote Video for  
Windows (VFW) est utilisé par DirectShow; ces pilotes sont indiqués par (VFW > Directshow) près de leur nom  
dans le menu Périphériques. Utiliser un pilote de cette manière ajoute les limitations de DirectShow aux  
limitations de VFW, et il est ainsi préférable d'utiliser ces pilotes directement avec VFW.
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Le pilote de capture d'image Microsoft WDM (Win32)
Si vous possédez un pilote Windows Driver Model (WDM) installé, vous aurez aussi une entrée dans la liste des  

périphériques nommés Microsoft WDM Image Capture (Win32) (VFW). Cette entrée provient d'un pilote de  
Microsoft nommé VFWWDM32 et constitue un emballage permettant aux pilotes de type WDM d'être utilisés par  
les anciens API de Vidéo pour Windows (VFW). Le pilote WDM qui est adapté peut être sélectionné via la boîte  
de dialogue du pilote Source Vidéo.

Il existe cependant certaines excentricités dans la façon dont cet adaptateur fonctionne, et certains périphériques  
de capture vidéo fonctionneront de façon imprévisible ou pas du tout. Les réglages du périphérique non  
accessibles par VFW ne le seront pas davantage lors de son utilisation. Si possible, utilisez le périphérique de  
capture directement dans le mode DirectShow plutôt que d'utiliser le pilote VFWWDM32.

Pilotes personnalisés
Quelques fabricants ont des difficultés à faire migrer leurs pilotes de capture depuis les versions Windows  

95/98/ME relativement complaisantes, vers les nouvelles versions plus strictes de Windows sur la base du noyau  
NT. Au lieu d'utiliser un pilote VFW ou WDM adéquat - les deux sont utilisables sous NT/2000/XP - ces fabricants  
utilisent un pilote maison avec une application de capture spécifique au matériel. Ces périphériques de capture ne  
sont malheureusement pas utilisables avec VirtualDub car ils utilisent une interface de programmation  
propriétaire (API).

Le pilote d'émulation vidéo
Le pilote de capture Fichier vidéo (émulation) n'est pas un vrai pilote de capture installé sous Windows, mais un  

mini pilote de capture vidéo interne à VirtualDub utilisé pour les tests. Il accepte un fichier vidéo, sélectionné à  
l'aide de la commande de menu Source vidéo, et lit cette vidéo, imaginant qu'il s'agit d'une source vidéo directe  
poussant les données audio et vidéo à partir de ce fichier. Bien qu'utile à l'origine au développement du  
programme VirtualDub, il est aussi parfois utile pour diagnostiquer les problèmes de compatibilité et déterminer  
si ceux-ci sont liés à VirtualDub ou au pilote de capture vidéo.

Notez qu'une charge supplémentaire est ajoutée au disque dur et au CPU par le décodage vidéo, et ce pilote n'est  
donc pas vraiment utile pour tester la performance.
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LE MENU F ICHIER (F ILE) DE CAPTURE MODE

COORDONNÉES  DU  FICHIER  DE  CAPTURE

File > Set capture file ou raccourci touche de fonction F2  

Indiquer l'emplacement et le nom du fichier vidéo qui sera capturé.

Lorsque cette option est validée, 
le nom (ici test_capture.avi) et 
l'emplacement du fichier de 
capture seront mémorisés.

INDIQUER  LE SYSTÈME  DE  STRIP ING

File > Set striping system 

ALLOUER  DE  L 'ESPACE  DISQUE

File > Allocate disk space 

Détermine le volume maximal réservé en Mb
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ID DU  FICHIER  PRÉCÉDENT

File > Previoud file ID ou raccourci touche  [  

ID DU  FICHIER  SUIVANT

File > Next file ID ou raccourci touche  ]  

QUITTER  LE MODE  CAPTURE

File > Exit capture mode  

LE MENU PÉRIPHÉRIQUE  (DEVICE) DE CAPTURE  MODE

PARAMÈTRES  DU  PÉRIPHÉRIQUE

Device > Device settings       

Enregistrer le mode d'affichage actuel comme mode par défaut

Changer de source audio lors d'un changement de source vidéo

Désactiver l'affichage de l'entrelacement pendant l'affichage des menus

Désactiver l'affichage de la prévisualisation pendant l'affichage des menus

TUNER

Device > Tuner channel       

SOURCE  DU  TUNER

Device > Tuner input mode       

CHOIX  DES  PÉRIPHÉRIQUES

Selon la configuration de l'ordinateur les différents périphériques apparaitront. Il suffit de sélectionner celui que 
nous voulons capturer. Pour ne rien sélectionner ou se déconnecter, valider Device > Disconnect      
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LE MENU V IDEO DE CAPTURE  MODE

On retrouve dans ce menu toutes les options concernant la vidéo. Ces options peuvent varier selon le 
périphérique.

NE PAS  AFFICHER  
Video > No display    

RECOUVREMENT  
Video > Overlay ou raccourci O

PRÉVISUALISATION  
Video > Preview ou raccourci P

ACCÉLÉRATION  DE  LA  PRÉVISUALISATION  
Video > Preview acceleration  > choix d'une des 9 options.

ÉTIRER  À LA TAILLE DE  LA  FENÊTRE  
Video > Stretch to window 

H ISTOGRAMME  
Video > Histogram ou raccourci H 

SOURCE  VIDÉO  
Video > Video source 
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FORMAT

 Video > Format ou raccourci F

SOURCE

 Video > Source ou raccourci S

Paramètres liés à la source vidéo.

AFFICHAGE  
Video > Display ou raccourci D 

P IN  DE  CAPTURE  
Video > Capture pin 

P IN  DE  PRÉVISUALISATION  
Video > Preview pin 

CONTRÔLE  DE  LA CAPTURE

Video > Capture Filter 

CROSSBAR

Video > Crossbar 

CROSSBAR2
Video > Crossbar2

TUNER

Video > Tuner 

N IVEAUX 
Video > Levels ou raccourci L

RECADRAGE  
Video > Cropping 

TRAMES  DE  REMPLACEMENT  
Video > Swap fields 
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RÉDUCTION  DU  BRUIT  
Video > Noise reduction 

RÉDUCTION  VERTICALE  
Video > Vertical reduction 

ÉTENDRE  LA LUMINANCE  DES NOIRS  
Video > Extend luma black point 

ÉTENDRE  LA LUMINANCE  DES BLANCS  
Video > Extend luma white point 

F I LTRAGE  RGB 
Video > Filter chain 

Validation ou pas des filtres vidéo à utiliser.

COMPRESSION

 Video > Compression ou raccourci C 

Choix des codecs de compression vidéo.

INDIQUER  UN  FORMAT  PERSONNALISÉ  
Video > Set custom format ou raccourci Maj+F 

Choix d'un format personnalisé
ici : 1920*1080
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OPTIMISATION  BT8X8
Video > BT8X8 Tweaker 

Voir DTV 2.1.2 pour récupérer les DLL :

http://sourceforge.net/projects/deinterlace/files/   

http://sourceforge.net/projects/deinterlace/files/dTV/2.1.2/dTV212exe.zip/download  

LE MENU AUDIO DE CAPTURE  MODE

ACTIVER  LA  CAPTURE  AUDIO

Audio > Enable audio capture  

ACTIVER  LA  LECTURE  AUDIO

Audio > Enable audio playback  

INSTRUMENT  DE  MASURE  DE  VOLUME

Audio > Volume meter  ou raccourci V  

CHOIX  DU  FORMAT  BRUT  AUDIO  (PCM)
Audio > Raw capture format  

Définition du format PCM ( Pulse Code Modulation) ou 
modulation d'impulsion codée :

http://fr.wikipedia.org/wiki/Modulation_d'impulsion_codée  

http://fr.wikipedia.org/wiki/Modulation_d'impulsion_cod%C3%A9e
http://sourceforge.net/projects/deinterlace/files/dTV/2.1.2/dTV212exe.zip/download
http://sourceforge.net/projects/deinterlace/files/


Débuter avec Virtualdub  -  Le mode capture vidéo (Capture mode)   -  jeudi 8 avril 2010  -  Page 73 / 181

CHOIX  DE  LA COMPRESSION  AUDIO

Audio > Compression  ou raccourci A  

FENÊTRES  DE  MIXAGE

Audio > Windows mixer  

CHOIX  DE  L 'ENTRÉE AUDIO

Audio > Audio input  

WAVE  MAPPER

Audio > Wave mapper  
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LE MENU CAPTURE DE CAPTURE MODE

CAPTURE V IDÉO

Capture > Capture video ou touche de fonction F5 , F6  

Appuyer sur le bouton OK pour commencer la capture

TESTER LA CAPTURE  VIDÉO

Capture > Test video capture ou touche de fonction F7  

ARRÊTER  LA CAPTURE  
Capture > Stop capture ou touche Échap  

PROFILER  TEMPS  RÉEL

Capture > Real-time profiler 

PARAMÈTRES

Capture > Settings ou touche de fonction F9  

Détermination du débit en images par seconde (Frame rate).



Débuter avec Virtualdub  -  Le mode capture vidéo (Capture mode)   -  jeudi 8 avril 2010  -  Page 75 / 181

PRÉFÉRENCES

Capture > Preferences ou touche de fonction F10 
Panneau latéral
Raccourcis
__________________
Images capturées
Temps total
Temps restant
Taille du fichier
Espace disque libre
Utilisation CPU
État multi-segment
Taille
Débit moyen
Débit vidéo
Rapport de compression
Taille moyenne
Images enlevées
Images ajoutées
Échantillonnage
Taille
Débit moyen
Débit relatif
Débit audio
Rapport de compression
Échantillonnage
Ajustement VT
Lattence relativement
Erreurs

CONDITIONS  D 'ARRÊT

Capture > Stop conditions 

Arrêt de la capture quand :

Le temps de capture est > à xxx secondes

Le volume du fichier est > à xxx Mb

L'espace libre sur le disque est < à xxx Mb

Les images perdues dépassent xxx %
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RESYNCHRONISATION

Capture > Timing 

E/S DU  DISQUE

Capture > Disk I/O 

PLEIN  ÉCRAN

Capture > Full screen ou raccourci Alt+Entrée  

MASQUER  LORS  DE  LA  CAPTURE

Capture > Hide display on capture 
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GROSSIR  L 'HEURE  ET LA DATE

Capture > Display large timer 

AFFICHER  LE  PANNEAU  D ' INFORMATI ONS

Capture > Show information panel 

AFFICHER  LA  BARRE  D 'ÉTATS

Capture > Show status bar 

GRAPHIQUE  DE  TEMPS

Capture > Timing graph 

RAPPORT

Capture > Log ou touche de fonction F8

PERMETTRE  LA  CAPTURE  EN  MULTI-SEGMENTS

Capture > Enable multisegment capture 

LANCER  LA  CAPTURE  LORS  D 'UN  CLIC  GAUCHE  DANS  LE  PANNEAU

Capture > Start capture on left-click in pane 

INCRÉMENTATION  AUTOMATIQUE  DU  NOM  DU  FICHIER  LORS  DE  LA CAPTURE

Capture > Autoincrement filename after capture 

ACTIVER  LE  RAPPORT  DE  TEMPS

Capture > Enable timing log  

LE MENU A IDE (HELP) DE CAPTURE MODE

Donne accès à l'aide CHM ou par la touche de fonction F1.
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LES PRINCIPAUX  FORMATS VIDÉO, AUDIO ET LES CÂBLES

Voici quelques éléments pour mieux situer les termes employés pour les vidéos, les TV numériques.

V IDÉO

Rapports largeur/hauteur des principaux formats : 

4/3 , 5/3 , 16/9 , 16/10 , Panoramique 1,85/1 , CinemaScope optique 2,39/1 

Affichage sur un écran 16/9 (source : http://fr.wikipedia.org/wiki/Format_de_projection ) 

Dans les formats suivants le chiffre désigne la hauteur de l'image en pixels et la lettre désigne le mode de 
balayage ou p = progressif et i = entrelacé.

HDMI = norme du transport numérique de la vidéo et du son entre 2 machines.

HDCP = Protection numérique pour les droits d'auteur.

Standard Résolution Caractéristiques
480p (4/3) 640*480 - 60 Hz EDTV (bas de gamme)
576p (4/3) 720*576 - 50 Hz EDTV (bas de gamme)
720p (16/9) 1280*720 (100%) HD-Ready
1080p (16/9) 1920*1080 (225%) Full HD / HDMI 1.0-1.2
1440p (16/9) 2560*1440 (400%) WQXGA / HDMI 1.3

Quelques autres formats :

640*360 (16/9)  

Matériel   240*376 (iPod Nano) / 320*240 (iPod Classic) / 480*320 (iPod Touch) / 800*480 (Nexus One)

Les formats de compression modernes :

H.264 ou MPEG-4 AVC (non libre) http://fr.wikipedia.org/wiki/H.264  

Theora (libre) http://www.theora.org/  

Dirac (libre) utilise la transformée en ondelettes discrète de 176*144 à 1920*1080  http://diracvideo.org/ 

VP8 (non libre – propriété de Google) http://www.on2.com/index.php?599  

http://www.on2.com/index.php?599
http://diracvideo.org/
http://fr.wikipedia.org/wiki/Transform%C3%A9e_en_ondelette_discr%C3%A8te
http://www.theora.org/
http://fr.wikipedia.org/wiki/H.264
http://fr.wikipedia.org/wiki/Format_de_projection
http://fr.wikipedia.org/wiki/Fichier:Format_Image_Television_Cinema.jpg
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SON

Codage Nombre de canaux
Stéréo 2
Dolby 2.1 3 (2 latéraux + 1 

subwoofer)
Dolby 5.1 6 (1 central+ 2 latéraux 

avant + 2 latéraux arrière 
+ 1 subwoofer)

Dolby digital (codec AC-3)

DTS 6 (signal moins comprimé 
que Dolby 5.1)

Digital Theater System 
Digital Surround

Dolby 7.1 8 ( 1 central + 2 latéraux 
avant + 2 surround milieu + 
2 latéraux arrière + 1 
subwoofer)

Dolby TrueHD

SDDS 6 (5+1) ou 8 (7+1) Sony Dynamic Digital Sound
THX Label de qualité Tom Holman eXperiment

LES CÂBLES (VIDÉO  ET SON) CHEZ  SOI

Les câbles sont les supports physiques qui relient plusieurs machines : Ordinateur, TV, décodeur, système de son, 
etc. Ils sont constitués de conducteurs électriques (cuivre, connecteurs dorés) ou de fibres optiques. Souvent les 
prix pratiqués dans les magasins sont très dispendieux et ne sont pas justifiés par des critères techniques. Ici, au 
Canada, nous achetons nos câbles chez Infinite Cables http://www.infinitecables.com/ où les prix sont compétitifs 
et la livraison par la poste rapide.

Il faut consulter les notices de ses appareils pour connaître les connecteurs utilisés qui définiront les câbles. Un 
principe est à retenir : plus le câble est court, plus les pertes sont faibles.

Quelques câbles et des liens pour les visualiser :

HDMI – HDMI pour relier 2 ports HDMI où transitent le son + la vidéo 
 http://www.infinitecables.com/mon_hdmi.html 

DVI – HDMI pour relier un port DVI à 1 port HDMI où transite la vidéo  
        http://www.infinitecables.com/mon_dvi-hdmi.html 

RCA – RCA audio pour le son stéréo                                           http://www.infinitecables.com/av_audio.html  

USB – USB Audio et/ou vidéo pour relier deux ports USB         http://www.infinitecables.com/usb_cbl.html  

Câbles optiques audio SPDIF   http://www.infinitecables.com/av_toslink.html  

http://www.infinitecables.com/av_toslink.html
http://www.infinitecables.com/usb_cbl.html
http://www.infinitecables.com/av_audio.html
http://www.infinitecables.com/mon_dvi-hdmi.html
http://www.infinitecables.com/mon_hdmi.html
http://www.infinitecables.com/
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TROUVER LES CARACTÉRISTIQUES DES FICHIERS VIDÉO ET AUDIO

F ICHIERS VIDÉO ( VIDÉO SEULE  OU VIDÉO + AUDIO)
Pour vérifier les caractéristiques lancer Virtualdub, ouvrir la vidéo par File > Open Video File  (ou utiliser le 

raccourci Ctrl+0) puis faire : File > File information

Une fenêtre s'affiche avec les caractéristiques, exemple :

     
Vidéo
Taille, nb débit images/secondes
Nb d'images, durée
Codec
Nb d'images clefs
Mini, moyenne, max, total, taille
Mini, moyenne, max, total, taille
Débit

Audio
Fréquence d'échantillonnage
Canaux
Précision échantillon
Codec
Layout
Nb échantillons, durée
Mini, moyenne, max, total, taille
Débit

La même fenêtre en français (1.9.6) »

La zone supérieure donne les 
caractéristiques de la partie vidéo et la 
zone inférieure les caractéristiques de 
l'audio. Sortir de la consultation par 
appui sur le bouton OK.
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F ICHIERS AUDIO

Virtualdub ne peut pas ouvrir directement un fichier audio et donner ses caractéristiques. Audacity (voir page 
169) permet d'obtenir ces données :

Métadonnées par Fichier > Ouvrir l'éditeur de 
métadonnées
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LES FILTRES AUDIO

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Le mode de filtre audio avancé de VirtualDub supporte un modèle de système de filtre, où vous pouvez lier des  
filtres selon des configurations de branchement complexes. Les filtres sont représentés par des nœuds  
rectangulaires sur le graphe; chaque nœud pouvant avoir des pins d'entrée du côté gauche et des pins de sortie du  
côté droit.

Ajouter ou supprimer des nœuds de filtres 
Pour ajouter des filtres, cliquez sur le bouton Add (Ajouter), ce qui ouvre une nouvelle boîte de dialogue « Add 

audio filter », affichant une liste des filtres disponibles. Dans cette fenêtre, cliquez sur un filtre (ici Input), puis sur 
Add pour ajouter le filtre au graphe, ou double-cliquez sur l'entrée du filtre. Cette boîte de dialogue restera  
ouverte jusqu'à ce que vous ayez fini d'ajouter des filtres et que vous la refermiez. Les nœuds de filtres ajoutés par  
erreur peuvent être supprimés en les sélectionnant et en cliquant sur le bouton Delete (Supprimer) ou en appuyant  
sur la touche Suppr. 

Connecter les nœuds de filtres 
Pour connecter les filtres ensembles, faites glisser le pin d'entrée d'un nœud vers le pin de sortie d'un autre (vous  

ne pouvez pas connecter deux pins d'entrée ou deux pins de sortie). Une flèche s'affichera montrant la connexion.  
Comme pour les nœuds, les connexions peuvent être sélectionnées et supprimées. Du fait que le processus est  
plutôt fastidieux, l'option connexion automatique (Auto-connect) est activée par défaut. La connexion automatique  
lie le premier pin de sortie inutilisé du filtre actuellement sélectionné au premier pin d'entrée du filtre  
nouvellement ajouté, et sélectionne alors le nouveau filtre. Les chaînes simples peuvent être générées simplement  
en ajoutant les filtres de façon séquentielle. 

http://philou-traductions.fr/
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Restrictions des graphes de filtres 
Les règles suivantes s'appliquent aux graphes de filtres audio: 

• Il doit y avoir exactement un seul nœud "source". 

• Il doit y avoir exactement un seul nœud de "sortie". 

• Tous les pins doivent être connectés. 

• Aucun cycle n'est permis, bien que le branchement parallèle soit permis. 

• Les chemins parallèles doivent s'exécuter à la même vitesse. 

• La dernière règle signifie que vous ne pouvez pas prendre un flux, le ralentir avec un "étirement", et le  
remixer avec lui-même. 

  Dand l'aide CHM de VirtualDub, rechercher  Audio filter reference.

BUTTERFLY  
Convertit les canaux vidéos entre gauche/droite et centré/latéral. 

Butterfly calcule la somme et la différence entre les canaux gauche et droit. Ce qui permet aux algorithmes stéréo  
d'être appliqués en mode centré/latéral . Par exemple, butterfly et gain peuvent être utilisés pour augmenter ou  
réduire la séparation stéréo. Bufferfly peut s'inverser et être utilisé pour basculer entre la représentation  
centrée/latérale. 

CENTER CUT 
Extrait un canal central d'un audio stéréo. 

Center cut utilise la phase d'analyse FFT pour deviner les sons du canal central, soustrait alors le canal pour  
produire les sorties gauche/droite et centrale. Du fait que le mixage de trois canaux arbitraire en deux est  
irréversible, cette séparation n'est pas parfaite et certains artefacts peuvent résulter de l'algorithme. 

CENTER MIX  
Mélange un flux mono à un flux stéréo.

 Le premier flux entrant doit être le flux stéréo, le second le mono. Les deux doivent posséder le  
même taux d'échantillonnage. 

DISCARD  
Vide un audio indésirable.

Puisque tous les pins d'un système de filtre audio doivent être connectés, utilisez le filtre discard 
pour vider toute sortie non voulue. 

 

GAIN 
Modifie le volume audio.

La sortie amplifiée ou atténuée est fortement saccadée, et forcer le gain d'un flux audio qui est déjà à plein  
volume au maximum entraînera une distorsion saccadée.  
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HIGHPASS  
Découpe les sons inférieurs à une fréquence donnée. 

Les filtres de haut niveau sont bons pour simuler les média de transmission métallique, comme une radio à deux  
voies. Ce filtre particulier utilise le filtre FIR 129-point; la bande de transition, la zone où le filtre s'accroît du  
gain zéro au gain complet, est d'environ 1.4KHz à un taux d'échantillonnage de 44KHz. Ce qui place quelques  
limites sur la façon dont le filtre de bas niveau se trouve effectivement dans des situations extrêmes. Par exemple,  
un filtre de bas niveau supprime tous les sons ayant zéro pour limite, mais ce filtre vous procurera un son  
assourdi jusqu'à environ 700Hz à un taux d'échantillonnage de 44KHz. 

INPUT 
Extrait l'audio d'une source AVI ou WAV. 

LOW PASS 
Découpe les sons au dessus d'une fréquence donnée. 

Les filtres de bas niveau sont bons pour éliminer les sifflements et autres bruits de haute fréquence. Ce filtre  
particulier utilise un filtre FIR 129-point; la bande de transition, la zone où le filtre se réduit du gain complet au  
gain zéro, est d'environ 1.4KHz à un taux d'échantillonnage de 44KHz. Ce qui place quelques limites sur la façon  
dont le filtre de bas niveau se trouve effectivement dans des situations extrêmes. Par exemple, un filtre de bas  
niveau supprime tous les sons ayant zéro pour limite, mais ce filtre vous procurera un son assourdi jusqu'à  
environ 700Hz à un taux d'échantillonnage de 44KHz. 

MIX  
Assemble des flux audio. 

Le mixage est une simple addition de découpages, et si vous combinez le mixage à un filtre de gain  
atténuant pour réduire le volume du post-mixage, le filtre de gain devra être le premier. Si une sortie a  
moins de canaux qu'un autre, le nombre inférieur N de canaux se trouvant entre les deux seront mixés,  
et les canaux restants seront traversés.

Vous ne pouvez pas mixer deux flux ayant des taux d'échantillonnage différents -- rééchantillonnez en un pour  
qu'il convienne à l'autre pour cela.

NEW RATE

Obtenir une nouvelle fréquence d'échantillonnage.

OUTPUT 
Provient d'un système à l'intérieur d'un fichier sortant. 

Vous en avez besoin d'un pour tout système de filtre audio. Il se déforme automatiquement dans un fichier  
sortant ou un filtre de restitution de façon appropriée. 
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PITCH SHIFT  
Modifie la hauteur de l'audio sans changer la vitesse.

Ratty pitch shift fonctionne en étirant ou réduisant ses entrées, en les découpant en petites sections, en les faisant  
ensuite se chevaucher et mixer. Ce qui altère les lancements audio sans en changer la vitesse; puisque la  
fréquence du spectre est étalonnée, les harmoniques sont préservées. Quand les pics s'élèvent, certaines portions  
d'audio sont dupliquées, et quand ils s'abaissent, certaines portions d'audio sont perdues. 

Ratty pitch shift essaie de décaler les segments voisins pour réduire les artefacts, mais occasionnellement vous  
pourrez entendre quelques hoquets, ou mesures dupliquées/manquantes. C'est la raison pour laquelle c'est  
énervant, mais c'est drôle de travailler avec. Le filtre est plus efficace à environ +/-10%.

Si vous combinez ratty pitch shift avec stretch et utilisez les mêmes proportions pour les deux, vous réduisez la  
durée, ce qui altère la vitesse de l'audio sans changer sa hauteur.

 

RATTY PITCH SHIFT 
Modifie la hauteur de l'audio sans changer la vitesse (ancien algorithme). 

Ratty pitch shift fonctionne en étirant ou réduisant ses entrées, en les découpant en petites sections, en les faisant  
ensuite se chevaucher et mixer. Ce qui altère les lancements audio sans en changer la vitesse; puisque la  
fréquence du spectre est étalonnée, les harmoniques sont préservées. Quand les pics s'élèvent, certaines portions  
d'audio sont dupliquées, et quand ils s'abaissent, certaines portions d'audio sont perdues. 

Ratty pitch shift essaie de décaler les segments voisins pour réduire les artefacts, mais occasionnellement vous  
pourrez entendre quelques hoquets, ou mesures dupliquées/manquantes. C'est la raison pour laquelle c'est  
énervant, mais c'est drôle de travailler avec. Le filtre est plus efficace à environ +/-10%.

Si vous combinez ratty pitch shift avec stretch et utilisez les mêmes proportions pour les deux, vous réduisez la  
durée, ce qui altère la vitesse de l'audio sans changer sa hauteur.

RESAMPLE  
Convertit l'audio en fréquences d'échantillonnage différentes. 

Ce filtre utilise le filtre 32-phase, le filtre 129-tap pour ré-échantillonner l'audio. La qualité est supérieure à  
l'option Audio | Conversion... et est préférable à une conversion entre taux d'échantillonnage. La bande de  
transition est de ~1.4KHz à un taux d'échantillonnage de 44KHz, et a pour résultat un fort abaissement  
d'échantillonnage, tel que 44KHz à 8KHz, ce qui peut entraîner un certain crénelage. Ce qui produit des sons un  
peu comme un halo. Vous pouvez réduire le crénelage en appliquant un filtre de bas niveau avec un raccourci  
~700Hz inférieur à la moitié de la source ou à la moitié du taux d'échantillonnage cible, celui qui est le plus bas.  
Cependant, le son sera quelque peu assourdi. 

SPLIT  
Coupe un flux audio en deux copies identiques. 

STÉRÉO  CHORUS  
Ajoute un effet de chœur.

 Stereo chorus mixe l'audio précédent avec lui-même avec un décalage variable de 24-26 ms, contrôlé par deux  
LFO à 3.3Hz décalés de 90°. Ce qui ajoute un peu de séparation stéréo au son.
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Vous utilisez le son mono ou stéréo en entrée stereo chorus; quand le mono est utilisé, il est d'abord dupliqué en  
canaux stéréo avant que le chœur soit ajouté.

STÉRÉO  MERGE  
Fusionne deux flux mono en un flux stéréo. 

Les deux flux doivent avoir le même taux d'échantillonnage. 

STÉRÉO  SPLIT  
Coupe un flux stéréo en deux flux mono. 

STRETCH  
Étire ou rétrécit l'audio, en modifiant longueur et hauteur.

 Cet effet est le même que celui que vous pourriez obtenir en lançant un enregistrement audio trop vite ou trop  
lentement . L'audio s'accélère et atteint le sommet, ou ralentit et devient maussade. 

Stretch utilise le ré-échantillonnage polyphasé ce qui n'introduit pas d'artefacts passagers; si vous n'avez besoin  
que de petits ajustements de longueur de piste audio, c'est la bonne méthode pour y parvenir. 

Remarque  : Stretch alimente sa sortie à un taux différent de la consommation du son d'entrée, du fait qu'il  
change la vitesse des flux audio. Les systèmes de filtres audio ne doivent jamais combiner deux branches qui  
tournent à des vitesses différentes. Le résultat serait une recherche instable ou un système de filtre se figeant.  
Soyez particulièrement vigilant avec cela quand vous créez des branches parallèles qui se fusionnent par la suite. 

TIME  STRETCH  
Étire ou contracte l'audio, en modifiant le longueur sans changer la hauteur.

Utilise l'étirement du temps pour qu'une piste audio s'exécute plus vite ou plus lentement, sans produire d'effet  
indésirable. Habituellement, cette fonction correspond à un changement le la vitesse vidéo tout en conservant la  
synchronisation entre les deux. Ce qui équivaut à combiner le décalage de hauteur aux filtres d'étirement, mais  
avec une qualité légèrement supérieure et une facilité d'utilisation.  
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LES FILTRES VIDÉO

Sur la fenêtre « Add filter », les filtres marqués « internal » sont fournis avec VirtualDub, les autres sont ajoutés 
(voir paragraphe « Filtres VirtualDub ajoutés » page 11) et repérés dans cette liste avec le caractère *. 

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Les filtres vidéo de VirtualDub sont organisés en chaîne linéaire, de telle sorte que la fin du premier filtre  
devienne le début du second, la fin du second le début du troisième, et ainsi de suite. Ainsi, l'ordre dans lequel ils  
sont énumérés correspond à l'ordre dans lequel ils sont appliqués. Par défaut, aucun filtre n'apparaît dans cette  
liste, ce qui signifie que le système de filtrage vidéo est entièrement ignoré.

Le mode de traitement vidéo doit être réglé sur «     Traitement Complet     »   Video   >   Full processing mode   pour que   
le système de filtrage vidéo soit activé. Si le traitement vidéo est réglé autrement, l'option de menu Video > Filters 
... sera grisée et la chaîne de filtrage vidéo désactivée.

Opérations de traitement vidéo courantes
VirtualDub contient un certain nombre de filtres vidéo internes qui facilitent un certain nombre de tâches de  

traitement vidéo courantes... Voici quelques techniques de filtrage utiles: 

• Le filtre Resize page 124     (redimensionnement) modifiera la résolution (taille) vidéo pour une valeur différente,  
en pixels. Il peut aussi être utilisé pour l'effet "boîte aux lettres" d'une vidéo en lui ajoutant une bordure. 

• Le filtre Levels page  112 (niveaux) est utile pour régler la luminosité et le contraste d'une vidéo, en  
particulier quand les noirs ne sont pas de vrais noirs, ou les blancs de vrais blancs. 

• Vous pouvez rogner au début de tout filtre en le sélectionnant et en utilisant le bouton Cropping. Si aucun filtre  
n'est présent, ajoutez simplement null transform page 121     (transformation nulle) pour vous procurer un  
emplacement de rognage (voir page 38). 

• Le filtre Temporal smoother page 131     (lissage temporel) peut être efficace pour supprimer le bruit d'une  
vidéo. Vous devrez cependant ajuster le seuil pour régler l'équilibre entre réduction du bruit et artéfacts de  
mouvement. 

• Utilisez le filtre Chroma smoother page 97     (lissage chromatique) pour corriger les petits blocs de couleur  
produits par les codecs vidéo qui n'interpolent pas correctement les informations de couleur. 

• Utilisez le filtre Rotate page 126     (rotation) pour faire pivoter la vidéo par incrément de 90° jusqu'à obtenir  
satisfaction, ou le filtre Rotate2 (rotation 2) plus lent mais plus puissant si vous souhaitez une rotation  
arbitraire. 

• Quand vous voyez une vidéo se déformer en clé de voûte ou s'éloigner du centre, essayez le filtre perspective  
page 122 pour qu'elle redevienne parallèle à l'écran. 

• Appliquez un logo page 114     à la vidéo pour la marquer comme vous appartenant. 

L'ordre dans lequel les filtres s'appliqueront peut entraîner des différences de qualité et de performance  
sensibles. En terme de performance, une image vidéo plus petite est plus rapide à traiter, ainsi lors d'une  
réduction, préférez placer les filtres après celle-ci, et lors d'un agrandissement, préférez les placer avant celui-ci.  
En terme de qualité, le flou réduit le bruit et le relief amplifie... ainsi, réduisez le bruit au plus vite et apportez les  
modifications d'amélioration plus tard.

http://philou-traductions.fr/
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2:1 REDUCTION (HIGH QUALITY)
Échelle ½ de la taille de l'image, interpolation de haute qualité en utilisant une matrice de 3*3, pas de paramètre 

pour ce filtre.

2:1 REDUCTION

Échelle ½ de la taille de l'image en utilisant une matrice de 2*2, pas de paramètre pour ce filtre.
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2D CLEANER  *
Nettoyage ou diminution du bruit (ici le bruit dû à la compression).

Site : http://home.earthlink.net/~casaburi/download/  

Paramètres :

Résultat :

file:///cgi/getfilter%3Fid=34&a=go
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ACOBW AND NDF *
Balance des blancs. Le réglage est assez délicat.

«Automatic correction of balance white»

Site : http://acobw.narod.ru/acobw.html  

Paramètres :

http://acobw.narod.ru/acobw.html
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ASVZZZ DEINTERLACE  *
Supprime les effets dû à l'entrelacement (pas de paramètre).

Site : http://asvzzz.narod.ru/vdfilters.htm 

Conserve le même nombre de trames: 20

file:///cgi/getfilter%3Fid=116&a=go
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BLUR  MORE

Ajout de beaucoup flou, pas de paramètre pour ce filtre.

BLUR

Ajout de flou, pas de paramètre pour ce filtre.
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BOB DOUBLER

Double les trames d'une vidéo entrelacée et double le débit, par exemple de 30 images/s à 60 images/s.

Paramètres :

Ordre des trames Trame du haut en premier

Trame du bas en premier

Méthode de désentrelacement Bob

ELA

ELA adaptatif

Aucune – Alterner trames

Aucune – Doubler images

Passe de 20 trames à 40 trames.
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BORDER CONTROL -2.34 *
Modifie chaque côté de l'image.

Site : http://www.geocities.com/siwalters_uk/bdrcntrl.html  

Couleur du contour en RVB (ici blanc 255, 255, 255)

Réglage de chaque coin, gauche (left settings), haut 
(top settings), bas (bottom settings), droite (right 
settings).

Black region : Zone où l'image disparaît (dans cet 
exemple la zone blanche de 5 pixels).

Smear region : Zone où l'image est étirée.

Fade region : Zone du fondu de 20 pixels.

Strech factor : Facteur d'étirement.

http://www.geocities.com/siwalters_uk/bdrcntrl.html
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BOX  BLUR (1.5) *
Ajoute un flou paramétrable.

BOX  BLUR

Ajoute un flou paramétrable.
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BRIGHTNESS /CONTRAST  (UI-ENHANCED)(1.0) *
Ajuste la luminosité et les contrastes.

BRIGHTNESS /CONTRAST

Ajuste la luminosité et les contrastes
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CHROMA  SMOOTHER

Chroma smoother (adoucissement chromatique), ré-interpole les informations de couleur d'une image sans  
affecter la luminosité. 

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

L'algorithme de compression vidéo stocke souvent les informations de couleur (chroma) à une résolution  
inférieure aux informations de luminosité des niveaux de gris, car l'œil est moins sensible aux détails de couleur;  
cependant, certains codecs vidéo n'interpolent pas bien la couleur lors de la décompression, ce qui produit une  
sorte de bloc autour de la transition de couleur d'une forme. Le filtre adoucissement chromatique (chroma  
smoother) essaie d'appliquer un flou uniquement au niveau des canaux de couleur pour corriger cette situation.

Chaque option chromatique de la configuration du filtre correspond à un flou réglé pour un type particulier de  
sous-échantillonnage chromatique; en supposant que le décodeur vidéo n'interpole pas du tout la couleur, choisir  
le bon réglage produira un résultat approchant l'interpolation linéaire. Bien sur, les options plus fortes ou plus  
faibles peuvent être utiliser pour tester.

http://philou-traductions.fr/


Débuter avec Virtualdub  -  Les filtres vidéo   -  jeudi 8 avril 2010  -  Page 98 / 181

COLORIZE (1.1 BETA 1) *
Colorisation suivant le choix d'une couleur

Voir aide  \VirtualDub\documentation_filtres\Colorize.html
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CONVERT  FORMAT

Convertit la vidéo sous un autre format d'image.

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Utilisez ce filtre pour forcer la conversion de la vidéo sous un format d'image différent. Ce qui est surtout utile  
pour un diagnostic, et aussi en mode capture pour forcer un format de sortie spécifique. 

DECIMATE  (1.2) *

Voir aide  \VirtualDub\documentation_filtres\Decimate.html  

This filter acts on the output of the Telecide filter (or any other stream of progressive frames derived from a de-
telecined clip) and deletes extra duplicated frames, while enforcing a desired decimation ratio.

DEFLICKER  (1.3B1) *
Lorsqu'un vidéo est projetée sur un écran à un certain débit et enregistrée par un caméscope à une vitesse 

d'images par seconde différente il se produit un moirage et un scintillement (flicker). Ce filtre enlève cet effet de 
scintillement.  

Voir aide  \VirtualDub\documentation_filtres\Deflick.html

DEINTERLACE  - AREA BASED  V 1.4 *
Supprime les effets dû à l'entrelacement uniquement où c'est utile et selon les paramètres utilisés.

Site : http://www.guthspot.se/video/     

http://www.guthspot.se/video/
http://en.wikipedia.org/wiki/Flicker_(screen)
http://philou-traductions.fr/
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DEINTERLACE  'MUKSUN '  *
Supprime les effets dû à l'entrelacement, filtre « haute performance ».

Site : http://acobw.narod.ru/deinterlace.html   

Images du site de l'auteur                 

http://acobw.narod.ru/deinterlace.html
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DEINTERLACE

Supprime les effets dû à l'entrelacement.

DYNAMIC  NOISE  REDUCTION (MMX) *
Réduction du bruit sans créer de flou.

Site : http://www.shdon.com/vid/dnr        

http://www.shdon.com/vid/dnr
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EMBOSS

Donne un effet de relief en fonction de l'origine de la lumière (light source direction).
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FIELD BOB

Ajustement des trames sur vidéo entrelacée.

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Ré-échantillonne les images alternantes pour supprimer les tremblements lors des découpes de champs d'images.

FIELD DELAY

Ajustement de delai sur vidéo entrelacée.

FIELD SW AP

Échange des trames  sur vidéo entrelacée (Pas de paramètre).

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Change les zones paires et impaires pour solutionner les fautes.  

http://philou-traductions.fr/
http://philou-traductions.fr/
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FILL

Remplissage d'une partie de l'image par une couleur.
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FLIP HORIZONTALLY

Retournement horizontal (sans paramètre)

FLIP VERTICALLY

Retournement vertical.
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GENERAL  CONVOLUTION

Créer de nombreux effets par une matrice de convolution.

DÉTECTION  DE  BORD
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ÉCLAIRCIR , FONCER  

De 0 à 256 = éclaircir

de 0 à -256 = foncer

valeur = 40

Valeur = -80
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GRAYSCALE

Convertir en niveaux de gris (pas de paramètre).

HISTOGRAM EQUALIZE (1.1) *
Change la répartition de couleurs.

Voir aide  \VirtualDub\documentation_filtres\Histo.html
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HOTSPOT (1.0) *
Amélioration des films projetés sur écran et récupérés avec une caméra vidéo.

Voir aide  \VirtualDub\documentation_filtres\hotspot.html

HSV ADJUST

Ajuste le rendu des couleurs  en jouant sur les 3 valeurs.

HUE/SATURATION/ INTENSITY (1.2) *
Ajuste le rendu des couleurs.
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INTERLACE

Entrelace une vidéo non entrelacée.
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INTERPOLATE

Multiplie le nombre d'images avec interpolation. 

L'image créée est un mélange entre l'image précédente et l'image suivante avec le mode Linear blending.

INVERT

Inversion des couleurs (pas de paramètre).
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IVTC
Removes 3:2 pulldown (telecine) from video.

http://en.wikipedia.org/wiki/Telecine#Reverse_telecine_.28a.k.a._inverse_telecine_.28IVTC.29.2C_reverse_pull
down.29   

LEVELS

Modifie le rendu des couleurs (genre de balance des blancs).

http://en.wikipedia.org/wiki/Telecine#Reverse_telecine_.28a.k.a._inverse_telecine_.28IVTC.29.2C_reverse_pulldown.29
http://en.wikipedia.org/wiki/Telecine#Reverse_telecine_.28a.k.a._inverse_telecine_.28IVTC.29.2C_reverse_pulldown.29
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LOGO (1.7B2) *
Permet d'ajouter un logo contenu dans une image bitmap.

Le bitmap est une image .bmp où le fond est gris : 127, 127, 127 (logo.bmp)

Voir aide  \VirtualDub\documentation_filtres\Logo.html
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LOGO

Permet d'ajouter un logo contenu dans une image bitmap (moins pratique que le filtre précédent).

AVEC  IMAGE  ALPHA

logo.bmp

logo_fond_gris.bmp



Débuter avec Virtualdub  -  Les filtres vidéo   -  jeudi 8 avril 2010  -  Page 115 / 181

LOGO  SUR  FOND  NOIR

Indiquer 2 fois le chemin de 
l'image (Logo image & 
Alpha image).

logo2.bmp
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LOGOAW AY  V4.01 *
Permet d'enlever un logo sur une séquence vidéo.

Site : http://republika.pl/voidon/virtualdub/index.html        

MOTION BLUR

Produit un effet de flou avec les rémanences des images précédentes (pas de paramètre). 

http://republika.pl/voidon/virtualdub/index.html
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MSHARPEN  (1.2.1) 
Augmentation de la netteté.

Voir aide  \VirtualDub\documentation_filtres\MSharpen.html
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MSU CARTOONIZER V 3.0 *
Peindre, dessiner, convertir en dessin animé. Les réglages sont délicats.

Site : http://compression.ru/video/cartoonizer/index_en.html  

Vidéo : Céline Dion (Taratata 1995)

origine en dessous                         effet »

http://www.mytaratata.com/
http://compression.ru/video/cartoonizer/index_en.html
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MSU OLD CINEMA  2.0 *
Effet simulant un vieux film.

Site : http://compression.ru/video/old_cinema/index_en.html      

Vidéo : Céline Dion (Taratata 1995) http://www.mytaratata.com/  

http://www.mytaratata.com/
http://compression.ru/video/old_cinema/index_en.html
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MSU SMART DEBLOCKING  0.8 *
Amélioration de la qualité d'une vidéo : Vidéo de téléphone cellulaire, élimine les bruits de compression.

Site : http://compression.ru/video/deblocking/smartdeblocking_en.html      

http://compression.ru/video/deblocking/smartdeblocking_en.html
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MSU SMART SHARPEN  1.4 *
Augmentation de la netteté avec peu d'amplification du bruit.

Site : http://compression.ru/video/smart_sharpen/index_en.html        

NULL TRANSFORM

Ce filtre ne fait rien mais autorise le découpage (Cropping), voir page 38.

http://compression.ru/video/smart_sharpen/index_en.html
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PAN (1.0 BETA 2) *
This filter allows you to pan a smaller video window across a larger video, producing an output video having the 

dimensions of the panning window. The horizontal and vertical motions may be independently defined and they 
may be combined to allow arbitrary panning direction. One possible application might be to create a pan across a 
larger still photo. The still photo must first be used to create a source AVI file. A number of freeware tools can do 
this (for example, VideoMach).

PERSPECTIVE

Déformation pour simuler 
une vue en perspective.



Débuter avec Virtualdub  -  Les filtres vidéo   -  jeudi 8 avril 2010  -  Page 123 / 181

PSEUDOCOLOR  (1.0) *
Modifie les couleurs selon une palette. 

  Les palettes de Gimp (.gpl) sont reconnues par ce filtre, ici ...\share\gimp\2.0\palettes\Coldfire.gpl

Voir aide  \VirtualDub\documentation_filtres\Pseudocolor.html

Visualisation de la palette Coldfire.gpl dans Gimp »

Vidéo : Céline Dion (Taratata 1995) http://www.mytaratata.com/  

http://www.mytaratata.com/
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RED/GREEN/BLUE  ADJUSTMENT (1.0) *
Ajustement des couleurs en jouant sur les valeurs R, V, B

RESIZE

Redimensionnement.
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REVERSE  FIELD DOMINANCE  (1.0) *
Voir aide  \VirtualDub\documentation_filtres\ReverseHelp.html

This filter for VirtualDub reverses the field dominance of a clip. It is a rarely used function but when you need it, 
you really need it.

Field dominance defines the field that is to be played first. For example, a PAL DV clip has lower (bottom) field 
dominance, so as each frame is displayed, first the lower field is shown, then the upper field is shown.

RGB EQUALIZER (2.11) *
Correction des couleurs.

Site : http://fdump.narod.ru/equalizer.htm  

http://fdump.narod.ru/equalizer.htm
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ROTATE

Rotation de l'image.

ROTATE2
Rotation de l'image.
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SHARPEN

Augmentation de la netteté.

SMART  BOB (1.1 BETA 2) *
Voir aide \VirtualDub\documentation_filtres\Bob.html

This filter acts similarly to the Smart Deinterlacer filter, except that it produces a doubled frame rate output file.  
For example, if the input is 30 frames per second (fps) interlaced, the output will be 60 fps progressive. Each 
output frame is created from a single input field by either interpolating data or by using data from the previous 
frame (=field, see below), depending upon whether the area is detected as moving or not. The filter uses bicubic 
interpolation for best results. It also provides a "dumb bob" mode by which the entire frame can be interpolated 
regardless of motion.

SMART  DEINTERLACE  (2.8 BETA 1) *
Supprime les effets dû à l'entrelacement.

Site : http://neuron2.net/smart/smart.html       

http://neuron2.net/smart/smart.html
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SMART  RESIZE (1.1) *
Redimensionnement.

Voir aide  \VirtualDub\documentation_filtres\Resize.html

SMART  SMOOTHER  (1.1) *
Supprimer le bruit et artefacts des formats MPG/JPG.

Site : http://neuron2.net/smooth.html   

http://neuron2.net/smooth.html
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SMOOTHER

Supprimer le bruit.
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SUBTILER *
Ajoute des sous-titres. Le sous-titres sont contenus dans un fichier au format SSA.

Liens sur ce format : http://en.wikipedia.org/wiki/SubStation_Alpha  

http://www.matroska.org/technical/specs/subtitles/ssa.html   

Voir aide  \VirtualDub\documentation_filtres\subtiler.txt

http://www.matroska.org/technical/specs/subtitles/ssa.html
http://en.wikipedia.org/wiki/SubStation_Alpha
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TELECIDE  (1.3.0) *

Voir aide  \VirtualDub\documentation_filtres\Telecide.html

This filter acts on telecined progressive source and attempts to recreate progressive frames. The filter 
automatically adjusts to different capture patterns and telecining methods (as described in the help file for Smart 
Deinterlacer). It reacts instantly to changes of telecining method that occur in the source clip.

TEMPORAL  SMOOTHER

Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Lissage temporel 

Réduction de bruit adaptative d'une vidéo par ses images. 

Un filtre temporel est l'un de ceux qui fonctionnent avec le temps -- lissage temporel ne compare pas les pixels à  
l'intérieur d'une image, mais dans une fenêtre à 7 cadres. C'est efficace pour réduire le bruit, mais pour un  
meilleur effet, il sera à combiner avec un filtre qui fonctionne à l'intérieur d'un cadre (filtre spatial). Élever la  
puissance du filtre augmente la réduction de la quantité de bruit mais peut aussi entraîner un mouchetage lors du  
mouvement ainsi que des scintillements au cours des transitions. Le fonctionnement est meilleur avec un réglage à  
3-5. 

THRESHOLD

Conversion en noir et blanc avec réglage du seuil.

http://philou-traductions.fr/
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TINT  (1.0) *
Simule une vidéo prise derrière un filtre coloré placé sur l'objectif.

Voir aide  \VirtualDub\documentation_filtres\Tint.html

0,64,64 transparence 25%

TV
Traduction par les Manuels d'Aide en Français sur philou-traductions.fr :

Crée un flou ou un ré-échantillonnage vidéo dans le domaine  
luminance/chrominance. 

À cause de la façon dont l'encodage vidéo analogique fonctionne,  
l'information de couleur dans une vidéo (chroma) a classiquement une  
basse résolution et plus de bruit que l'information de luminosité (luma). Ce  
problème est particulièrement sévère avec les enregistrements vidéo. Le  
filtre TV peut réduire le bruit chroma en ne faisant que la moyenne du  
chroma, et en laissant le luma. Ce qui peut réduire le scintillement de  
couleurs d'une vidéo, mais doit être utilisé avec prudence du fait que trop  
de halo de chroma conduira au pleurage.

http://philou-traductions.fr/
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UNSHARP  MASK *
Amélioration de la qualité de l'image. Ce filtre est instable et difficile à régler.

Voir aide  \VirtualDub\documentation_filtres\Unsharp.txt

UNV IEWF IELDS V1.2 *
Site : http://www.geocities.com/siwalters_uk/unviewfields.html   

All this does is refold the fields back to normal after a ViewFields operation. 

VHS *
Site : http://flaxen.edwardk.info/         

The original VHS filter. Noise reduction & sharpening functions. 

V IEWF IELDS V1.2 *
Site : http://www.geocities.com/siwalters_uk/viewfields.html  

This filter is nearly identical to the unfold fields option within VirtualDub's built-in deinterlace filter except that 
it re-arranges the top field on the top and the bottom field on the bottom of a frame.

Annulé par UnViewFields V1.2 *

http://www.geocities.com/siwalters_uk/viewfields.html
http://flaxen.edwardk.info/
http://www.geocities.com/siwalters_uk/unviewfields.html
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W ARP RESIZE

Redimensionnement de l'image.

W ARP SHARP

Amélioration de la qualité de l'image.

W ARP SHARP  *
Amélioration de la qualité de l'image.  Ce filtre est instable. 

WINDOW ED HISTOGRAM EQUALIZE (1.0) *
Modification des couleurs.

Voir aide  \VirtualDub\documentation_filtres\Winhisto.html

A global histogram equalization is useful for many but not all images.



Débuter avec Virtualdub  -  Les filtres vidéo   -  jeudi 8 avril 2010  -  Page 135 / 181

XSHARPEN  (1.0 BETA 2) *
Amélioration de la netteté. Réglage délicat.

Site : http://neuron2.net/xsharp.html   

ZOOM (1.2) *
Zoom sur une partie de l'image. Réglage délicat.  Ce filtre est instable. 

Voir aide  \VirtualDub\documentation_filtres\Zoom.html

http://neuron2.net/xsharp.html
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L'ÉDITEUR DE COURBES (RÉGLAGE DE L'OPACITÉ AVEC LES FILTRES)

Une description existe dans l'aide en anglais CHM de VirtualDub  au chapitre Video Filters > Filter curves. 

PRINCIPE

L'éditeur de courbes permet de faire varier « l'opacité » ou le niveau de l'effet d'un filtre, par exemple pour faire 
un fondu (fade) avec une couleur (filtre fill).

– Valider l'option afficher l'éditeur de courbe « Curve editor » par View > Curve editor

– Activer un filtre via Video > Filters , choisir un filtre, sélectionner le filtre, appuyer sur le bouton « Blend » (le 
symbole [B] s'ajoute,  Appuyer sur OK.

– Ajouter des points sur la courbe par appui sur la touche Maj et clic gauche avec la souris (ici 2 points de 
couleur bleue). Les numéros en bas représentent les images (frames). La variation de la courbe entraine la 
variation de l'opacité du filtre. La ligne placée en bas => pas d'effet du filtre , ligne en haut => effet total du 
filtre. Le traitement vidéo est légèrement ralenti pendant les transitions.

– Un point se déplace par clic gauche avec la souris sur le point puis déplacement.

– Pour supprimer des points de la courbe, maintenir la touche Ctrl enfoncée et cliquer sur les points à effacer. 

– Pour transformer une ligne courbe en droite (effet linéaire) et réciproquement faire un clic droit avec la souris.
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EXEMPLE

Passer une vidéo couleurs => noir et blanc => couleurs. 

La vidéo de cet exemple est \VirtualDub\videos\cube_rvb.avi 

– Ouvrir cette vidéo dans VirtualDub par File > Open video file ou Ctrl+O , choisir le fichier cube_rvb.avi et 
appuyer sur le bouton Ouvrir.

– Valider l'option afficher l'éditeur de courbe « Curve editor » par View > Curve editor  

– Valider le mode de traitement complet pour la vidéo par Video > Full processing mode (Un point indique que 
ce mode est validé).Activer un filtre via Video > Filters ou Ctrl+F, choisir le filtre par appui sur le bouton Add , 
une fenêtre « Add Filter » s'ouvre, sélectionner le filtre « grayscale », appuyer sur le bouton Ok. 

– Sur la fenêtre « Filters », sélectionner le filtre puis appuyer sur le bouton « Blend » (le symbole [B] s'ajoute, 
Appuyer sur OK.
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– Ajouter des points sur la courbe par appui sur la touche Maj et clic gauche avec la souris, ici 4 points (405 en 
bas, 425 en haut, 435 en haut, 455 en bas).

–  Transformer les segments courbes en droites par clic droit avec la souris :

Nota : Les numéros en blanc sur fond noir sont le numéros d'images (frames), le trait rouge vertical indique la 
position du curseur.

– Vérifier l'effet en déplaçant le curseur : 
de 0 à 405 => couleur (le filtre grayscale n'est pas appliqué).
de 405 à 425 => transition de couleur vers noir et blanc.
de 425 à 435 => noir et blanc (filtre grayscale appliqué à 100%).
de 435 à 455 => transition de noir et blanc vers couleurs.
de 455 à 1000 => couleurs (le filtre grayscale n'est pas appliqué).
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AJOUTER DU SON À UNE VIDÉO

Dans cet exemple, le son ...\VirtualDub\videos\son\1free7wav.wav sera ajouté à la séquence d'images 
...\VirtualDub\videos\sequence_images\kaleidoscope.xcf.bz2001.tga et l'ensemble sera sauvegardé en 
compressant le son avec un codec et la vidéo avec le codec XVID dans le fichier 
...\VirtualDub\videos\kaleidoscope-1free7wav.avi (Il faut se méfier des codecs qui ne sont pas tous compatibles  
avec tous les lecteurs vidéo)

Ouvrir la séquence d'images par File > 
Open video file , paramétrer comme indiqué 
ci-dessous et appuyer sur le bouton Ouvrir.

La séquence d'images se retrouve dans 
Virtualdub
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Indiquer à Virtualdub le fichier son à utiliser par Audio > Audio from other file ,  sélectionner le fichier et appuyer 
sur le bouton Ouvrir.

Indiquer à Virtualdub d'utiliser le mode de traitement complet pour le son par Audio > Full processing mode (Un 
point indique que ce mode est validé).

Paramétrer le codec audio par 
Audio > Compression

Cette fenêtre s'affiche »

Valider l'option Show all 
formats pour visualiser les 
options des codecs quand elles 
existent.

Pour cet exemple on peut 
choisir Microsoft ADPCM et 
une qualité moyenne 
22.050khz 4 bits Mono 
11KB/s (Attention, certains 
paramètres des codecs ne 
fonctionnent pas et  l'audio de 
la vidéo sera au format wav)

Appuyer sur OK
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Indiquer à Virtualdub d'utiliser le mode de traitement complet pour la vidéo par Video > Full processing mode 
(Un point indique que ce mode est validé).

Paramétrer le codec audio 
par Audio > Compression

Cette fenêtre s'affiche »

Valider XviD MPEG-4 
codec.

Appuyer sur le bouton 
Configure.

Paramétrer Single pass (l'encodage du fichier AVI 
résultant se fera en une passe)

Mettre une faible qualité du rendu vidéo à 15.00

Appuyer sur OK.
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Appuyer sur OK de la fenêtre « Select video compression ».

Créer le fichier vidéo+son kaleidoscope-1free7wav.avi par File > Save as AVI ou raccourci F7.

 Appuyer sur le bouton Enregistrer. 

Cette fenêtre s'affiche rapidement »

La vidéo est disponible :

Remarque : Le son n'est pas rendu dans le lecteur
         Windows Media 12 

Pour vérifier les caractéristiques ouvrir la vidéo dans une nouvelle 
session de Virtualdub et faire : File > File information

Caractéristiques de la vidéo »

La visualisation indique que le son s'arrête avant la fin de l'animation. 
Pour éviter ce phénomène voir le paragraphe suivant.
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VARIANTES

MODIFICATION  DE  LA  DURÉE  DE  L 'ANIMATION

Comme la vidéo est une séquence d'images, nous pouvons modifier le débit par Video > Frame rate ou raccourci 
Ctrl+R et appliquer une valeur de 30 images par secondes ou adapter le débit à la durée de la musique.

Les 3 résultats :

10 fps : \VirtualDub\videos\kaleidoscope-1free7wav.avi

30 fps :  \VirtualDub\videos\kaleidoscope-1free7wav_30fps.avi (91 474 octets)

17.497 fps :  \VirtualDub\videos\kaleidoscope-1free7wav_17-497fps.avi

Nota : La lecture à un très faible débit n'est pas bonne dans VLC 1.0.5 mais correcte dans Media Player 
Classic 6.4.9.1 et Lecteur Windows Média .

NE PAS  UTIL ISER  LA  COMPRESSION  AUDIO

Valider Audio > Direct stream copy.

Résultat à 30fps : \VirtualDub\videos\kaleidoscope-1free7wav_30fps_dsc.avi (135 932 octets)

Remarque : Le son est rendu dans les 3 lecteurs : Windows Media 12, VLC, Media Player Classic.
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IMPORTER  UN  FICHIER  AUDIO  MP3
Lors de l'importation de ce type de fichiers, ici \VirtualDub\videos\son\59._initial_zend.mp3, cette fenêtre 

s'affiche : 

Elle permet de paramétrer les options de la fréquence d'échantillonnage (Kbits par seconde) :

– Détection automatique en fonction de l'analyse du fichier (Autodetect).

– Fréquence d'échantillonnage fixe (Constant bit rate CBR ), est plus compatible mais donne des erreurs avec les 
fichiers codés en mode d'échantillonnage variable (VBR).  Valable aussi pour les fichiers codés en fréquence 
d'échantillonnage moyenne  (Average bitrate ABR) .

– Fréquence d'échantillonnage variable (Variable bit rate VBR), option « non-standard », supportée par les 
lecteurs mais qui peut causer des problèmes de compatibilité. La synchronisation audio est bonne avec tous les 
types d'échantillonnages.

RÉGLAGE  DU  VOLUME

Indiquer à Virtualdub d'utiliser le mode de traitement complet pour le son par Audio > Full processing mode puis 
modifier le volume par Audio > Volume.

Valider Adjust volume of audio channels puis ajuster le curseur du volume. Valider par OK.
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APPLIQUER  DES  EFFETS  À LA VIDÉO  ET/OU  AU  SON

De nombreux filtres existent pour l'audio et la vidéo.

Pour y avoir accès il faut valider Full processing mode
Audio > Full processing mode et/ou  Video > Full processing mode 

Valider les filtres audio :   Audio > Use advanced filtering. 

Choisir les filtres :   Audio > Filters et/ou  Video > Filters. 

 Pour les effets voir page 82     (audio) et page 87 (vidéo).
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ENLEVER DES SÉQUENCES D'UNE VIDÉO : PUBLICITÉ, DÉBUT, FIN

Lorsque nous enregistrons de vidéos diffusées par la télévision entrecoupées de publicité, nous pouvons 
simplement les supprimer. Cette information peut facilement faire diminuer le volume des fichiers de 25%.

Il est possible de gagner quelques mégaoctets en supprimant les marges que nous prenons au début et à la fin de 
l'enregistrement.

Malheureusement, VirtualDub, ne permet pas de traiter tous les types de vidéo en   mode de copie directe   (Direct 
stream copy). Lorsque Direct stream copy est sélectionné, seules les vidéos AVI sont traitées.

Pour les vidéos qui ne sont pas des AVI nous utiliserons un autre logiciel libre : Avidemux (voir page 173)

Remarque : Le mode Direct stream copy a un traitement très rapide, il n'est pas nécessaire de ré-encoder toute la 
vidéo.

 LE FICHIER EST UN AVI

http://fr.wikipedia.org/wiki/Avidemux


Débuter avec Virtualdub  -  Enlever des séquences d'une vidéo : publicité, début, fin   -  jeudi 8 avril 2010  -  Page 147 / 181

LE FICHIER N 'EST PAS UN AVI
Installer le  logiciel libre Avidemux (voir page 173) qui nous permettra de faire ces découpages.

Dans cet exemple nous utilisons une vidéo codée par le système HD PVR de marque Hauppauge 
http://www.hauppauge.com/site/products/data_hdpvr.html  au format .mp4 (compatible Xbox360).

Site en français : http://www.hauppauge.fr/site/products/data_hdpvr.html  

 Lancer Avidemux et ouvrir le fichier par Fichier > Ouvrir ou raccourci Ctrl+O . La fenêtre suivante s'affiche :

Valider par le bouton Oui.

Paramétrer :

Vidéo sur Copy

Audio sur Copy

Format sur MP4

http://www.hauppauge.fr/site/products/data_hdpvr.html
http://www.hauppauge.com/site/products/data_hdpvr.html
http://fr.wikipedia.org/wiki/Avidemux
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Remarque : Dans Avidemux, les images clef sont des « images I » ou « images intra ». Pour se déplacer sur ces images 
clef, utiliser les boutons « ou touche Up (image clef précédente) et » ou touche Down (image clef suivante) . 
Pour avoir un bon découpage, les sélections doivent se faire sur ces images clef, repérées I.

Sélectionner les tronçons à supprimer avec A qui marque le début de la sélection et B la fin de la sélection.

Supprimer la sélection par Édition > Supprimer .

Recommencer ces sélections sur tous les tronçons à supprimer.

Enregistrer par Fichier > Enregistrer > Enregistrer une vidéo ou raccourci Ctrl+S , donner un nom à cette vidéo 
(ma_belle_video.mp4 par exemple), appuyer sur le bouton Enregistrer. Le traitement commence :

Lorsque le traitement est terminé cette fenêtre s'affiche :

On peut visualiser le résultat dans le Lecteur Windows Media.  
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CAPTURE D'ÉCRAN AVEC V IRTUALDUB

Ouvrir VirtualDub et passer en mode capture par File > Capture AVI  

Valider la capture d'écran par Device > Screen Capture  

Choisir le format par Video > Set custom format ou raccourci Maj+F , exemple plein écran d'un moniteur de 
1920*1080 pixels :

Pour ne pas valider l'affichage dans VirtualDub désactiver l'option Video > Preview et/ou Video > Overlay 

Choisir un arrêt automatique de la capture, ici 30 secondes par Capture > Stop conditions 

Valider par Accept

Remarque au sujet de la capture d'écran : 

Nous avons eu quelques difficultés à faire fonctionner la capture d'écran . Chez nous, sur deux ordinateurs 
équipés de Windows 7, il ne faut pas valider l'option   Use OpenGl hardware acceleration   dans Video > 
Source ou raccourci S lorsque Device > Screen capture est validé. 
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Déterminer le nom du fichier de capture par File > Set capture file ou F2 , exemple ouverture_de_gimp

Choisir ou non un codec de compression vidéo par Video > Compression ou C (pour retravailler la vidéo 
ultérieurement, ne pas choisir de compression et faire attention au volume des fichiers créés) :

Réduire la fenêtre et démarrer la capture par F6 ou éventuellement F5 , valider par OK

Vérifier le résultat dans Lecteur Windows Media.

Il est possible d'arrêter la capture par la touche Échapp si la fenêtre VirtualDub a le focus et de modifier le débit  
vidéo par Capture > Settings ou F9. 

En cas de problème consulter http://www.virtualdub.org/docs_capture.html   

VARIANTE AVEC  VHSCRCAP

Voir http://www.donsalva.com/real-time-screen-capturing-recording-with-virtualdub-and-vhscrcap/   (non testé)

Site : http://www.splitmedialabs.com/vh-video-sdk/vh-screen-capture  

http://www.splitmedialabs.com/vh-video-sdk/vh-screen-capture
http://www.donsalva.com/real-time-screen-capturing-recording-with-virtualdub-and-vhscrcap/
http://www.virtualdub.org/docs_capture.html
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LE LANGAGE  DE SCRIPTS DE V IRTUALDUB

Notice sur le langage de script, origine : http://www.virtualdub.org/docs/vdscript.txt (updated for 1.6.7)

VirtualDub scripting language reference, v0.7
=============================================

This is a document documenting VirtualDub's awful scripting interface.  I am releasing it under the GNU 
General Public License (GPL), the same license as VirtualDub.  This reference is current as of VirtualDub 
1.6.7 (WIP), and may not apply to earlier versions.  If I ever update this document again, check 
http://www.virtualdub.org/  for updates.
Note that I do not consider the scripting interface to be a major public interface, and thus have no 

qualms about breaking it at any time.  I do try to keep compatibility to avoid breaking job scripts, but 
I have been known to goof (V1.4b).  You have been warned.
-- Avery Lee <phaeron@virtualdub.org>
   June 09, 2005

VirtualDub's scripts
--------------------
VirtualDub's batch system is based on the scripting language, and is stored in a file called 

VirtualDub.jobs in the program directory.  If you click the Defer button in the save requester, 
information to start the processing job is queued in this file.  It is text, so it can be edited by hand 
and produced by external programs.  You will want to produce a couple of jobs to get a feel for how this 
works.
The command-line options, which are documented in the help file, allow you to launch VirtualDub, from a 

batch file or programmatically, to process a script.  If you do this, you should heed the following:
1) Do not bundle VirtualDub.exe in an archive with the client application, the GPL forbids distribution 

of the binary without source code.  (This is not entirely true, since you may offer access to end users 
without requiring that they download source; read the GPL itself for details.) Furthermore, I don't like 
seeing VirtualDub stripped of its documentation and help file.  Don't do it.
2) Make the distinction between your application and VirtualDub very clear, and let the user know you 

are a launching an external application and what to do if something goes wrong.  I've only had one 
incident, but I do not want to get support email from people who think my program is at fault when an 
external application goofs.  I get enough email already.
3) Save your script in VirtualDub.jobs, but save off the old file if it exists and restore it afterward. 

This protects a user's existing scripts and causes VirtualDub to post errors in the job file instead of 
presenting them to the user and halting the process.
4) If you use any filters which are not internal to VirtualDub, they *must* be installed in VirtualDub's 

plugins directory so that they are autoloaded on startup.  VirtualDub does not currently allow external 
filters to be loaded from a script.
5) If you are launching VirtualDub from a batch file, you will need to use "start /wait" to launch it, 

or the batch file will continue execution immediately after VirtualDub loads.  For a program, launch 
VirtualDub using CreateProcess() and use WaitForSingleObject() to delay until VirtualDub completes.
VirtualDub's scripting system offers mainly the same controls that are available through the user 

interface; there are no hidden features, and a few options are not settable via scripting.  Capture mode 
is entirely unavailable from a script, so don't even try to set up a Windows VCR this way.

http://www.virtualdub.org/
http://www.virtualdub.org/docs/vdscript.txt
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Sylia: the world's worst scripting language
-------------------------------------------
I don't know what I was thinking when I created this scripting language.  It's very loosely based on C, 

but it sucks more.  I must have been watching Bubblegum Crisis before I created it.  There are only three 
types (void, int, string) and three keywords defined:

declare var; Declares a typeless global named var.
true 1
false 0

All statements are either declarations or expressions, and all statements must end in a semicolon. 
There is no flow control -- no functions, no procedures, no if, no while, no for, no switch, no goto. 
Sylia supports class objects and arrays but they can't be defined or instantiated by scripts. Objects can 
be assigned to variables, so the following is valid:

declare foo;
foo = VirtualDub.video.filters;
foo.Add("bar");

Arrays and member function names can also be assigned to variables.  In the latter case, overload 
resolution is deferred until the variable is dereferenced.
Constants may be integers or strings.  Integers are 32-bit signed and can be specified in decimal, octal 

(leading 0) or hex (leading 0x).  Type suffixes are not allowed (i.e. -1L).  Strings must be double 
quoted, but may contain the following C escapes:

\a, \b, \f, \n, \r, \t, \v, \xhh, \\, \"

Strings may not contain nulls.
The following C operators are supported in expressions:

= assignment
+ integer addition, string concatenation, or unary plus
- integer subtraction or unary minus
* integer multiplication
/ integer division
% modulus
[] array indexing operator
() expression grouping or function dereference operator
. object dereference operator
~ bitwise not
& bitwise and
| bitwise or
^ bitwise xor
! logical not
== integer equality
!= integer inequality
< integer less than
<= integer less than or equals
> integer greater than
>= integer greater than or equals
&& logical and
|| logical or

Precedence is the same as in C.  Division and modulus by zero may cause mild nausea, the destabilization 
of the universe, or a script error.
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UTF-8 string encoding (VirtualDub 1.5.5+)
-----------------------------------------
Beginning with VirtualDub 1.5.5, parts of the application run in Unicode under Windows NT/2000/XP, 

meaning that filenames can have characters that are not representable in 8-bit (ANSI).  Script commands 
that take filenames, with the exception of internal filters, now accept UTF-8 rather than ANSI.  UTF-8 is 
similar to UTF-16, the Unicode encoding used by Win32, except that code points above U+007F are encoded 
using multi-byte sequences.
VirtualDub escapes UTF-8 sequences using C-style \x escapes when writing out scripts, so high-bit 

characters are never seen in script files even when present in filenames.  This means that scripts in 
1.5.5 continue to be readable as ANSI files.
For more information on UTF-8 encoding or the Unicode standard, see the Unicode website at 

http://unicode.org/.

Additional data types (VirtualDub 1.6.0+)
-----------------------------------------
Starting with VirtualDub 1.6.0, Sylia supports 64-bit long integer (l) and double-precision real (d) 

types, variables, and constants. The interpreter will automatically promote or demote types as necessary 
to match a method prototype; if multiple overloads are available, the first one in the list is used.

Undecorated strings (VirtualDub 1.6.1+)
---------------------------------------
Because string paths with escaped backslashes are difficult to create from batch files, and some 

languages may not have UTF-8 conversion support, Sylia supports an alternative syntax for strings: 
strings prefixed with u or U are treated as undecorated, ANSI encoded strings. An example:

VirtualDub.Open(U"e:\test\test.avi");
The string is automatically converted from the system ANSI code page to UTF-8 in the script system 

before being handed to the command system. This allows file paths to be directly inserted in scripts 
without the need for escaping or text conversion.

Script arguments (VirtualDub 1.6.4+)
------------------------------------
An invoke (/i) switch has been added that allows parameters to be passed to a script from the command 

line:
virtualdub /i foo.script in.avi out.avi

Non-switch parameters immediately after the /i switch are placed into the VirtualDub.params[] array. 
VirtualDub.params[0] would thus return the string "in.avi" in the above example.

Command-line interface (VirtualDub 1.6.5+)
------------------------------------------
Starting with VirtualDub 1.6.5, it is possible to launch VirtualDub in command-line mode, which makes 

some kinds of batch operations easier. To do so, launch vdub.exe (32-bit) or vdub64.exe (64-bit). This 
will then redirect the output of the program to standard output. Also, it will return a non-zero error 
code when an error occurs.
Launching the program with /? will display command-line help.

Version query (VirtualDub 1.6.5+)
---------------------------------
A /queryVersion flag has been added that causes VirtualDub to exit with the build number of the 

executable. This makes it easier to detect and adjust for different versions of the program. For an NT 
CMD batch file, the build number will be found in the %ERRORLEVEL% environment variable.
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Casting (VirtualDub 1.6.7+)
---------------------------
In 1.6.7, it is possible to use C-style casts to coerce between the numeric types:

Foo(1 + (int)4.0);
Casting from double to long or int causes truncation toward zero; if the double value cannot be 

represented in the target type the result is undefined. Casting from long to int results in the lower 
bits being kept, and casting from int to long results in sign extension.
Numeric values cannot be casted to strings and vice versa. Use the Atoi(), Atol(), Atod(), and 

ToString() functions for that.

============================
Scripting function reference
============================

All functions are member functions of objects.  For instance, Open() is a member function in the object 
VirtualDub, so to access it:

VirtualDub.Open(...);
CAUTION: Most or all of the functions below do not do any parameter validation and will crash if you 

pass bad parameters.  Try not to do stupid things like add a -10x-10 resize filter!

Object: Sylia
-------------
void dprint(int/string value);

Prints the named string or value to the debug output.
void messagebox(string text, string caption);

(VirtualDub 1.6.2+ or later)
Displays a message box.
NOTE: A message box is displayed even if VirtualDub is running in batch or command-line mode, so 

this is best not used in production scripts!
string ToString(int); (VirtualDub 1.6.2+ or later)
string ToString(long); (VirtualDub 1.6.2+ or later)
string ToString(double); (VirtualDub 1.6.2+ or later)
string ToString(string); (VirtualDub 1.6.2+ or later)

Converts a numeric value to a string, formatted as a decimal number.
The string-to-string version does nothing and exists for convenience when displaying expressions 

of arbitrary type for debugging.
int Atoi(string s); (VirtualDub 1.6.5+ or later)
long Atol(string s); (VirtualDub 1.6.5+ or later)
double Atod(string s); (VirtualDub 1.6.5+ or later)

Converts a string to an integer, long integer, or double. An error is thrown if the conversion 
fails because the string is not a valid number representation. These functions are useful for converting 
command-line parameter strings to numeric form.

Object: VirtualDub
------------------
void SetStatus(string text);

Sets the text displayed on the status bar at the bottom of VirtualDub's window.
void Open(string filename, int type, int xopts);
void Open(string filename, int type, int xopts, string xoptstring);
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Opens a video file.  type is one of:
0 Autodetect
1 AVI
2 MPEG-1
4 Striped AVI
5 AVI through AVIFile (Avisynth)

If xopts is nonzero, VirtualDub opens the file with extended open options.  If xoptstring is 
absent, the dialog is opened, otherwise xoptstring is processed as a MIME BASE64 encoded string of the 
binary options structure.
void Open(string filename, string type, int xopts);
void Open(string filename, string type, int xopts, string xoptstring);

(VirtualDub 1.5.5+ or later)
This is the preferred form of the Open() function in 1.5.5+.
Instead of taking a number, it takes a type name instead.  Here are some type names:
"Audio/video interleave input driver (internal)"
"AVIFile/Avisynth input driver (internal)"
"Image sequence input driver (internal)"
"MPEG-1 input driver (internal)"

void Open(string filename) (VirtualDub 1.6.5+ or later)
This is a simpler form of the Open() command that always uses auto-detect mode for determining the 

file type.
void Append(string filename);

Appends an additional video segment onto the current file.

void Close();
Closes the current input file.

void Preview();
Launches a preview of the current file, with the current settings.
This is equivalent to File > Preview.

void SaveAVI(string filename);
Runs the processing engine to produce an output file in AVI2 format.

void SaveCompatibleAVI(string filename);
Runs the processing engine to produce an output file in AVI1 format.

void SaveSegmentedAVI(string filename, int spacethresh, int framethresh);
Runs the processing engine to produce an output file in multiple AVI files.  spacethresh is the 

maximum file size in megabytes, framethresh is the maximum number of frames.  framethresh is ignored if 
it is zero.
void SaveImageSequence(string prefix, string suffix, int mindigits,

int format);
void SaveImageSequence(string prefix, string suffix, int mindigits,

int format, int quality); (VirtualDub 1.6.0+ or later)
Saves an image sequence with filenames in the form "prefix#suffix," where # is the sequence 

number, padded to mindigits length with zeroes.  Format specifies the type of file to be generated:
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0 - Windows BMP
1 - TARGA
2 - JPEG (VirtualDub 1.6.0+ or later)

void SaveWAV(string filename); (VirtualDub 1.4d or later)
Runs the processing engine to produce an output file in WAV format.

void RunNullVideoPass(); (VirtualDub 1.6.5+ or later)
Runs the processing engine in video-only mode but discards the output.
This is useful with video filters or codecs that have an analysis pass which does not produce 

usable output.
void Log(string output); (VirtualDub 1.6.5+ or later)

Outputs an entry to the log at Info priority. When VirtualDub is run from the command-line, this 
text will also be output to the standard output.

Object: VirtualDub.video
------------------------
int GetDepth(int var);
void SetDepth(int var, int value);

If var is zero, these functions affect the input depth, otherwise they deal with the output depth. 
GetDepth() returns 0, 1, or 2. SetDepth() receives 16, 24, and 32 as values for the same bit depths. I 
don't remember why they don't match.

It is highly recommended that you use SetInputFormat() and SetOutputFormat() instead. The 16, 24, 
and 32-bit settings are equivalent to the XRGB1555, RGB888, and XRGB8888 formats, respectively.
void SetInputFormat(int format); (VirtualDub 1.6.0+ or later)
void SetOutputFormat(int format); (VirtualDub 1.6.0+ or later)

Sets the preferred input and output formats used for video processing.

0 Autodetect / Same as input
5 XRGB1555 16-bit 555 RGB
6 RGB565 16-bit 565 RGB
7 RGB888 24-bit 888 RGB
8 XRGB8888 32-bit 888 RGB + dummy alpha
9 Y8 luminance only [16, 235]
10 YUV422_UYVY 4:2:2 YCbCr interleaved, UYVY ordering
11 YUV422_YUY2 4:2:2 YCbCr interleaved, YUY2 ordering
14 YUV422_Planar 4:2:2 YCbCr planar (YV16)
15 YUV420_Planar 4:2:0 YCbCr planar (YV12/I420)
17 YUV410_Planar 4:1:0 YCbCr planar (YVU9)

int GetMode();
void SetMode(int mode);

Sets the video processing mode:

0 direct stream copy
1 fast recompress
2 slow recompress
3 full processing mode
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int GetFrameRate(int var);
void SetFrameRate(int var, int value);

Gets or sets a particular frame rate control value:
var=0 frame rate decimation factor, 1=all frames
var=1 new frame rate in microseconds per frame; 0=no change, -1 means match duration
var=2 nonzero if inverse telecine is enabled
Do not set frame rate decimation at the same time as inverse telecine. It won't work.

void SetTargetFrameRate(int hi, int lo); (VirtualDub 1.5.2+)
Sets the target frame rate for frame rate conversion as a 64-bit rational fraction (hi divided by 

lo).  Note that both hi and lo are *unsigned*.  Values from 2147483648 to 4294967295 must be passed as 
the equivalent 32-bit negative signed value!

As of 1.6.7, it is OK to specify all values as positive integers, as the large values will be 
interpreted as long and then automatically converted to int to match the function.

int GetRange(int var);
void SetRange(int startMS, int endMS);

Gets or sets a particular range value.  If var=0, the start offset is used, and if var=1, the end 
offset is used.  The start offset is measured in milliseconds from the beginning, and the end offset is 
in milliseconds from the end.  Yes, I know this is stupid.

Because the end offset is only an offset, it is not possible to determine the length of the video 
stream using these functions.

void SetRangeEmpty(); (VirtualDub 1.6.5+)
Clears the current selection but does not affect the start/end points of the processing range. 

This is equivalent to Clear Selection (Ctrl+D) in the UI and is useful for avoiding spurious displayed 
selections after the script runs.

int GetCompression(int var);
Retrieves a variable for the currently selected compressor:

var=0 Returns the fccHandler ID for the compressor.
var=1 Returns the maximum keyframe interval.
var=2 Returns the quality factor (0-10000).
var=3 Returns the data rate (0=no data rate).

void SetCompression();
void SetCompression(string fccHandler, int keyrate, int quality, int datarate);
void SetCompression(int fccHandler, int keyrate, int quality, int datarate);

The argumentless syntax turns off video compression.  The other two syntaxes select a video 
compressor.  Note that the fccHandler can be specified as either an integer or a string.  If the string 
is shorter than 4 bytes, it is padded with spaces.
void SetCompData(int length, string data);

Sets the private codec data for the video compressor that is modified when you click Configure in 
the Video Compression dialog.  This data is opaque to VirtualDub and is used only by the video codec. 
length is the length of the data block in bytes, and the data is the data block encoded in MIME BASE64.

void EnableIndeoQC(int enableQC);
Enables or disables Quick Compress on the Ligos (formerly Intel) Indeo v4.x/5.x video codec.

void SetIVTC(int enableIVTC, int ivtcmode, int offset, int polarity);
Sets inverse telecine parameters.
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enableIVTC: nonzero if IVTC should be enabled
ivtcmode: 0=field based, 1=frame based
offset: frame offset for the IVTC pattern, -1=adaptive
polarity: 0=field A dominant, 1=field B dominant, ignored if offset=-1
There is a bug in VirtualDub 1.4c that causes the offset value to be cast to a bool (either 0 or 

1).  This unfortunately makes setting adaptive IVTC impossible.  The problem is fixed in V1.4d.

int width; [VirtualDub 1.4d (12667) or later]
int height;

Read-only variables giving the width and height of the source video.
The values are undefined if the source video does not exist.

Object: VirtualDub.audio
------------------------
void GetMode();
void SetMode(int mode);

Gets or sets the audio processing mode.
0 direct stream copy
1 full processing mode

int GetInterleave(int var);
void SetInterleave(int enabled, int preload, int interval, int is_ms, int offset);

Gets or sets audio interleaving parameters.
get set description
var=0 enabled Nonzero if audio interleaving is enabled.
var=1 preload Preload in milliseconds.
var=2 interval Interleaving interval in milliseconds or frames.
var=3 is_ms Nonzero if interleaving interval is in milliseconds.
var=4 offset Displacement offset in milliseconds.

int GetClipMode(int var);
void SetClipMode(int begin, int end);

Gets or sets audio clipping parameters.  begin (var=0) specifies if audio should be displaced when 
video is left out.  This is almost always nonzero.  end (var=1) specifies if audio should be clipped if 
it is longer than the video.  This is also almost always nonzero.

int GetConversion(int var);
void SetConversion(int new_rate, int new_precision, int new_channels);
void SetConversion(int new_rate, int new_precision, int new_channels,

int integral_rate, int high_quality);
Gets or sets audio conversion parameters.

var=0 (new_rate) New sampling rate in Hz; 0=no change
var=1 (new_precision) New precision; 0=no change, 1=8-bit, 2=16-bit
var=2 (new_channels) 0=no change, 1=mono, 2=stereo
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void SetSource(int mode);
void SetSource(string file);

Sets the audio source.  mode=0 is no audio, and mode=1 is input audio.
The string form opens an external WAV file.

void SetCompression();
void SetCompression(int wFormatTag, int nChannels, int wBitsPerSample, int nAvgBytesPerSec, int 

nBlockAlign);
void SetCompression(int wFormatTag, int nChannels, int wBitsPerSample, int nAvgBytesPerSec, int 

nBlockAlign, int cbData, string data);
Sets the audio compression format.  The first format clears audio compression.  The second and 

third specify parameters from a standard Win32 WAVEFORMATEX structure:
wFormatTag Specifies an audio compression format.
nChannels 1=mono, 2=stereo.
wBitsPerSample 8 or 16 for PCM, but may vary for others.
nAvgBytesPerSec Just what it says.
nBlockAlign The size of a compressed data block.
These fields are present when using an audio compressor with private data, opaque to VirtualDub:
cbData Size of data in bytes
data MIME BASE64 encoded data string
Usually, you will want to derive these fields by querying the compressor or looking at job scripts 

VirtualDub saves, because audio compressors tend to only accept specific values.  Some, but not all, of 
the private data formats are documented in MMREG.H in the Win32 Platform SDK.
void SetVolume(); [VirtualDub 1.4d (12667) or later]
void SetVolume(int v); [VirtualDub 1.4d (12667) or later]
int GetVolume(); [VirtualDub 1.4d (12667) or later]

Sets or gets the current audio volume amplification value.  The volume is expressed as an 8-bit 
fixed point fraction, where 256 is no amplification, 128 is half volume, and 512 is double volume.  The 
empty argument form of SetVolume() disables volume amplification.

Object: VirtualDub.subset
-------------------------
The subset is the edit list for processing the video stream. It consists of a set of frame ranges, 

indicating which frames in the source stream are to be processed. Frame numbers are zero-based.
In 1.5.4 and earlier, the subset is constrained to only contain ranges sorted in source order, and thus 

ranges may be reordered when added. Starting with 1.5.5, the subset may contain duplicate or out-of-order 
ranges, allowing portions of the video stream to be repeated or used in a different order than in the 
original. For best compatibility it is recommended that ranges always be added in ascending timeline 
order.
void Delete();

Deletes the subset so that no edits are applied; the whole source file is processed, subject only 
to the start/end offsets.
void Clear();

Removes any existing subset and creates a new one with no frames. This should be done before 
calling AddFrame()/AddRange() to start constructing the subset.
void AddFrame(int start, int length);
void AddRange(int start, int length); [VirtualDub 1.4.10 or later]

Adds a range of frames to the subset.  Subset frames should be isolated; they should not overlap 
or abut against each other (i.e. don't do [0,5] and [5,5]).  Starting with 1.5.5, overlapping or out-of-
order ranges are allowed, but abutting ranges should still be avoided.

The AddRange() function was added in 1.4.10 as a better-named synonym. It is equivalent to 
AddFrame(), and the AddFrame() syntax is now deprecated.
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void AddMaskedRange(int start, int length); [VirtualDub 1.4.8 or later]
Adds a range of masked frames to the subset. A masked frame is a frame that repeats the previous 

frame, wherever it may come from; it is used as a placeholder for a frame that is otherwise unusable, 
such as one with corrupted data.

Object: VirtualDub.params (VirtualDub 1.6.1+ or later)
--------------------------------------------------------------------
string operator[](int index); (VirtualDub 1.6.1+ or later)

Retrieves parameters from an invoke (/i) command-line switch. The parameter indices are zero-
based, so params[0] is the first parameter. If the indicated parameter does not exist, an error is 
thrown.

Object: VirtualDub.project (VirtualDub 1.6.5+ or later)
--------------------------------------------------------------------
void ClearTextInfo(); (VirtualDub 1.6.5+ or later)

Clears the text information assocated with output AVI files. By default annotations are loaded and 
preserved from the input file.
void AddTextInfo(string fourcc, string text);

Adds a text annotation for use with subsequent AVI output files, such as author and name strings. 
fourcc should be one of the standard AVI text annotation chunk four character codes (FOURCCs), such as 
"ISBJ" and "IART." Note that the second parameter, which specifies the text, is a raw 8-bit string that 
is directly copied into the AVI file, and is _not_ UTF-8 -- this is because AVI itself doesn't have a 
viable way to indicate the code page encoding of such strings.

Object: VirtualDub.video.filters
--------------------------------
void Clear();

Removes all filter instances from the filter list.

void Add(string filter); [VirtualDub 1.4c or older]
int Add(string filter); [VirtualDub 1.4d or newer]

Adds a new instance of the specified filter to the bottom of the video filter list.
Starting with VirtualDub 1.4d, this function returns the instance number of the added filter.

Object: VirtualDub.video.filters.instance[nFilt]
------------------------------------------------
nFilt is a zero-based index of the filter instance to be modified.
void Remove();

Removes the selected filter from the list.  Note that this changes the indices of the filters 
after it.
int GetClipping(int var);
void SetClipping(int x1, int y1, int x2, int y2);

Gets or sets filter input clipping parameters.  var ranges from 0 to 3 and corresponds to x1, y1, 
x2, and y2 respectively.  All values are in pixels from the edge.
... Config(...);

This is a function that may be provided by the video filter.  It is required for a filter to work 
in batch mode if the filter has user-definable parameters.  However, no syntax is enforced on this member 
and the parameter syntax will vary from filter to filter.
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Filter configuration functions
------------------------------
2:1 reduce No configuration.
2:1 reduce (HQ) No configuration.
3x3 average No configuration.
blur No configuration.
blur more No configuration.

box blur void Config(int width, int power);
brightness/contrast void Config(int brightness, int contrast);
deinterlace void Config(int mode);

0=blend, 1=dup1, 2=dup2, 3=discard1, 4=discard2, 5=unfold, 6=fold
emboss void Config(int direction, int height);
field swap No configuration.
fill void Config(int x1, int y1, int x2, int y2, int color);

x1...y2: insets in pixels, color is 24-bit RGB
(like HTML but with 0x instead of #)

flip horizontally No configuration.
flip vertically No configuration.

general convolution void Config(int c0, int c1, int c2, int c3, int c4, int c5, int c6, int c7, int c8, 
int bias, int clip);
grayscale No configuration.
hsv void Config(int h, int s, int v);

h: Hue adjustment, 0...65535 -> 0...360 degrees
s: Saturation multiplier, 0...131072 -> 0-200%
v: Value multiplier, 0...131072 -> 0-200%

invert No configuration.
levels void Config(int inputlo, int inputhi, int gammacorr, int inputmid, int outputlo, 

int outputhi);
void Config(int inputlo, int inputhi, int gammacorr, int inputmid, int outputlo, 

int outputhi, int lumaonly);
All are 0-255 except gammacorr which is a 24-bit fixed point fraction.  If 

lumaonly is nonzero the filter works in luma instead of RGB.

logo void Config(string logoFile, int xpos, int ypos, int alphaEnable, int 
premultDisable, int xj, int yj, int opacity);

void Config(string logoFile, int xpos, int ypos, string alphaFile, int 
premultDisable, int xj, int yj, int opacity);

logoFile: filename of logo image
xpos, ypos: position in pixels from placement origin (see xj/yj below)
alphaEnable: non-zero to enable per-pixel alpha blending based on alpha channel
premultDisable: non-zero to use non-premultiplied alpha

xj: horiz. justification
0 - left
1 - center
2 - right
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yj: vert. justification
0 - top
1 - middle
2 - bottom

opacity: constant alpha to apply over entire logo, 0...65536

null transform No configuration.
resize void Config(int w, int h, int/string mode);

void Config(int w, int h, int/string mode, int framew, int frameh, int color);
filter modes:

0 "nearest" or "point"
1 "bilinear"
2 "bicubic"
3 (precise bilinear, no string)
4 (precise bicubic, no string)

rotate void Config(int mode);
0=left90, 1=right90, 2=180

rotate2 void Config(int angle, int filtmode, int color, int expandbounds);

angle: 24-bit fraction (16777216 = 360d)
filtmode: 0=point, 1=bilinear, 2=bicubic

sharpen void Config(int power);
smoother void Config(int threshold, int use_blur_pass);
threshold void Config(int threshold);
temporal softener No configuration.
(motion blur)
temporal smoother void Config(int power);
TV void Config(mode);

0=Y, 1=I, 2=Q, 3=avg3x3, 4=avg5x5, 5=5x5+tmp, 6=chromaup, 7=chromadown

other filters
-------------
The version of Donald Graft's smart deinterlacer bundled with VirtualDub:

void Config(int motion_only, int blend, int luma_threshold, int scene_threshold);

My subtitler:
void Config(int enable_supersampling, string script_filename);

Others, you'll have to ask the filter author.

Object: VirtualDub.audio.filters                   (VirtualDub 1.5+)
--------------------------------------------------------------------
This subobject controls the filter graph for advanced audio mode.
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void Clear();
Removes all filters from the advanced filter graph.

int Add(string name);
Adds an audio filter to the graph.  The name of the filter is UTF-8 encoded.  Returns the ID# of 

the filter.

void Connect(int srcfilt, int srcpin, int dstfilt, int dstpin);
Establishes a connection between two filters, from an output pin on a source filter 

(srcfilt/srcpin) to an input pin on a destination filter (dstfilt/dstpin).  Both filter and pin numbers 
are zero-based.

Object: VirtualDub.audio.filters.instance[nFilt]   (VirtualDub 1.5+)
--------------------------------------------------------------------
nFilt is the zero-based index of the audio filter in the filter graph.

void SetInt(int parmidx, int value);
void SetLong(int parmidx, int valuehi, int valuelo);
void SetDouble(int parmidx, int valuehi, int valuelo);
void SetString(int parmidx, string value);
void SetRaw(int parmidx, int length, string base64value);

Sets configuration parameters for an audio filter.
"parmidx" is the index of the configuration parameter.
For long (64-bit int) and double (64-bit FP) parameters, the value is broken into two 32-bit 

integers, with the high 32-bits being passed first.
For string parameters, the string value is a Unicode string encoded as UTF-8.
For raw (binary) parameters, "length" refers to the raw unencoded length in bytes, and 

"base64value" is the binary data encoded using MIME BASE64 encoding.
void SetLong(int parmidx, long value);        [VirtualDub 1.6+]
void SetDouble(int parmidx, double value);    [VirtualDub 1.6+]

These overloads are equivalent to the raw methods of the same name
in 1.5, except they take long and double values directly.

=======================
Audio filter parameters
=======================
These are the configuration parameters for the audio filters built into VirtualDub 1.5.6.

Filter Index/type Description
---------------------------------------------------
Gain 0 (double) Gain factor (-8.0 to 8.0)
New rate 0 (uint32) New frequency in Hz
Ratty pitch shift 0 (double) Pitch shift ratio (0.5 to 2.0)
Lowpass/highpass 0 (uint32) Cutoff frequency in Hz

1 (uint32) Filter taps (approx quality)
Resample 0 (uint32) New frequency in Hz

1 (uint32) Filter taps (approx quality)
Stretch 0 (double) Stretch ratio (0.25 to 4.0)
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===========================
VirtualDub.jobs file format
===========================
Jobs in VirtualDub are stored as scripts in plain text format, with additional control parameters stored 

as specially-formatted text strings.  It is best to let VirtualDub modify its job control file instead of 
modifying it directly, but it may be useful to do this with a text editor or with an external program.
All control lines are comment lines with a token starting with a dollar sign ($), and optionally 

followed by arguments, with only one control op per line:
// $numjobs 3
This line tells VirtualDub that there are three jobs in this file.  Since all non-scripting commands are 

stored as comments, it is possible to execute the job file as an ordinary script, although error control 
is different in job control -- individual sections are executed as separate scripts and errors are 
isolated between them, so that an error in one script does not prevent others from executing.
Each additional job in the file is of the form:

// $job "Job 1"
// $input "f:\mkrtest.avi"
// $output "f:\test.avi"
// $state 2
// $start_time 01c01df3 c2eb68c0
// $end_time 01c01df3 eb3d85b0
// $script
<script commands>
// $endjob

Notice that the job ($job), input filename ($input), and output filename ($output) arguments are strings 
but do not contain escapes.  Also, the input and output filenames are used for display purposes; they 
should match the script but changing them will not change the files used.
$state controls the execution state of the job entry:
    0 WAITING Job is ready to be executed.
    1 INPROGRESS Job is currently being executed.  If VirtualDub sees this tag when loading a jobs 

file, it assumes that the operation crashed, and the job is switched to the ABORTED state.
    2 DONE Job is completed and does not need to be executed.
    3 POSTPONED Job is ready to be executed but has been postponed by the user and thus should be 

skipped.
    4 ABORTED Job was started but did not complete properly. VirtualDub won't reattempt this job 

unless it is switched to WAITING by the user.
    5 ERR     An error was enountered while executing this job. VirtualDub won't reattempt 

this job unless it is switched to WAITING by the user.
$start_time and $stop_time contain the starting and stopping times, respectively, of the given job.  The 

times are stored as two 32-bit hexa- decimal values, with the first being the dwHighDateTime value of a 
Win32 FILETIME structure, and the second being dwLowDateTime.  Zero for both values indicates no time for 
that entry.  It makes no sense to have a stop time without a start time.

The actual Sylia script is bracketed by the $script and $endjob markers; this means that the script must 
come last, after all job parameter commands.  Any command is actually valid in this script, including 
multiple operations; this may be helpful if multiple operations need to be sequenced, and subsequent 
operations can't be done if the initial ones fail.  Scripts run with whatever environment exists at the 
time of invocation, so the script needs to set all parameters appropriately, and can't assume 
configuration variables will be set in any particular manner.
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L ISTE DES RACCOURCIS DE V IRTUALDUB

Ouvrir un fichier
F2 Ré-ouvrir le fichier 
Barre d'espacement Visualiser la vidéo d'entrée (source)
Entrée Visualiser la vidéo filtrée
F5 Visualiser le résultat depuis le début
F7 Sauvegarde au format AVI

Sauvegarde à l'ancien format AVI
Fermer le fichier vidéo ouvert

Ctrl+Maj+F7 Sauvegarde différée au format AVI
Charger les paramètres du traitement
Sauvegarder les paramètres du traitement
Appel centre de gestion des tâches différées

Annuler
Répéter
Couper
Copier
Coller

Suppr Supprimer
Vider la sélection
Tout sélectionner

Début Indiquer le début de la sélection en fonction de la position du curseur
Fin Indiquer la fin de la sélection en fonction de la position du curseur

F9 Valider l''affichage de la vidéo en entrée
F10 Valider l''affichage de la vidéo filtrée en sortie

Afficher la vidéo décompressée en sortie
F8 Afficher le compte-rendu

Aller au début de la vidéo
Aller à la fin de la vidéo
Aller à l'image précédente
Aller à l'image suivante
Aller à l'image clef précédente
Aller à l'image clef suivante
Reculer de 50 images
Avancer de 50 images
Aller à l'image perdue précédente
Aller à l'image perdue suivante
Aller à la séquence précédente
Aller à la séquence suivante
Aller au début de la sélection
Aller à la fin de la sélection
Aller à la scène précédente
Aller à la scène suivante
Aller à l'image xxx

Ctrl+0 

Maj + F7
Crtl + W

Ctrl+L
Ctrl+S 
F4 

Ctrl+Z
Ctrl+Y
Ctrl+X
Ctrl+C
Ctrl+V

Ctrl+D
Ctrl+A

Maj+F10

Maj+F8 Afficher le « profiler » temps réel

Ctrl+Gauche 
Ctrl+Droite 
Gauche 
Droite 
Maj+Gauche 
Maj+Droite 
Alt+Gauche 
Page Suivante 
Maj+Accent circonflexe 
Maj+Cédille 
Maj+, 
Maj+. 
Accent circonflexe 
Cédille 
Ctrl+Maj+Gauche 
Ctrl+Maj+Droite 
Ctrl+G
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Activer le sélecteur de filtres vidéo
Débit de la vidéo en images par secondes
Choix des codecs de compression vidéo
Copier l'image source dans le presse-papiers
Copier l'image filtrée de sortie dans le presse-papiers

Entrelacement
Conversion audio

F1 Accès à l'aide CHM de VirtualDub

Ctrl+F
Ctrl+R
Ctrl+P
Ctrl+1 
Ctrl+2 

Ctrl+I 
Ctrl+N
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V IDÉOS, IMAGES ET MUSIQUES UTILISÉES DANS CETTE DOCUMENTATIONS

Merci aux auteurs et aux artistes qui mettent leurs œuvres à la disposition du public.

V IDÉOS

POPEYE  - SPOOKY  SW ABS

Popeye - Spooky Swabs

• Distributed by: Paramount Studios

• Cartoon Characters: Popeye, Olive Oyl, Ghosts.

• Directed By Isadore Sparber.

• Animated By Tom Johnson, Frank Endres.

• Written By Larz Bourne.

• Originally Released on August 09, 1957.

Site : http://www.youtube.com/watch?v=tHsz0egoQ2E    

Informations sur Popeye - Spooky Swabs :  http://en.wikipedia.org/wiki/Spooky_Swabs  

Licence : Domaine public

MUSIQUES

1FREE7W AV.W AV

Site : http://www.hooverwebdesign.com/sounds/ 

59._ IN IT IAL_ZEND .MP3
Auteur : Dhalius

Making music since 1997, professionally since 2007, based on jamendo.com (artist) but still making 
music for various projects, and making collab projects with many artists and compilations around the 
world.

Œuvre : DHALIUS.- INITIAL ZEND (Fast moving electronic theme created on fl4).

Site de téléchargement : http://opsound.org/artist/dhalius/ 

Lien direct : 
http://www.archive.org/download/AdrianAlonsoDiazRangelDhaliusElectronicMusic/59._initial_zend.mp3 

Licence : http://creativecommons.org/licenses/by-sa/2.5/ 

http://creativecommons.org/licenses/by-sa/2.5/
http://www.archive.org/download/AdrianAlonsoDiazRangelDhaliusElectronicMusic/59._initial_zend.mp3
http://opsound.org/artist/dhalius/
http://www.hooverwebdesign.com/sounds/
http://en.wikipedia.org/wiki/Spooky_Swabs
http://www.youtube.com/watch?v=tHsz0egoQ2E
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LES PRINCIPAUX  LECTEURS V IDÉO SOUS W INDOWS

LECTEUR W INDOW S MEDIA 12
C'est le lecteur de Microsoft qui après de nombreuses comparaisons sur différents systèmes d'exploitation (Linux, 

Apple Mac OS X Snow Leopard) donne le meilleur rendu : netteté, décodage très rapide sans à-coup, nombreux 
formats supportés.

http://windows.microsoft.com/fr-fr/windows7/products/features/windows-media-player-12  

http://windows.microsoft.com/fr-FR/windows7/Getting-started-with-Windows-Media-Player  

MEDIA PLAYER CLASSIC

Fourni avec les installateurs décrits au début de cette documentation il donne de bons résultats mais a des 
problèmes de décodage sur des vidéos de 1920*1080 (décodage non linéaire qui donne des à-coups) sur Windows 
7 64 bits .

http://sourceforge.net/projects/guliverkli/files/  

VLC
C'est un lecteur très populaire et multi-plateformes (Windows, Linux, OS X, etc.). Il donne aussi des à-coups lors 

du décodage de vidéos de 1920*1080 pixels sur Windows 7 64 bits.

Ce lecteur possède aussi de nombreuses autres possibilités : conversions, streaming, etc.

http://www.videolan.org/  

QUICKT IME 7 D 'APPLE

Ce lecteur reconnaît peu de formats. Le rendu est relativement bon sur OS X Snow Leopard et sur Windows 7 64 
bits. L'installation n'est pas transparente et on se retrouve avec d'autres programmes installés en plus de 
QuickTime !

http://www.apple.com/fr/quicktime/download/ 

D IVX PLAYER

Ce lecteur peut lire de nombreux formats dont les fichiers HD compressés en H.264.

http://www.divx.com/fr/software/divx-plus/player 

COMPARAISON  DE DIFFÉRENTS LECTEURS

http://en.wikipedia.org/wiki/Comparison_of_video_player_software  

http://en.wikipedia.org/wiki/Comparison_of_video_player_software
http://www.divx.com/fr/software/divx-plus/player
http://www.apple.com/fr/quicktime/download/
http://www.videolan.org/
http://sourceforge.net/projects/guliverkli/files/
http://windows.microsoft.com/fr-FR/windows7/Getting-started-with-Windows-Media-Player
http://windows.microsoft.com/fr-fr/windows7/products/features/windows-media-player-12
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OUTILS DIVERS

TRAITEMENT D ' IMAGES

Gimp : http://www.gimp.org/ , notre site http://www.aljacom.com/~gimp/ 

Apophysis, générateur de fractales :   http://sourceforge.net/projects/apophysis/files/  

LOGICIELS 3D
Blender : http://www.blender.org/ 

Art of Illusion : http://www.artofillusion.org/  

TRAITEMENT SON 
Audacity : http://audacity.sourceforge.net/  

Version bêta Windows 7 : http://audacity.sourceforge.net/download/beta_windows  

CONVERTISSEUR  VERS FORMAT  THEORA

Ce convertisseur ffmpeg vers theora fonctionne en lignes de commandes.

Site : http://v2v.cc/~j/ffmpeg2theora/  

Exemples de commandes : http://v2v.cc/~j/ffmpeg2theora/examples.html 

Ce programme est dans l'archive 7Zip que nous fournissons.

Usage :
ffmpeg2theora 0.26 - Xiph.Org libtheora 1.1 20090822 (Thusnelda)
  Usage: ffmpeg2theora [options] input
General output options:
  -o, --output           alternative output filename
      --no-skeleton      disables ogg skeleton metadata output
      --seek-index      enables keyframe index in skeleton track

http://v2v.cc/~j/ffmpeg2theora/examples.html
http://v2v.cc/~j/ffmpeg2theora/
http://audacity.sourceforge.net/download/beta_windows
http://audacity.sourceforge.net/
http://www.artofillusion.org/
http://www.blender.org/
http://sourceforge.net/projects/apophysis/files/
http://www.aljacom.com/~gimp/
http://www.gimp.org/
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  -s, --starttime        start encoding at this time (in sec.)
  -e, --endtime          end encoding at this time (in sec.)
  -p, --preset           encode file with preset. Right now there is preview, pro and videobin. 

Run 'ffmpeg2theora -p info' for more informations

Video output options:
  -v, --videoquality     [0 to 10] encoding quality for video (default: 6) use higher values for 

better quality
  -V, --videobitrate     encoding bitrate for video (kb/s)
      --soft-target      Use a large reservoir and treat the rateas a soft target; rate control 

is less strict but resulting quality is usually higher/smoother overall. 
Soft target also allows an optional -v setting to specify a minimum 
allowed quality.

      --two-pass         Compress input using two-pass rate control This option requires that the 
input to the to the encoder is seekable and performs both passes 
automatically.

      --first-pass <filename> Perform first-pass of a two-pass rate controlled encoding, saving pass 
data to <filename> for a later second pass

      --second-pass <filename> Perform second-pass of a two-pass rate controlled encoding, reading 
first-pass data from <filename>.  The first pass data must come from a 
first encoding pass  using identical input video to work properly.

      --optimize         optimize video output filesize (slower) (same as speedlevel 0)
      --speedlevel       encoding is faster with higher values the cost is quality and bandwidth
                         - 0: Slowest (best)
                         - 1: Enable early skip (default)
                         - 2: Disable motion compensation
  -x, --width            scale to given width (in pixels)
  -y, --height           scale to given height (in pixels)
      --max_size         scale output frame to be within box of
                         given size, height optional (%d[x%d], i.e. 640x480)
      --aspect           define frame aspect ratio: i.e. 4:3 or 16:9
      --pixel-aspect     define pixel aspect ratio: i.e. 1:1 or 4:3, overwrites frame aspect 

ratio
  -F, --framerate        output framerate e.g 25:2 or 16
      --croptop, --cropbottom, --cropleft, --cropright
                         crop input by given pixels before resizing
  -K, --keyint           [1 to 2147483647] keyframe interval (default: 64)
  -d --buf-delay <n>     Buffer delay (in frames). Longer delays allow smoother rate adaptation 

and provide better overall quality, but require more client side 
buffering and add latency. The default value is the keyframe interval 
for one-pass encoding (or somewhat larger if --soft-target is used) and 
infinite for two-pass encoding. (only works in bitrate mode)

      --no-upscaling     only scale video or resample audio if input is bigger than provided 
parameters

Video transfer options:
  --pp                   Video Postprocessing, denoise, deblock, deinterlacer use --pp help for a 

list of available filters.
  -C, --contrast         [0.1 to 10.0] contrast correction (default: 1.0)
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Note: lower values make the video darker.
  -B, --brightness       [-1.0 to 1.0] brightness correction (default: 0.0)

Note: lower values make the video darker.
  -G, --gamma            [0.1 to 10.0] gamma correction (default: 1.0)

Note: lower values make the video darker.
  -Z, --saturation       [0.1 to 10.0] saturation correction (default: 1.0)

Note: lower values make the video grey.

Audio output options:
  -a, --audioquality     [-2 to 10] encoding quality for audio (default: 1) use higher values for 

better quality
  -A, --audiobitrate     [32 to 500] encoding bitrate for audio (kb/s)
  -c, --channels         set number of output channels
  -H, --samplerate       set output samplerate (in Hz)
      --noaudio          disable audio from input
      --novideo          disable video from input

Input options:
      --deinterlace      force deinterlace, otherwise only material marked as interlaced will be 

deinterlaced
  -f, --format           specify input format
      --inputfps fps     override input fps
      --audiostream id   by default the first audio stream is selected, use this to select 

another audio stream
      --videostream id   by default the first video stream is selected, use this to select 

another video stream
      --nosync           do not use A/V sync from input container. try this if you have issues 

with A/V sync
Subtitles options:
      --subtitles file      use subtitles from the given file (SubRip (.srt) format)
      --subtitles-encoding encoding    set encoding of the subtitles file supported are utf-8, utf8, 

iso-8859-1, latin1
      --subtitles-language language    set subtitles language (de, en_GB, etc)
      --subtitles-category category    set subtitles category (default "subtitles")
      --subtitles-ignore-non-utf8      ignores any non UTF-8 sequence in UTF-8 text
      --nosubtitles                    disables subtitles from input

Metadata options:
      --artist           Name of artist (director)
      --title            Title
      --date             Date
      --location         Location
      --organization     Name of organization (studio)
      --copyright        Copyright
      --license          License
      --contact          Contact link
      --nometadata       disables metadata from input
      --no-oshash        do not include oshash of source file(SOURCE_OSHASH)

Keyframe indexing options:
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      --index-interval <n>  set minimum distance between indexed keyframes to <n> ms (default: 
2000)

      --theora-index-reserve <n>   reserve <n> bytes for theora keyframe index
      --vorbis-index-reserve <n>   reserve <n> bytes for vorbis keyframe index
      --kate-index-reserve <n>     reserve <n> bytes for kate keyframe index

Other options:
  -P, --pid fname        write the process' id to a file
  -h, --help             this message
      --info             output json info about input file, use -o to save json to file

Examples:
  ffmpeg2theora videoclip.avi (will write output to videoclip.ogv)
  ffmpeg2theora videoclip.avi --subtitles subtitles.srt (same, with subtitles)
  cat something.dv | ffmpeg2theora -f dv -o output.ogv -
  Encode a series of images:
    ffmpeg2theora frame%06d.png -o output.ogv
  Live streaming from V4L Device:
    ffmpeg2theora /dev/video0 -f video4linux --inputfps 15 -x 160 -y 128 -o - \
     | oggfwd icast2server 8000 password /theora.ogv
  Live encoding from a DV camcorder (needs a fast machine):
    dvgrab - | ffmpeg2theora -f dv -x 352 -y 288 -o output.ogv -
  Live encoding and streaming to icecast server:
    dvgrab --format raw - \
     | ffmpeg2theora -f dv -x 160 -y 128 -o /dev/stdout - \
     | oggfwd icast2server 8000 password /theora.ogv

FFDSHOW

ffdshow is an advanced DirectShow filter and VFW codec that supports many audio and video formats. For 
example: H.264, MPEG-4, MPEG-2, H.263, VP3, VP6, Theora, MJPEG, SVQ3, MP3, AC3, DTS, E-AC3, AAC, 
and Vorbis.

http://www.ffdshow.info/ 

http://fr.wikipedia.org/wiki/Ffdshow 

http://ffdshow-tryout.sourceforge.net/  (Fork plus à jour)

FFMPEG

FFmpeg is a complete, cross-platform solution to record, convert and stream audio and video. It includes 
libavcodec - the leading audio/video codec library.

http://ffmpeg.org/ 

http://ffmpeg.arrozcru.org/wiki/index.php?title=Links (versions Windows)

http://fr.wikipedia.org/wiki/FFmpeg 

http://fr.wikipedia.org/wiki/FFmpeg
http://ffmpeg.arrozcru.org/wiki/index.php?title=Links
http://ffmpeg.org/
http://ffdshow-tryout.sourceforge.net/
http://fr.wikipedia.org/wiki/Ffdshow
http://www.ffdshow.info/
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AVIDEMUX

Avidemux est un superbe outil pour découper, appliquer des filtres et encoder. Il est multiplateforme. 

L'encodage est très rapide, y-compris sous Windows (bonne gestion des processeurs).

Sites : http://fixounet.free.fr/avidemux/ ,  http://avidemux.sourceforge.net/  

Documentation : http://www.avidemux.org/admWiki/index.php?title=Main_Page   

Forum : http://avidemux.org/admForum/   

Téléchargement : http://fixounet.free.fr/avidemux/download.html 
     http://sourceforge.net/projects/avidemux/files/  

Voir chapitre « Enlever des séquences d'une vidéo, le fichier n'est pas un AVI  » page 147.

Une version est fournie avec l'archive que nous proposons.

http://sourceforge.net/projects/avidemux/files/
http://fixounet.free.fr/avidemux/download.html
http://avidemux.org/admForum/
http://www.avidemux.org/admWiki/index.php?title=Main_Page
http://avidemux.sourceforge.net/
http://fixounet.free.fr/avidemux/
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ENREGISTREUR DE VIDÉOS HAUPPAUGE HD PVR
Ce matériel permet d'enregistrer des vidéos jusqu'à 1080i en H.264.

Chez nous il est connecté derrière un décodeur satellite et sert de magnétoscope.

Diagramme de connexion que nous utilisons :

    Led de télécommande pour changement de canal du décodeur

        Video YPbPr + son stéréo

audio S/PDIF 

optique (non testé)

pour son Dolby 5.1

USB

HDMI Ethernet (RJ 45)

Site en français : http://www.hauppauge.fr/site/products/data_hdpvr.html  

D IFFUSER  THEORA SUR INTERNET

ITheora est un script en PHP permettant de diffuser en ligne des fichiers multimédias aux formats theora (ogv) et 
vorbis (ogg).

Il gère également les listes de lecture et les podcasts.

Il est conçu pour être simple à installer et à utiliser et pourra convenir aussi bien au blogger qu'au webmaster 
averti.

http://itheora.org/ 

Décodeur satellite

Hauppauge
HD PVR

Ordi. en réseau
(Acquisition vidéo,

programmation enregistrement
 différé, etc.)

TV

http://itheora.org/
http://www.hauppauge.fr/site/products/data_hdpvr.html
http://fr.wikipedia.org/wiki/Hdmi
http://fr.wikipedia.org/wiki/S/PDIF
http://fr.wikipedia.org/wiki/YPbPr
http://fr.wikipedia.org/wiki/Diode_%C3%A9lectroluminescente
http://fr.wikipedia.org/wiki/H.264
http://fr.wikipedia.org/wiki/1080i
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L IENS

Site de Virtualdub en français (léger retard de mise à jour) : http://www.virtualdub-fr.org/ où il existe une 
ancienne version de Virtualdub en français 1.9.6 (http://www.virtualdub-fr.org/telechargement).  

Didacticiels en français sur VirtualDub : http://www.cestfacile.org/guides_virtualdub.htm   

Convertir des fichiers Quicktime, Realvideo et Windows Media en AVI : http://www.virtualdub-
fr.org/2008/tutoriaux-96-convertir-des-fichiers-movrmwmv-en-avi.html   

Encoder en X264 : http://www.siteduzero.com/tutoriel-3-8425-encoder-en-x264.html  

Convertir un fichier video en .avi avec xvid et lame. : http://jeremy1000.free.fr/tutoriaux/conversion/   

Comparaison des formats : http://en.wikipedia.org/wiki/Comparison_of_container_formats  

Comparaison de codecs vidéo : http://en.wikipedia.org/wiki/Comparison_of_video_codecs  

Comparaison de codecs audio : http://en.wikipedia.org/wiki/Comparison_of_audio_codecs  

Windows Live Movie Maker : http://www.01net.com/contenu/2562/ta_fiches/maitrisez-les-nouveautes-de-live-
movie-maker-14-729-1  

http://www.01net.com/contenu/2562/ta_fiches/maitrisez-les-nouveautes-de-live-movie-maker-14-729-1
http://www.01net.com/contenu/2562/ta_fiches/maitrisez-les-nouveautes-de-live-movie-maker-14-729-1
http://en.wikipedia.org/wiki/Comparison_of_audio_codecs
http://en.wikipedia.org/wiki/Comparison_of_video_codecs
http://en.wikipedia.org/wiki/Comparison_of_container_formats
http://jeremy1000.free.fr/tutoriaux/conversion/
http://www.siteduzero.com/tutoriel-3-8425-encoder-en-x264.html
http://www.virtualdub-fr.org/2008/tutoriaux-96-convertir-des-fichiers-movrmwmv-en-avi.html
http://www.virtualdub-fr.org/2008/tutoriaux-96-convertir-des-fichiers-movrmwmv-en-avi.html
http://www.cestfacile.org/guides_virtualdub.htm
http://www.virtualdub-fr.org/telechargement
http://www.virtualdub-fr.org/
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AU SUJET DE CETTE DOCUMENTATION

La documentation « Débuter avec Virtualdub » est sous licence CC BY SA :

http://creativecommons.org/licenses/by-sa/3.0/deed.fr_CA  

© SAMJ  2009

Pour signaler des erreurs, améliorer cette documentation vous pouvez contacter sylvie.alexandre@aljacom.com 

Si vous souhaitez obtenir le document au format OO.o (mise en page au format letter) ayant servi à obtenir le 
PDF de cette documentation, contactez-nous.
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Merci à tous les auteurs des logiciels libres, aux artistes, aux auteurs de documents techniques, aux traducteurs 
des documents cités dans cette notice, en particulier les anciennes traductions françaises de VirtualDubMod et 
Virtualdub (en italique dans ce texte) :
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http://trad-fr.com/
http://philou-traductions.fr/
mailto:sylvie.alexandre@aljacom.com
http://creativecommons.org/licenses/by-sa/3.0/deed.fr_CA
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