Aller au contenu


Debian : premières installations

Debian installation install graphique

  • Vous ne pouvez pas répondre à ce sujet
47 replies to this topic

#31 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 12 août 2013 - 19:26

Avec la version "KDE", aucun problème, cela fonctionne très bien. J'ai l'impression de me retrouver sous " Simply Mepis " d'il y a 4-5 ans. Par contre, impossible de passer via le router et son hub. Problème de configuration que je ne maîtrise pas. Un petit coup de main si possible!? Merci...

Ceci peut arriver quand la distribution n'a pas trouvé/ne contient pas le pilote d'un périphérique. J'ai eu le cas sur un ordinateur portable récent. La seule solution est de chercher le pilote par soi même ... s'il existe pour Linux. Quel est le modèle de ton "Belkin" de ta carte réseau ?

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#32 vigen

vigen

    Hardcore Papa

  • Tonton Flingueur
  • PipPipPipPipPipPipPipPipPip
  • 6 440 Messages :
  • Gender:Male
  • Location:Normandie

Posté 12 août 2013 - 20:01

Je rajouterais a l'avis de mon éminent collègue !!! :D

 

Éventuellement:

 

Rajouter a ton sources.list:

 

deb http://ftp.fr.debian.org/debian wheezy main contrib non-free

 

Puis, ouvrir le terminal:

 

apt-get update
apt-get install firmware-ralink wireless-tools

 

Alors, il est vrai que c'est pour un routeur "sans fil", mais cela résoud pas mal de soucis apparemment...

 

Cela ne coute rien a essayer ;)



#33 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 13 août 2013 - 03:17

Rajouter a ton sources.list:

 

deb http://ftp.fr.debian.org/debian wheezy main contrib non-free

 

Puis, ouvrir le terminal:

 

apt-get update
apt-get install firmware-ralink wireless-tools

Merci pour ce "rajout".

 

Un lien pour les sources de la version 7, "Wheezy" : Debian Wheezy sources.list

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#34 kool56

kool56

    Phobosien

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 863 Messages :

Posté 13 août 2013 - 06:30

Bonjour tout le monde,

 

Seul le câble RJ 45 est utlisé. No "Wireless" ou autre "WIFI" :

 

Voici le modèle du routeur "Belkin" ==> http://www.amazon.co...r/dp/B00008VF4L (modèle en ma possession)

314M79G7QCL._SX300_.jpg

 

Nouveau modèle ==> http://www.belkin.co...ticle?rnId=7033

 

Bonne journée et merci d'avance


"Les autres, c'est nous" de moi.

#35 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 13 août 2013 - 10:42

Seul le câble RJ 45 est utlisé. No "Wireless" ou autre "WIFI" :

 

Voici le modèle du routeur "Belkin" ==> http://www.amazon.co...r/dp/B00008VF4L (modèle en ma possession)

Selon ce que je lis, le Belkin F5D5231-4 fonctionne aussi bien avec Windows que Mac OS X et Linux.

Voici le -> Belkin F5D5231-4 Cable/DSL Gateway Router <- sur le site de Belkin USA. Tu peux télécharger le "firmware" et suivre les instructions.

Fais attention à ce qu'il n'y ait rien d'autre à l'adresse 192.168.2.1 (adresse par défaut pour ce routeur).

 

Questions peut-être très bêtes ...

.. Quel est le modèle du boîtier fourni par ton FAI ? Y a-t-il déjà un routeur dans le boîtier fourni par ton FAI ? Si oui, à quoi te sert le routeur Belkin ? Est-ce une simple sécurité complémentaire contre les agressions ?

.. Qu'as-tu comme switch (hub) ? SI le boîtier fourni par ton FAI contient un routeur, pourquoi ce switch est-il connecté au routeur Belkin ?

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#36 kool56

kool56

    Phobosien

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 863 Messages :

Posté 13 août 2013 - 13:13

@Txon,

 

Le modèle du boîter du FAI n'a jamais pu vraiment être déterminé. Il semblerait que cela soit un SAGEM en VDSL ou ADSL2

Aucune documentation complète n'a été fournie avec ce modem dont le pare-feu interne a été désactivé au profit de celui du routeur

sur lequel le hub (Belkin F5D5141-5V3)  est branché ( fiche spécifique à l'arrière + bouton à enfoncer au routeur).

 

Par ailleurs, le FAI souhaitait ardemment que l'installation soit faite en " WIFI" ce qui lui a été refusé.

En fait, cela lui aurait permis d'user de ce boîter pour son système "FON"

==> http://www.belgacom....ee_hotspots_res

système auquel je ne souhaitais pas adhérer car il eut fallu que le boîter du FAI reste allumé 24h/24 et que le FAI y ait accès pour les "mises à jour".

 

Enfin, le FAI fournit 1 boîtier avec deux connections RJ45 d'où le routeur + le hub. Après d'autres renseignements pris, la seule solution eut été d'acquérir, semble-t-il, une FRITZBOX ==> http://www.fritzbox.eu/en/index.php .

Via le routeur il y a une perte de vitesse en bande passante; cela m'est égal ce qui pourrait être évité avec la Fritzbox, paraît-il...!

 

N'empêche que je trouve curieux que sous Ubuntu, ce problème ne se pose pas: branchement sur le hub et "hop" cela fonctionne...

 

Sinon, rien à redire quant cet OS que je ne connaissais pas. Tout fonctionne bien; Libre office, Clementine, Audacity,etc...


"Les autres, c'est nous" de moi.

#37 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 13 août 2013 - 16:07

Attention ! J'ai écrit une connerie plus haut concernant le routeur Belkin. J'ai du prendre un coup de chaleur (c'est ça les petits vieux :old: ).

Les paramètres de connexion à Internet ne prennent peut-être pas en compte le routeur Belkin et ses paramètres/caractéristiques.

 

@Txon,

 

Le modèle du boîter du FAI n'a jamais pu vraiment être déterminé. Il semblerait que cela soit un SAGEM en VDSL ou ADSL2

Aucune documentation complète n'a été fournie avec ce modem dont le pare-feu interne a été désactivé au profit de celui du routeur

sur lequel le hub (Belkin F5D5141-5V3)  est branché ( fiche spécifique à l'arrière + bouton à enfoncer au routeur).

 

... ... ... ...

 

N'empêche que je trouve curieux que sous Ubuntu, ce problème ne se pose pas: branchement sur le hub et "hop" cela fonctionne...

Sinon, rien à redire quant cet OS que je ne connaissais pas. Tout fonctionne bien; Libre office, Clementine, Audacity,etc...

 

Pourquoi la connexion à Internet se fait-elle en branchement direct sur la box et pas lorsque le routeur est interposé ?

.. Le port sélectionné pour la connexion serait-il bloqué par le routeur ? Port 3306 ?

.. Quelle est l'adresse du routeur Belkin dans ton réseau, 192.168.2.1 ? Quelle est l'adresse de la box, 192.168.1.1 ? Quelle adresse figure dans les paramètres de ta connexion eth0 (ou eth1 ...)

 

As-tu noté une impossibilité d'accéder à Internet dès l'installation de Debian ? Comment ton PC était-il connecté à ce moment là ?

 

D'autre part, as-tu essayé de connecter directement le "hub" sur ta box et ton PC sur ce switch ?

 

@+

Quelques liens ...

Faire marcher le connexion à Internet (Formation Debian via ecp)

Pare-feu et partage de connexion Internet (Formation Debian via ecp)


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#38 kool56

kool56

    Phobosien

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 863 Messages :

Posté 13 août 2013 - 16:19

@Txon,

 

Venant d'installer la version xfce, très agréable au demeurant, le branchement du hub sur la seconde prise RJ 45 du boîter du FAI et ensuite, la connection du RJ 45 depuis ce hub vers le PC (sur lequel Debian 7.1.0 xfce) permet de naviguer. donc etho fonctionne en ce cas...

 

Pour le reste, il faudrait que j'entre à nouveau et dans le boîter du FAI et le routeur .

 

Une capture d'écran faite à l'instant: (Bizarre, pourtant je suis sous debian 7.1.0 xfce!???°

647164Capturedcran1130813172710.png

 

 

 

AJOUT: J'ai lu les deux articles repris plus haut. c'est trop technique pour moi. Cela fonctionne ainsi pour le moment.

càad le hub branché sur la seconde prise RJ 45 du boîter du FAI. Un autre hub sera placé sur le routeur.

 

Remarque: En tous les cas, je suis vraiment sous le charme de cet OS. Clementine, Audacity, Ok pour l'enregistrement de la musique en streaming. Installation des dictionnaires pour Libre Office = OK . Dommage que PavuControl fasse un peu des siennes. Le Mixer (réglage des volumes = OK) n'est pas top...Mais cela me suffit pour l'heure. trop de MS dans les doigts sans doute...


"Les autres, c'est nous" de moi.

#39 Vocal

Vocal

    Marsonaute

  • Zimien
  • PipPip
  • 12 Messages :

Posté 14 août 2013 - 07:39

Salut, Comment est l'installation des pilotes graphiques, sont ils en paqués ou on doit compilier soi meme? :-)

 

j'ai trouve ce depot : http://ftp.debian.or...aphics-drivers/

 

Devrais je installer chaque paquet ou un paquet install tout d'un coup?


Ce message a été modifié par Vocal - 14 août 2013 - 07:44 .


#40 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 14 août 2013 - 16:02

Salut, Comment est l'installation des pilotes graphiques, sont ils en paqués ou on doit compilier soi meme? :-)

j'ai trouve ce depot : http://ftp.debian.or...aphics-drivers/

Devrais je installer chaque paquet ou un paquet install tout d'un coup?

Dans ce dépôt, il n'y a que des fichiers à extension .deb qui sont des fichiers d'installation de programmes/pilotes. Pas besoin de compilation donc.

Un seul de ces pilotes est à installer. Tu dois choisir entre la version 32 bits (i386) et la version 64 bits (amd64).

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#41 kool56

kool56

    Phobosien

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 863 Messages :

Posté 14 août 2013 - 18:15

Bonsoir tout le monde,

 

Un petit tutoriel pour le partionnement serait le bien venu.Enfin, il ya bien ceci, en attendant:

 

==> http://www.demongeot...NetInstall.html (étape 6)

==> http://www.nairabyte...1-debian-wheezy (English. ici, l'auteur propose d'utilsier le disque entier

       (recommandé pour les débutants. Choisir avec la partition /home séparée n'est pas plus compliqué))


"Les autres, c'est nous" de moi.

#42 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 15 août 2013 - 00:26

Un petit tutoriel pour le partionnement serait le bien venu.

Depuis -> ICI, jusque -> LA. Attention ! Les partitionnements décrits dans ce "topo" correspondent à des cartes-mères à BIOS et disques à MBR.

 

En faut-il davantage ? Oui ! A cause des ordinateurs dont la carte-mère récente est polluée par le Secure boot/UEFI. Dans ce cas ...

Il y a aussi l'UEFI (Unified Extensible Firmware Interface) ou EFI, pilier du ''secure boot'' qui prétend sécuriser le démarrage des ordinateurs sous Windows mais qui a déjà été percé :Le "secure boot" contourné sous Windows 8 . Il sert surtout à compliquer l'installation des distributions Linux sur un ordinateur.

Plusieurs solutions :

.. Se passer complètement de ce "secure boot" : UEFI et Ubuntu (Infomars - mai 2013)

.. S'adapter : Installations de Windows et de Linux/Ubuntu après désactivation du "secure boot" et utilsation de rEFInd : multiboot UEFI (Infomars - août 2013) :

Pour plus d'informations concernant l'UEFI, ce nouveau type de BIOS : UEFI, BIOS, GRUB et GAG (Infomars - juin 2013)

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#43 kool56

kool56

    Phobosien

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 863 Messages :

Posté 15 août 2013 - 00:40

@Txon,

 

Comme d'habitude, merci pour ces informations précieuses. Par tutoriel bien venu, j'entendais, un explicatif avec captures d'écrans pour le partiionnement

de Debian 7.1.0 car c'est quand même un peu trop spartiate, non!? Je vais tenter la chose en faisant une nouvelle installation sur un DD séparé de mon bon vieux IBM T41 , quoique j'ai bien envie de tester la version amd64. En 32, c'est déjà très rapide sur un vieux Pentium 4 de 3Ghz

 

Bonne nuit


"Les autres, c'est nous" de moi.

#44 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 15 août 2013 - 18:31

Le partitionnement d'une Debian se fait sur les mêmes bases que celui d'Ubuntu et de la quasi totalité des distributions Linux.

Tu peux utiliser Gparted pour une préparation préalable à l'installation. Comme tu sembles débuter, tu ne devrais pas avoir besoin d'un partitionnement complexe généralement réservé à ceux qui veulent monter un serveur etc.

 

.. une partition /boot uniquement si tu veux faire du multiboot (Windows + Linux), taille de 512 Mo à 1 Go

.. une partition / (racine) de 8 Go

.. une partition /swap de la taille de ta mémoire avec un minumum de 1 Go

.. le reste du disque pour la partition /home

N'oublie pas le formatage en EXT4, sauf /swap bien entendu.

 

Pas besoin de "zolis zimages".

 

Fais attention à ne pas te tromper de disque lors du formatage et de l'installation. A ce moments là, au besoin, débranche le disque qui contient Windows

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#45 kool56

kool56

    Phobosien

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 863 Messages :

Posté 16 août 2013 - 18:39

@Txon,

 

Désolé, je n'ai pas encore eu l'occasion de régler le problème de connexion via le routeur. DE plus , Debian 7.1.0 xfce donne l'avis suivant:

 

647164Capturedcran1130813172710.png

 

 

"KessSSaKo"!!?? (Pour les adresses routeur et boîter FAI , ce sont bien celles-là)

 

Pour en revenir au partionnement, sauf erreur, il suffit de préparer le DD avec Gparted ou PartedMagic et ensuite, lors de l'installation de Debian 7.1.0 xfce, de choisir le partionnement manuel (Voir image suivante du site anglophone repris plus haut)

debianwheezy12.png

 et de vérifier que le partitionnement y repris corresponde bien à ce qui avait été préparé au préalable, ou non!?

 

Si non, que choisir lors de l’installation de Debian...? merci d'avance.

 

Remarque: J'ai la nette impression de devoir en apprendre bien plus sous cet OS là qu'Ubuntu que j'apprécie pourtant. Et je préfère en apprendre car en ai assez de MS pour les raisons connues...


"Les autres, c'est nous" de moi.

#46 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 16 août 2013 - 20:58

Désolé, je n'ai pas encore eu l'occasion de régler le problème de connexion via le routeur. DE plus , Debian 7.1.0 xfce donne l'avis suivant:

 

647164Capturedcran1130813172710.png

 

Tu n'as toujours pas répondu à mes questions posées plus haut.

Pourquoi la connexion à Internet se fait-elle en branchement direct sur la box et pas lorsque le routeur est interposé ?

.. Le port sélectionné pour la connexion serait-il bloqué par le routeur ? Port 3306 ?

.. Quelle est l'adresse du routeur Belkin dans ton réseau, 192.168.2.1 ? Quelle est l'adresse de la box, 192.168.1.1 ? Quelle adresse figure dans les paramètres de ta connexion eth0 (ou eth1 ...)

 


Pour en revenir au partionnement, sauf erreur, il suffit de préparer le DD avec Gparted ou PartedMagic et ensuite, lors de l'installation de Debian 7.1.0 xfce, de choisir le partionnement manuel (Voir image suivante du site anglophone repris plus haut)

debianwheezy12.png

 et de vérifier que le partitionnement y repris corresponde bien à ce qui avait été préparé au préalable, ou non!?

 

Si non, que choisir lors de l’installation de Debian...? merci d'avance.

Si tu fais une préparation préalable, il faut choisir "Manual" et préciser à nouveau ce partitionnement. Les autres solutions font une installation plus "en vrac".

Lis mon "topo" sur Ubuntu tout (ou presque) y est écrit et, grosso modo, c'est pareil pour Debian ( ou l'inverse puisque Ubuntu est une distributuion Debian arrangée à la sauce Canonical).

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#47 kool56

kool56

    Phobosien

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 863 Messages :

Posté 17 août 2013 - 12:47

@Txon

 

Désolé, mais il y a une réponse qui se trouvait dans le message précédent.( Voir mise en gras noire)

 

Merci pour ta réponse relative au partitionnement. Je vais installer Debian 7.1.0 xfce sur ce vieux T41 sur un DD séparé .Dans le T41, on ne peut y placer qu'un seul et unique DD. Il suffit de sortir l'un et placer l'autre.

 

@Txon,

 

Désolé, je n'ai pas encore eu l'occasion de régler le problème de connexion via le routeur. DE plus , Debian 7.1.0 xfce donne l'avis suivant:

 

647164Capturedcran1130813172710.png

 

 

"KessSSaKo"!!?? (Pour les adresses routeur et boîter FAI , ce sont bien celles-là) à savoir ==> 192.168.1.1 (box FAI) et 1921.168.2.1 (routeur)

 

 

Et voici la seconde réponse.  C'est eth0 qui est repris. Pas de blocage sur le port 3306 / Lors de la fermeture de Debian, il y a un écran (fond noir) avec un défilement de tas d'informations. J'y ai aperçu l'adresse du boîtier du FAI et "eth0"

 

Pour en revenir à ce problème de connexion , je me demande si cela n'aurait pas à voir avec les MAC address . A l'époque, c'est un ami informaticien qui avait configurer ce routeur...

Faudrait-il que j'y introduise la MAC address du PC sur lequel est installé (provisoirement) Debian? Ce serait curieux car cela n'explique pas pourquoi et comment cela fonctionne sans problème avec Ubuntu!

 

Merci d'avance de tes éclairages.


"Les autres, c'est nous" de moi.

#48 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 17 août 2013 - 17:18

@Txon

 

Désolé, mais il y a une réponse qui se trouvait dans le message précédent.( Voir mise en gras noire)



 

"KessSSaKo"!!?? (Pour les adresses routeur et boîter FAI , ce sont bien celles-là) à savoir ==> 192.168.1.1 (box FAI) et 1921.168.2.1 (routeur)

 

 

Et voici la seconde réponse.  C'est eth0 qui est repris. Pas de blocage sur le port 3306 / Lors de la fermeture de Debian, il y a un écran (fond noir) avec un défilement de tas d'informations. J'y ai aperçu l'adresse du boîtier du FAI et "eth0"

Tu n'avais pas répondu à toute la question ... Quelle adresse figure dans les paramètres de ta connexion eth0 (ou eth1 ...)

Si c'est bien "eth0" qui est repris dans les deux cas et qu'il contient une adresse de connexion 192.168.1.1 (box FAI), comment veux-tu que soit trouvé le routeur qui est en 192.168.2.1 ?

Si tu positionne les aiguillages de la voie ferrée pour qu'un train aille de Nancy à Luxembourg, vas-tu garder les même aiguillages pour en envoyer un autre de Nancy à Paris ?

Si tu veux que ton routeur soit pris en compte par une tentative de connexion, commence par mettre la bonne adresse dans les paramètres d'un eth1 ...

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)




0 utilisateur(s) en train de lire ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)