Aller au contenu


Réinstallation en UEFI de mon multiboot LMDE 2 / Windows

UEFI LMDE2 multiboot Windows

  • Vous ne pouvez pas répondre à ce sujet
5 replies to this topic

#1 Darksky

Darksky

    Martien

  • Eminence Verte
  • PipPipPipPipPipPipPipPip
  • 1 212 Messages :
  • Gender:Male
  • Location:Belgique

Posté 11 juillet 2015 - 06:37

Ce sujet est lié à mon installation de LMDE2 "Betsy, qui continuera à me servir de base pour mon "expérience" sur le long terme de LMDE 2. Il en est la variante d'installation "moderne" faisant suite à mon inattention la première fois quand à l'installation en UEFI, que j'avais bâclée.

Il vient donc s'intercaler pour présenter l'installation sur une machine UEFI, mais le premier sujet restera celui qui accueillera mes remarques et découvertes.

 

 

Ayant réinstallé Windows 7 Professionnel en lieu et place de Windows 8.1 sur mon pc, j'ai par la même occasion « cassé » mon multiboot LMDE 2 /Windows (qui, pour rappel, est réalisé avec 2 SSD distincts sur mon pc - voir une précédente installation de Linux Mint 17.1).

 

Lorsque j'ai voulu réparer ça, il m'était impossible de le faire, GRUB refusant obstinément de réintégrer Windows dans le menu de démarrage.

Le raison était simple : j'avais installé (sans trop m'en rendre compte) Windows 7 en mode UEFI.

 

Lors de mon installation précédente, autant Windows 8.1 que LMDE 2 étaient, miraculeusement sans doute, installés en mode « classique », c'est à dire non UEFI. Dans ce cas de figure, Windows est en mode MBR classique, LMDE 2 idem, et tout fonctionnait.

 

Hors, après investigation, je me suis rendu compte qu'en réinstallant Windows 7 j'ai opté, dans le BIOS de ma carte mère, pour le lecteur DVD/Bluray précédé de la mention « UEFI » devant son nom.

Sur l'Asus H97-Plus, il est donc possible, après avoir désactivé SecureBoot, de sélectionner les périphériques en mode « classique » (qu'on peut donc relier au BIOS Legacy), ou alors en mode UEFI. Voilà donc la raison de mon embarras de multiboot.

 

Après avoir effectué mes sauvegardes sur LMDE, je me suis donc mis en route pour réinstaller ma distribution favorite en mode UEFI.

 

Pré-requis

 

Avant de commencer, il faut se documenter un peu, pour savoir ce dont a besoin une distribution pour fonctionner en UEFI.

Il est donc, déjà, important de vous renseigner sur le site de cette dernière pour voir si elle gère l'UEFI (parfois mentionné en EFI, qui est en fait la norme entre le bios legacy et l'UEFI).

C'est maintenant de plus en plus souvent le cas pour les dernières distributions, pas toutes, mais à une condition : il faut impérativement que votre distribution soit une version 64bits. Les versions 32bits ne gèrent simplement pas l'UEFI (d'après ce que j'ai lu)

 

Il faut ensuite bien entendu désactiver le SecureBoot. Pour rappel, c'est une fonctionnalité n'autorisant le démarrage qu'aux systèmes d'exploitation reconnus. Cette fonctionnalité vise à interdire le démarrage d'un système d'exploitation corrompu notamment par un virus ou un rootkit.

Le « hic », c'est que pour ça, le système d'exploitation doit posséder une signature numérique, qui est bien sur payante.

 

Les distributions Gnu/Linux n'ont pas toutes ce type de signature et ne sont donc pas reconnues, ce qui empêche leur lancement. Désactiver SecureBoot est donc nécessaire pour démarrer/Installer ma LMDE 2.

Sur ma carte mère, cela se traduit par une option : il faut remplacer le « mode UEFI Windows » par « autres SE ».

 

Il faut enfin partitionner votre disque d'une certaine manière pour que la distribution (et le multiboot, dans mon cas) fonctionne en UEFI. C'est ce que nous allons décrire ci-après.

 

 

Le partitionnement

 

Inutile de reprendre l'ensemble du processus, la base est la même que pour une installation classique.

Je vais donc me concentrer sur les réglages spécifiques à l'UEFI.

 

Il nous faut donc :

 

          -Une partition EFI comprise entre 100 et 250Mo, formatée en FAT32. J'ai opté pour 250Mo, dans le doute.

          -Une partition /racine

          -Une partition /swap

          -Une partition /home

 

Ce qui change donc fondamentalement, par rapport à l'installation classique, c'est la partition /EFI. Il faut donc impérativement créer ses partitions manuellement. Ceci est possible et déjà connu de ceux qui n'utilisent pas l'installeur de base de LMDE, en cliquant sur Edit Partitions dans la fenêtre de partitionnement, lors de l'installation (celle qui propose les réglages de base et automatisés pour l'installation de LMDE)

 

Il faut ensuite attribuer, toujours depuis Gparted, à la partition EFI le drapeau (« flag ») boot. Pour cela, un clic-droit sur la partition, puis se rendre dans le menu « manage flags », et cocher la mention boot dans la fenêtre qui s'est ouverte.

 

live-flag.png

 

Après avoir appliqué les changements, on se retrouve sur la fenêtre principale, que l'on rafraichi en cliquant sur refresh pour actualiser les modifications faites depuis Gparted, et on attribue le reste des points de montages aux autres partitions. Ici, toujours pour la partition EFI, il faut lui attribuer « /boot/EFI ».

 

partitionnement.png

 

Et voila, votre installation est prête à accueillir une distribution GNU/Linux en mode UEFI.

L'installation terminée, vous redémarrerez votre pc et il vous restera une dernière chose à faire : Mettre à jour GRUB pour qu'il intègre votre Windows dans le menu de démarrage.

 

Mettre à jour GRUB

 

Pour cela, rien de plus simple.

Dès votre distribution démarrée, il faut lancer un terminal, et taper le code suivant :

sudo update-grub

Vous verrez alors l'ensemble de ce que proposera GRUB au démarrage s'afficher. Vérifiez bien qu'une mention Windows dans ce qu'il propose soit présente.

 

update grub.png


"Ils ne savaient pas que c'était impossible, alors ils l'ont fait."

Mark Twain


#2 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 11 juillet 2015 - 13:53

..

 

Voici ce qui nous manquait sur Infomars : une installation en multiple démarrage dans le contexte d'un ordinateur récent équipé du dispositif UEFI.

 

Tout est à retenir !

 

Merci et grand bravo darksky1985 !

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#3 nocopyright

nocopyright

    Terrien

  • Zimien
  • Pip
  • 2 Messages :
  • Gender:Male
  • Location:ALBI (81 - Tarn)

Posté 11 juillet 2015 - 17:46

Bonjour,

 

félicitations, tuto clair net et sans bavure  :etoile: :etoile: :etoile: :etoile: :etoile:

 

Merci

 

@+



#4 Darksky

Darksky

    Martien

  • Eminence Verte
  • PipPipPipPipPipPipPipPip
  • 1 212 Messages :
  • Gender:Male
  • Location:Belgique

Posté 11 juillet 2015 - 18:23

Bonjour,

 

Merci à vous, en espérant qu'il vous soit utile ;)


"Ils ne savaient pas que c'était impossible, alors ils l'ont fait."

Mark Twain


#5 noisette

noisette

    Webmarster

  • Admin
  • PipPipPipPipPipPipPipPipPip
  • 20 887 Messages :
  • Gender:Male

Posté 20 décembre 2016 - 13:39

Merci Darksky,

 

ce sujet m'avait échappé, et il est celui sur mesure dont je vais avoir besoin bientôt !

 

providentiel. :yes:



#6 Darksky

Darksky

    Martien

  • Eminence Verte
  • PipPipPipPipPipPipPipPip
  • 1 212 Messages :
  • Gender:Male
  • Location:Belgique

Posté 20 décembre 2016 - 14:34

Ah ben oui, voila l'article :)

 

Ceci-dit, je viens d'aller vérifier et:

 

Après avoir désactivé le SecureBoot dans le bios:

 

- Si tu installes sur le même disque les 2 OS, commence par installer Windows 7 (en prévoyant déjà un espace réservé à Mint)

- En installant Mint, en choissisant "autre chose" lors de l'installation, il va automatiquement utiliser la partition EFI que Windows aura créée lors de la création de tes partitions. Pas besoin, donc, d'en créer une avec Mint

- Prends bien soin de placer le Grub au tout début du disque (sda).

 

Tu devrais normalement démarrer sur Mint, et ensuite mettre à jour Grub pour que tout soit fonctionnel :)


"Ils ne savaient pas que c'était impossible, alors ils l'ont fait."

Mark Twain




1 utilisateur(s) en train de lire ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)