Aller au contenu


OpenSuse : premiers pas


  • Vous ne pouvez pas répondre à ce sujet
12 replies to this topic

#1 Neuromancien

Neuromancien

    Octozimien

  • Modérateur
  • PipPipPipPipPipPipPipPipPip
  • 5 971 Messages :
  • Gender:Male
  • Location:Moselle

Posté 25 avril 2015 - 12:03

Bonjour !

 

En passant comme ça...

Je suis en train de découvrir OpenSuse sous Gnome. Je peux déjà vous dire que je déteste cet environnement bureau et que je vais regarder comment le changer et si trop prise de tête, je referais une installation ou je testerais LMDE2.

 

Signé : Neuro un peu déçu et de mauvaise humeur.


"Nous sommes des nains juchés sur des épaules de géants. Nous voyons ainsi davantage et plus loin qu'eux, non parce que notre vue est plus aiguë ou notre taille plus haute, mais parce qu'ils nous portent en l'air et nous élèvent de toute leur hauteur gigantesque." (Bernard de Chartres, XIIe siècle)


#2 Neuromancien

Neuromancien

    Octozimien

  • Modérateur
  • PipPipPipPipPipPipPipPipPip
  • 5 971 Messages :
  • Gender:Male
  • Location:Moselle

Posté 25 avril 2015 - 15:29

En passant comme ça...

Je suis en train de découvrir OpenSuse sous Gnome. Je peux déjà vous dire que je déteste cet environnement bureau et que je vais regarder comment le changer et si trop prise de tête, je referais une installation ou je testerais LMDE2.

 

Signé : Neuro un peu déçu et de mauvaise humeur.

 

J'ai finalement viré Gnome et installé XFCE. Je me sens mieux.

Maintenant, je vais un peu tester tout ça.


"Nous sommes des nains juchés sur des épaules de géants. Nous voyons ainsi davantage et plus loin qu'eux, non parce que notre vue est plus aiguë ou notre taille plus haute, mais parce qu'ils nous portent en l'air et nous élèvent de toute leur hauteur gigantesque." (Bernard de Chartres, XIIe siècle)


#3 Neuromancien

Neuromancien

    Octozimien

  • Modérateur
  • PipPipPipPipPipPipPipPipPip
  • 5 971 Messages :
  • Gender:Male
  • Location:Moselle

Posté 26 avril 2015 - 07:41

Salut !

 

Moi qui était un aficionados d'Opensuse et de Yast je suis vraiment déçu...Pourtant, à l'époque où j'avais essayé Ubuntu, OpenSuse m'avait parue si "user friendly" avec sa première version de Yast, autant la version deux sous Gnome est catastrophique et celle sous  XFCE est bof-bof.

Je n'ai jamais réussi a installer OpenVPN que ce soit par Zypper ou Yast ou plutôt la machine me prétend qu'il est installé et je ne le retrouve pas.

 

Capture d'écran - 26042015 - 08:39:59.png

 

Comme dit le terminal : Rien à faire.


"Nous sommes des nains juchés sur des épaules de géants. Nous voyons ainsi davantage et plus loin qu'eux, non parce que notre vue est plus aiguë ou notre taille plus haute, mais parce qu'ils nous portent en l'air et nous élèvent de toute leur hauteur gigantesque." (Bernard de Chartres, XIIe siècle)


#4 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 26 avril 2015 - 15:09

Je suis en train de découvrir OpenSuse ..

 

Quel que soit le résultat de tes essais, j'espère que tu trouveras le temps de faire un "topo" sur ses caractéristiques, avantages et inconvénients. ;)

 

@+

 

 


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#5 Neuromancien

Neuromancien

    Octozimien

  • Modérateur
  • PipPipPipPipPipPipPipPipPip
  • 5 971 Messages :
  • Gender:Male
  • Location:Moselle

Posté 26 avril 2015 - 20:59

 

Je suis en train de découvrir OpenSuse ..

 

Quel que soit le résultat de tes essais, j'espère que tu trouveras le temps de faire un "topo" sur ses caractéristiques, avantages et inconvénients. ;)

 

Bien sûr.  Il y a quelques particularités qui méritent d'être signalées comme le système de fichier BRTFS et snapper. La version 13.2 de ce système d'exploitation est actuellement livrée avec XFCE 4.10 et la mise à jour vers la dernière version n'est pas piquée des hannetons !

Sur le site officiel d'OpenSuse, un compte à rebours est enclenché, ce qui veut dire qu'une nouvelle version va sortir dans 4 jour à partir d'aujourd'hui le 26/04/2015.


"Nous sommes des nains juchés sur des épaules de géants. Nous voyons ainsi davantage et plus loin qu'eux, non parce que notre vue est plus aiguë ou notre taille plus haute, mais parce qu'ils nous portent en l'air et nous élèvent de toute leur hauteur gigantesque." (Bernard de Chartres, XIIe siècle)


#6 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 27 avril 2015 - 06:32

..

 

@ Neuromancien ..

 

Je ne connais rien à OpenSuse, mais, d'après la copie d'écran que tu as postée -> ICI, OpenVPN y est déjà installé. La question dans OpenSuse est de savoir où (dans quel directoire). L'as-tu cherché ?

As-tu essayé de le lancer manuellement dans le -> Terminal <- éventuellement avec des droits d'administrateur ?

 

Btrfs d'Oracle comme système de fichiers dans une distribution Linux destinée aux ordinateurs de bureau, ce n'est pas fréquent bien que ce ne soit pas une mauvaise solution (parfois même recommandée). Je le croyais surtout utilisé pour des serveurs et palier la limite à 16TO de Ext4.

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#7 Neuromancien

Neuromancien

    Octozimien

  • Modérateur
  • PipPipPipPipPipPipPipPipPip
  • 5 971 Messages :
  • Gender:Male
  • Location:Moselle

Posté 27 avril 2015 - 12:04

..

 


Je ne connais rien à OpenSuse, mais, d'après la copie d'écran que tu as postée -> ICI, OpenVPN y est déjà installé.

 

Oui, hélas, je sais.

Pour le terminal une commande "Find" ne' donne rien.


"Nous sommes des nains juchés sur des épaules de géants. Nous voyons ainsi davantage et plus loin qu'eux, non parce que notre vue est plus aiguë ou notre taille plus haute, mais parce qu'ils nous portent en l'air et nous élèvent de toute leur hauteur gigantesque." (Bernard de Chartres, XIIe siècle)


#8 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 27 avril 2015 - 14:33

..

 

Les fichiers exécutables ne sont-ils pas dans /usr/bin ?

Comment voir les fichiers cachés ? La commande .. ls -aR .. fonctionne-t-elle sous OpenSuse ?

 

A quoi sert au juste la commande de recherche .. zypper se "nom d'un paquet" .. ? Tient-elle compte seulement du répertoire présent ou de toute l'arborescence ?

Qu'est au juste l’outil d’indexation sémantique .. nepomuk .. ? Est-il activé dans ton système ?

Pour lancer une application, utilises-tu .. dolphin .. ?

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#9 Neuromancien

Neuromancien

    Octozimien

  • Modérateur
  • PipPipPipPipPipPipPipPipPip
  • 5 971 Messages :
  • Gender:Male
  • Location:Moselle

Posté 28 avril 2015 - 03:43

Salut !

 

..

 

Les fichiers exécutables ne sont-ils pas dans /usr/bin ?

Comment voir les fichiers cachés ? La commande .. ls -aR .. fonctionne-t-elle sous OpenSuse ?

 

A quoi sert au juste la commande de recherche .. zypper se "nom d'un paquet" .. ? Tient-elle compte seulement du répertoire présent ou de toute l'arborescence ?

Qu'est au juste l’outil d’indexation sémantique .. nepomuk .. ? Est-il activé dans ton système ?

Pour lancer une application, utilises-tu .. dolphin .. ?

 

@+

Merci de t'intéresser à mon problème.

Je regarderais tout ça précisément en fin de matinée.

Mais pour commencer, la commande  ls -aR fonctionne bien sous OpenSuse.

 

..

Qu'est au juste l’outil d’indexation sémantique .. nepomuk .. ? Est-il activé dans ton système ?

Pour lancer une application, utilises-tu .. dolphin .. ?

 

@+

 

À première vue, il me semble (je ne suis pas certain) que cet outil et dolphin  concernent  KDE, non ?

J'ai installé XFCE.

 

Pour info, voici ce que donne une commande "zypper info openvpn"

linux-txk3:/home/neuromancien # zypper info openvpn
Chargement des données du dépôt...
Lecture des paquets installés...


Informations sur paquet openvpn :
---------------------------------
Dépôt : Dépôt principal de mise à jour
Nom : openvpn
Version : 2.3.4-2.4.1
Arch : i586
Fabricant : openSUSE
Installé : Oui
État : A jour
Taille une fois installé : 1,1 MiB
Résumé : Full-featured SSL VPN solution using a TUN/TAP Interface
Description :
  OpenVPN is a full-featured SSL VPN solution which can accommodate a wide
  range of configurations, including remote access, site-to-site VPNs,
  WiFi security, and enterprise-scale remote access solutions with load
  balancing, failover, and fine-grained access-controls.
 
  OpenVPN implements OSI layer 2 or 3 secure network extension using the
  industry standard SSL/TLS protocol, supports flexible client
  authentication methods based on certificates, smart cards, and/or
  2-factor authentication, and allows user or group-specific access
  control policies using firewall rules applied to the VPN virtual
  interface.
 
  OpenVPN runs on: Linux, Windows 2000/XP and higher, OpenBSD, FreeBSD,
  NetBSD, Mac OS X, and Solaris.
 
  OpenVPN is not a web application proxy and does not operate through a
  web browser.

C'est donc bien installé et à jour.

Cela m'aurait étonné si cela n'avait pas été le cas. J'avais déjà lancé la commande "zypper up"

 

 

update or up

The following commands update packages with their newer available versions.


"Nous sommes des nains juchés sur des épaules de géants. Nous voyons ainsi davantage et plus loin qu'eux, non parce que notre vue est plus aiguë ou notre taille plus haute, mais parce qu'ils nous portent en l'air et nous élèvent de toute leur hauteur gigantesque." (Bernard de Chartres, XIIe siècle)


#10 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 28 avril 2015 - 11:28

 

Mais pour commencer, la commande  ls -aR fonctionne bien sous OpenSuse.

Que donne-t-elle appliquée dans /usr/bin .

 

Pour info, voici ce que donne une commande "zypper info openvpn"

Et la commande .. zypper se openvpn .. ?

 

À première vue, il me semble (je ne suis pas certain) que cet outil et dolphin  concernent  KDE, non ?

J'ai installé XFCE.

Le plus souvent, l'installation d'un environnement de bureau supplémentaire ne provoque pas automatiquement la suppression de l'ancien et des ses modules particuliers. Dans ton cas, il se pourrait qu'il reste des traces de Gnome. Peut-être les utilitaires propres à KDE seraient-ils encore là si tu étais parti de cet environnement de bureau.

 

Mais puisque OpenVPN est bien là, comment peux-tu faire pour le lancer manuellement ?

Simplement en tapant .. openvpn .. dans le Terminal (éventuellement avec des droits d'administrateur) ?

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#11 Neuromancien

Neuromancien

    Octozimien

  • Modérateur
  • PipPipPipPipPipPipPipPipPip
  • 5 971 Messages :
  • Gender:Male
  • Location:Moselle

Posté 01 mai 2015 - 07:40

Salut !

 

 

 

Que donne-t-elle appliquée dans /usr/bin .
 

 

Une liste très longue classée dans l'ordre alphabétique où OpenVPN n’apparaît pas.

 

 

 

Et la commande .. zypper se openvpn .. ?

 

Chargement des données du dépôt...
Lecture des paquets installés...

S | Nom                                    | Résumé              | Type         
--+----------------------------------------+---------------------+--------------
  | NetworkManager-openvpn-debuginfo       | Debug information-> | paquet       
  | NetworkManager-openvpn-debugsource     | Debug sources for-> | paquet       
  | NetworkManager-openvpn-gnome-debuginfo | Debug information-> | paquet       
i | openvpn-auth-pam-plugin-debuginfo      | Debug information-> | paquet       
i | openvpn-debuginfo                      | Debug information-> | paquet       
i | openvpn-debugsource                    | Debug sources for-> | paquet       
i | openvpn-down-root-plugin-debuginfo     | Debug information-> | paquet       
  | plasma-nm-openvpn-debuginfo            | Debug information-> | paquet       
  | plasma-nm5-openvpn-debuginfo           | Debug information-> | paquet       
  | NetworkManager-openvpn                 | NetworkManager VP-> | paquet       
  | NetworkManager-openvpn-gnome           | NetworkManager VP-> | paquet       
i | openvpn                                | Full-featured SSL-> | paquet       
i | openvpn-auth-pam-plugin                | OpenVPN auth-pam -> | paquet       
i | openvpn-down-root-plugin               | OpenVPN down-root-> | paquet       
  | plasma-nm-openvpn                      | OpenVPN support f-> | paquet       
  | plasma-nm5-openvpn                     | OpenVPN support f-> | paquet       
  | NetworkManager-openvpn-lang            | Languages for pac-> | paquet       
  | NetworkManager-openvpn                 | NetworkManager VP-> | paquet source
  | openvpn    

 

Mais puisque OpenVPN est bien là, comment peux-tu faire pour le lancer manuellement ?

 

Simplement en tapant .. openvpn .. dans le Terminal (éventuellement avec des droits d'administrateur) ?

 

 

 

Non, cela me donne l'accès aux options en mode graphique.

Je n'ai pas tout mis :

 

linux-txk3:/ # openvpn
OpenVPN 2.3.4 i586-suse-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on May  1 2014

General Options:
--config file   : Read configuration options from file.
--help          : Show options.
--version       : Show copyright and version information.

Tunnel Options:
--local host    : Local host name or ip address. Implies --bind.
--remote host [port] : Remote host name or ip address.
--remote-random : If multiple --remote options specified, choose one

 

 

 

Bon...comme ça commence a me gonfler mais à un point que l'on ne peut pas s'imaginer, je laisse tomber pour l'instant.

 


"Nous sommes des nains juchés sur des épaules de géants. Nous voyons ainsi davantage et plus loin qu'eux, non parce que notre vue est plus aiguë ou notre taille plus haute, mais parce qu'ils nous portent en l'air et nous élèvent de toute leur hauteur gigantesque." (Bernard de Chartres, XIIe siècle)


#12 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 01 mai 2015 - 07:56

..

 

Quelle version de OpenSUSE utilises-tu ? Le 13.2 ?

 

Dans le site officiel en anglais, je tombe sur SDB:OpenVPN Installation and Setup et dans leur forum sur OpenVPN does not work under opensuse 13.2 où il est question de  /etc/openvpn

You have to create a config in /etc/openvpn/ and then enable/start that particular instance.

 

 

Il y a aussi dns - OpenSUSE 13.1 openvpn (StackOverflow)

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#13 Neuromancien

Neuromancien

    Octozimien

  • Modérateur
  • PipPipPipPipPipPipPipPipPip
  • 5 971 Messages :
  • Gender:Male
  • Location:Moselle

Posté 01 mai 2015 - 18:04

..

 

Quelle version de OpenSUSE utilises-tu ? Le 13.2 ?

 

Oui.

 

J'ai désinstallé OpenVPN.


"Nous sommes des nains juchés sur des épaules de géants. Nous voyons ainsi davantage et plus loin qu'eux, non parce que notre vue est plus aiguë ou notre taille plus haute, mais parce qu'ils nous portent en l'air et nous élèvent de toute leur hauteur gigantesque." (Bernard de Chartres, XIIe siècle)




1 utilisateur(s) en train de lire ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)