Aller au contenu


LMDE 2 "Besty" : premiers essais


  • Sujet fermé Ce sujet est fermé
13 replies to this topic

#1 Darksky

Darksky

    Martien

  • Eminence Verte
  • PipPipPipPipPipPipPipPip
  • 1 212 Messages :
  • Gender:Male
  • Location:Belgique

Posté 11 avril 2015 - 12:29

Bonjour,

 

La version finale de la LMDE 2 "Besty" est dans les bacs!

 

Sorties simultanées des versions Cinnamon et Mate, hier.

 

Attention, les versions LMDE sont directement basées sur Debian et non plus sur Ubuntu, ce qui veut dire que les PPAs d'Ubuntu ne sont pas pris en charge.

D'après l'annonce officielle sur le site de Linux Mint, cela se traduit par quelques "manquements" encore, et ils ne conseillent donc pas spécialement ça aux utilisateurs débutants.

 

Toutefois, ils assurent que cette version est plus "excitante" que la Mint basée sur Ubuntu du fait qu'elle va recevoir en continu toutes les améliorations de Linux Mint, avant que celles-ci ne soient proposées sur la version "classique" (base Ubuntu).

D'après le site, toujours, la LMDE est plus stable et légèrement plus rapide que la Linux Mint.

 

Je vais tenter d'installer ça sur machine virtuelle (peut-être simplement en faisant les mise à jours de la version RC ?) pour éventuellement passer ensuite mon installation Mint principale en LMDE.

 

Pour les télécharger, c'est par ici:

 

http://www.linuxmint...wnload_lmde.php

 

…. …. …. ….

…. …. …. ….

 

 

La suite du sujet -> ICI

 

…. …. …. ….

…. …. …. ….


"Ils ne savaient pas que c'était impossible, alors ils l'ont fait."

Mark Twain


#2 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 11 avril 2015 - 18:20

..

 

Merci pour cette annonce. J'attends avec impatience tes essais.

 

Juste quelques notes ..

.. LMDE 2 "Besty" serait basée sur Debian 8 "Jessie'' (dont la sortie officielle est prévue dans deux semaines). Peux-tu confirmer ?

.. Il existe un tutoriel récent dans la documentation Debian pour créer un package propre à Debian à partir de celui qui se trouve dans un PPA d'Ubuntu : CreatePackageFromPPA ("If a package is availaible in a Ubuntu PPA but not in Debian, you can easily create a Debian version of if.")

.. Pour ceux qui ne s'en rappelleraient pas, rajouter les dépôts "Backports" grâce à Synaptic ou en modifiant le fichier /etc/apt/sources.list .. et SourcesList pour l'ensemble dont les "non-free".

 

Les problèmes connus de la LMDE 2 et les solutions provisoires ..

lmde-2.png

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#3 Darksky

Darksky

    Martien

  • Eminence Verte
  • PipPipPipPipPipPipPipPip
  • 1 212 Messages :
  • Gender:Male
  • Location:Belgique

Posté 12 avril 2015 - 09:24

Je ne manquerais pas de vous en faire retour.

 

Ici, première installation, et j'ai réussi à la "flinguer" en voulant installer le pilote Nvidia.

Pas de doute, on se trouve bien sur une base Debian :D

Et comme, en plus de ça, je suis un manche....

 

Je réinstallerais ça comme il faut dès que possible.


"Ils ne savaient pas que c'était impossible, alors ils l'ont fait."

Mark Twain


#4 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 12 avril 2015 - 16:14

..

 

As-tu essayé de suivre l'un ou l'autre de ces tutoriels ???

 

.. NvidiaGraphicsDrivers - Debian Wiki

.. Installation des pilotes pour cartes video Nvidia sous Debian

.. Installer un driver pour carte graphique NVIDIA sous Debian GNU ...

 

ou un autre ?

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#5 Darksky

Darksky

    Martien

  • Eminence Verte
  • PipPipPipPipPipPipPipPip
  • 1 212 Messages :
  • Gender:Male
  • Location:Belgique

Posté 12 avril 2015 - 21:01

Hello,

 

Oui, en effet, j'ai suivi les instructions qui sont données dans les liens que tu cites.

 

Le soucis, c'est que je dois au préalable arrêter le serveur X.

Je n'y parviens pas.

 

Du coup, tablant sur la chance (que je n'ai jamais), je tente quand même d'exécuter le fichier .run téléchargé sur le site de Nvidia. Ça ne rend rien, bien entendu, vu que le serveur X n'est pas stoppé.

Et, de là, en découle l'impossibilité de relancer la LMDE.

 

Pour moi, en tout cas. Je viens encore d'essayer après l'avoir réinstallé.

 

Si je tente par tous les moyens d'installer le pilote propriétaire, c'est parce que de base, avec le pilote générique, j'ai un message au lancement de LMDE qui me dit que Cinnamon est exécuté en mode de rendu je ne sais pas quoi, ce qui fait que l'utilisation CPU est plus importante, et qui me dit que ce mode ne devrait être utilisé qu'en cas de nécessité (je ne sais pas laquelle, mais il y en a surement une, puisqu'il le dit...)

 

Du coup, pour alléger la charge CPU et avoir un meilleur rendu graphique, hop --> pilote proprio.

 

Oui, mais... C'est Debian, et franchement, je me revois quelques mois en arrière, à galérer comme un mineur de fond pour installer un malheureux pilote graphique.

Y a pas à dire, niveau pilote graphique, Debian, c'est vraiment pas ça...

Autant ça passe avec des CG "simples", autant quand on monte un peu en gamme ou qu'on a une CG un peu récente, c'est la croix et la bannière avant même d'avoir commencé.

 

C'est triste parce que ça te dégoûte presque dès le départ alors que derrière, une fois cette étape passée, c'est assez sympa.

J'espérais qu'avec la LMDE ce genre de truc serait "tranquille", à l'instar de leur module d'installation de drivers proprio sur la Mint base Ubuntu, mais ce machin qui simplifie la vie de l'inculte profane que je suis n'est pas présent sur la LMDE.

 

Que ça ne dégoûte pas les autres (comme Noisette) de tenter la LMDE, au demeurant elle me semble vraiment bonne et peut-être qu'avec Mate le soucis ne se pose pas niveau rendu graphique, mais en tout cas sur un matos récent (CG GTX970) et en Cinnamon, c'est un autre challenge, que je compte résoudre, mais là pour l'instant je n'ai plus le courage, donc je remets ça au mieux à demain, au pire à dans la semaine.


"Ils ne savaient pas que c'était impossible, alors ils l'ont fait."

Mark Twain


#6 Severian

Severian

    Plus riant que sévère

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 747 Messages :
  • Gender:Male

Posté 13 avril 2015 - 05:17

jette un oeil à ces liens

https://debian-facil...d=10653&p=1

https://debian-facil...pic.php?id=1755

http://smxi.org/

ob3-de10.pngbanner98x30.png


#7 noisette

noisette

    Webmarster

  • Admin
  • PipPipPipPipPipPipPipPipPip
  • 21 131 Messages :
  • Gender:Male

Posté 13 avril 2015 - 06:15

J'espère en ce qui me concerne que les trois mois qui viennent vont permettre de régler ces soucis, c'est vrai que comme Darksky, j'espère voir à terme la version Debian aussi performante que la version classique en ce qui concerne la facilité d'installation.



#8 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 13 avril 2015 - 08:13

..

 

Ton système est-il en 32 ou 64 bits ? Et le pilote ?

Est-ce bien celui qui a été préparé pour "Jessie" ? As-tu essayé ce qui se trouve dans les dépôts "non-free" : nvidia-driver (340.65-2) .. xserver-xorg-video-nvidia (340.65-2)

 

Une autre piste : NVIDIA GeForce Driver Installation on Debian Jessie Linux 8 64bit (Linux Config)

 

 

Si je trouve un peu de temps je vais essayer cette LMDE 2 mais avec l'environnement de bureau Mate et je n'ai pas de carte graphique spécifique. Le résultat pourrait être tout différent.

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#9 Darksky

Darksky

    Martien

  • Eminence Verte
  • PipPipPipPipPipPipPipPip
  • 1 212 Messages :
  • Gender:Male
  • Location:Belgique

Posté 13 avril 2015 - 12:03

Mon système est en 64 bits.

 

Je vais retenter avec ton dernier lien. Jusque-là je ne l'avais pas fait car la version 340.65-2 ne supporte pas la GTX970 (d'après ce que j'ai pu voir dans le listing sur Debian). la 970 étant une des toutes dernières Nvidia sortie, il semblerait que seule la version 346 disponible sur le site de Nvidia la prenne en charge.

 

Je tenterais toujours, de toutes façons.

 

Normalement, tu ne devrais pas avoir de problème avec la version Mate. C'est un fork de Gnome 2, qui demande moins de ressources graphiques tandis que Cinnamon en est un de Gnome Shell à la sauce Mint.

J'apprécie Cinnamon justement parce qu'il allie la simplicité de Gnome 2 tout en apportant une touche de moderne. Par exemple, un truc con, mais j'aime beaucoup la possibilité qu'il offre de désinstaller une application en faisant un simple clic droit dans le menu, plutôt que de passer par synaptic ou le gestionnaire de logiciels.

 

Certes, c'est plus une commodité, mais il y a d'autres exemples de ce qu'il permet/propose qui sont à mon goût.

 

Je vous tiendrais au courant ;)

 

Merci encore pour votre aide.


"Ils ne savaient pas que c'était impossible, alors ils l'ont fait."

Mark Twain


#10 Darksky

Darksky

    Martien

  • Eminence Verte
  • PipPipPipPipPipPipPipPip
  • 1 212 Messages :
  • Gender:Male
  • Location:Belgique

Posté 13 avril 2015 - 17:11

Hé bien... non,ça ne marche pas.
Comme je le craignais la 340 ne supporte pas ma carte et du coup le fichier Xorg est mauvais, ce qui me vaut de demarrer en mode console sans arrêt.

Je pense que je vais soit installer la Mate, ou plutôt repasser sur la mint base ubuntu qui elle ne me prend pas la tête avec le pilote Nvidia, pour profiter de Cinnamon.

En espérant voir à terme un plus doué que moi réussir et expliquer cette installation.

Ça me prouve au moins que même la debian pure aurait eu du mal sur ma nouvelle config.

"Ils ne savaient pas que c'était impossible, alors ils l'ont fait."

Mark Twain


#11 Severian

Severian

    Plus riant que sévère

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 747 Messages :
  • Gender:Male

Posté 13 avril 2015 - 20:08

une question, tu as la possibilité de démarrer lmde en mode "dépannage" avec grub ? car normalement ça ne lance pas le serveur X

ob3-de10.pngbanner98x30.png


#12 Txon

Txon

    AïoligaToR

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 10 854 Messages :
  • Gender:Male

Posté 14 avril 2015 - 07:24

..

 

Deux "trucs" que je viens de trouver .. peut-être un peu tard.

 

.. NVIDIA GTX 970 on Debian Jessie (sur Reddit  .. 01 février 2015)

From a quick search I can see that Jessie currently has version 340.65-2 of the nvidia binary driver, and that support for your card was added by nvidia in the driver versioned 343.22. The only version of the driver in debians repositories that match your card is in experimental which has 343.36-1.

So either use pinning to get the package from experimental, or install it manually from nvidias site.

 

 

How To Install The Nvidia 346.16 Beta Driver For Linux On The Most Popular Linux Systems (sur LinuxG .. 16 novembre 2014)
NVIDIA 346.16 Beta GPU driver for Linux has been released recently, coming with support for the GeForce GTX 970M and GeForce GTX 980M GPUs .. .. .. .. how to install the Nvidia 346.16 Beta drivers on the most popular Linux systems, including: Ubuntu, Linux Mint, Elementary OS, Pinguy OS, LXLE, Linux Lite, Deepin, Peppermint, Debian, Fedora, CentOS, OpenSUSE, Mageia and OpenMandriva.

 

@+


"They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety."(Benjamin Franklin)


#13 Darksky

Darksky

    Martien

  • Eminence Verte
  • PipPipPipPipPipPipPipPip
  • 1 212 Messages :
  • Gender:Male
  • Location:Belgique

Posté 14 avril 2015 - 08:47

Mdm stop... MDM STOP!
Txon, tu es mon sauveur!

Voila la commande qui me manquait.
Jusque là j'utilisais gdm mais linux mint,effectivement, n'utilise pas le même environnement.

J'essaie ça et vous tiendrai au jus.
Merci!!

"Ils ne savaient pas que c'était impossible, alors ils l'ont fait."

Mark Twain


#14 Darksky

Darksky

    Martien

  • Eminence Verte
  • PipPipPipPipPipPipPipPip
  • 1 212 Messages :
  • Gender:Male
  • Location:Belgique

Posté 15 avril 2015 - 17:05

Bonjour à tous,

 

Comme expliqué dans l'autre sujet, j'ai réussi à installer les pilotes graphique de ma Nvidia GTX970.

 

Je m'emploie donc maintenant à réinstaller toutes les applications d'usage courant.

Si je viens le signaler, c'est parce que j'ai eu l'agréable surprise de trouver dans le gestionnaire de logiciels intégré à LMDE la toute dernière version de VirtualBox, ce qui n'était pas le cas avec ma Debian "pure", où il m'avait fallu ajouter les dépôts de VirtualBox pour profiter des dernières améliorations.

 

Autre point, il est indispensable d'installer l'interface graphique pour le pare-feu GUFW, qui n'est pas présente par défaut (comme sur Debian, alors qu'elle est bien là sur le Mint classique). Le pare-feu est ensuite disponible dans "paramètres système", "administration". Il ne faut pas oublier de l'activer.

 

…. …. …. ….

…. …. …. ….

 

 

La suite du sujet -> ICI

 

…. …. …. ….

…. …. …. ….


"Ils ne savaient pas que c'était impossible, alors ils l'ont fait."

Mark Twain




0 utilisateur(s) en train de lire ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)