Aller au contenu


installation de debian jessie sur un pc portable samsung

test debian jessie

  • Vous ne pouvez pas répondre à ce sujet
9 replies to this topic

#1 Severian

Severian

    Plus riant que sévère

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 747 Messages :
  • Gender:Male

Posté 25 janvier 2016 - 13:06

le portable :

  • samsung NP370R5E-A04FR
  • Intel Core i3-2365M (Dual-Core 1.4 GHz - Cache 3 Mo)
  • 4 Go de ram

 

premières prises en main...

le pc est livré avec un dd réinitialisé d'usine (windows 8)

 

1er étape

configuration de windows 8

suppression des applications / logiciels inutils

 

2eme étape

mise à jour vers windows 8.1 (si vous ne le savez pas, m$ arrête totalement le support pour win 8)

pour installer win 8.1, il faut déjà mettre à jour le 8 ... 142 màj c'est long

configuration de win 8.1

 

3eme étape

créer un media de restauration système (pas de dvd ou clé livré avec le pc, donc j'en créer un) heureusement samsung met à disposition un outil de sauvegarde bien pratique.

créer une image système de windows

 

4eme étape

changer la disque dure et tester une réinstallation pour vérifier que le média de restauration et l'image fonctionnent bien (et là c'est le drame...)

la restauration se fait bien, mais impossible de récupérer une image système 8.1 depuis une version 8 ... je suis bon pour refaire la màj de win 8 (142 màj ... c'est long), réinstaller win 8.1 pour voir si l'image système fonctionne....

bon cette foi je vais aussi faire une image système de win 8 une fois celui-ci à jour, je gagnerai peut être du temps ....

 

à suivre .....


ob3-de10.pngbanner98x30.png


#2 Severian

Severian

    Plus riant que sévère

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 747 Messages :
  • Gender:Male

Posté 27 janvier 2016 - 22:06

bon visiblement un petit soucis de disque dure ...

tant pis je sais que le média de restoration fonctionne lui :p

 

5eme étape

avec les outil windows je partitionne mon disque (c'est à dire que je sépare en deux la partition de contenant le windows, et je laisse la seconde partition non formaté (espace libre))

création de la clé usb

utilisation de Rufus pour y coller Debian 8.3 jessie (vi vi y a eu une nouvelle version ce week-end)

 

démarrage depuis la clé un peu galère ...

1 - désactiver le sécure boot

2 - désactiver le fast boot

3 - trouver la bonne touche pour selectionner le média de démarrage (F12 dans mon cas)

 

plusieurs médias apparaissent

1 - windows uefi (normal)

2 - la clé debian en mode uefi

3 - média de récupération (pour restorer le pc) en mode normal

4 - la clé debian en mode normal

 

histoire de pas casser mon boot efi, je lance en normal ...

 

installation sans problème (juste l'avertissement qu'il me manque le firmware pour ma carte wifi)

au choix des partitions je fais en assité, l'installateur me créé une patition swap et deux partitions ext4 (une pour le système et une pour le home)

petite remarque, impossible de mettre un "drapeau" de boot sur mes partions ext4, j'ai un peu "tiqué" mais j'ai continué

installation de grub sur le disque mais pas dans le mrb, donc je pense qu'il me l'a collé sur la partition système débian

 

reboot ....

impossible de booter sur autre chose que windows, il ne voit que lui....

 

je retente une installation, mais choisi la clé en mode uefi

réinstallation (ça ne change pas)

pour le grub je choisi cette fois l'installation de base (sur le boot du disque)

reboot et bingo ... j'ai grub avec les options debian, windows et récupération...

je teste windows, et tout fonctionne bien.

je teste debian et tout fonctionne bien aussi....

 

bref me voila avec un pc en dual boot window 8.1 / debian

 

comme à mon habitude j'ai choisi d'installer debian sans environnement graphique (tout décoché au choix des bureaux / programmes)

donc sans rentrer dans les détails

modification du sources.list pour avoir les dépôts non-free

installation des firmwares et microcode (realtek et intel)

installation du serveur graphique

installation de divers outils

installation openbox plus des outils (panel / plugins xfce4)

démarrage de la session utilisateur

règlage de l'environnement graphique, des connexions (filaire et wifi), installation d'utilitaires

 

et me voila en train de vous écrire ce petit résumé depuis ce portable qui fonctionne comme un charme (le tout en wifi)

 

qui a dit que debian c'était compliqué ?? :p

 

samsung-deian-270116.jpg


ob3-de10.pngbanner98x30.png


#3 noisette

noisette

    Webmarster

  • Admin
  • PipPipPipPipPipPipPipPipPip
  • 20 959 Messages :
  • Gender:Male

Posté 28 janvier 2016 - 08:54

Ahhhhh, ces histoires d'efi, uefi, mbr, il y a de quoi devenir dingue ! Je crois bien que je suis resté coincé à quelques années auparavant.



#4 vigen

vigen

    Hardcore Papa

  • Tonton Flingueur
  • PipPipPipPipPipPipPipPipPip
  • 6 439 Messages :
  • Gender:Male
  • Location:Normandie

Posté 28 janvier 2016 - 17:32

Pour info, sur ma carte mère ça se désactive sans problème...



#5 Severian

Severian

    Plus riant que sévère

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 747 Messages :
  • Gender:Male

Posté 14 février 2016 - 22:43

bon j'ai tout planté samedi ....

je voulais redimensionner ma partition windows (la réduire) pour ne garder que 70 Go, mais impossible de descendre en dessous de 300 Go (plus d'espace dispo soit disant...)

au final j'ai redimensionné avec gparted, et planté mon système windows (debian fonctionnait toujours très bien)

du coup j'ai réinstallé l'image système windows ce qui m'a effacé debian :|

enfin j'ai compris le truc.

pour redimensionner tranquillement windows (avec les outil windows c'est plus prudent)

  • désactiver la veille prolongée
    lancer l'invite de commande (cmd) en mode administrateur
    et taper
    powercfg -h off
  • désactiver le "fichier d'échange"
    panneau de configuration / système / à gauche cliquer sur Paramètres système avancés
    onglet paramètres système avancés section Performances (Effet visuels...) cliquer sur "Paramètres..."
    onglet Avancé, Dans la zone Mémoire virtuelle, cliquez sur le bouton Modifier
    sélectionner C: et choisir Aucun fichier d'échange -> Définir
  • redémarrer le pc
  • défragmenter
  • maintenant il est possible de réduire la partition,

en fait la veille prolongé et le fichier d'échange créent des fichiers système (caché) qui se placent en fin de partition et qui ne peuvent pas être déplacé par une défragmentation. Donc en les désactivant, plus de fichiers ennuyant :p (sans compter que windows devient tout de suite plus léger, à peine 16 Go avec quelques programmes installés (gimp, firefox,...)

 

du coup j'ai pu créer une partition de 50Go pour windows, 10Go pour le fichier d'échange windows, et réinstaller debian (15Go pour le sys (/), 25 pour le /home et 12Go pour la swap (j'ai gonflé le portable en passant à 8Go de ram, prochaine étape le ssd)

 

l'uefi ne m'a vraiment pas posé de problème, la clé d'installation pour debian étant démarré en uefi, grub s'installe bien et les systèmes sont bien reconnus

Image : debian-8.3.0-amd64-netinst.iso

pour créer la clé : sous windows avec rufus


ob3-de10.pngbanner98x30.png


#6 Severian

Severian

    Plus riant que sévère

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 747 Messages :
  • Gender:Male

Posté 23 février 2016 - 22:47

bon ...

bon ....


non c'est pas bon au final ...

je parle du SSD...

le clonage de mon disque sur le ssd à très bien fonctionné, pour la copie j'ai utilisé EaseUs Disk Copy (une base linux pour un logiciel propriétaire de clonage, rapide et léger)
pas de soucis de boot sur le ssd, que ce soir windows ou debian ... le soucis vient de windows, impossible de l'activer (à mon avis une foutu protection oem lié au matos, donc au disque d'origine du portable...)

du coup pour l'instant le ssd est en standby, le temps que je trouve le courage d'appeler samsung ou m$ pour avoir une solution...

par contre je n'ai pas pensé à vérifier si les partitions étaient alignées :|

ob3-de10.pngbanner98x30.png


#7 vigen

vigen

    Hardcore Papa

  • Tonton Flingueur
  • PipPipPipPipPipPipPipPipPip
  • 6 439 Messages :
  • Gender:Male
  • Location:Normandie

Posté 24 février 2016 - 00:36

"à mon avis une foutu protection oem lié au matos, donc au disque d'origine du portable..."

 

Il y'a de forte chance, c'est comme cela que fonctionne les licences OEM.

 

Tu n'utilises pas Clonezilla?



#8 Severian

Severian

    Plus riant que sévère

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 747 Messages :
  • Gender:Male

Posté 19 avril 2016 - 19:58

après quelques mois de "sommeil" me revoilà...
 
bon j'ai retenté un clonage de du système sur le ssd ...
 
cette fois j'ai utilisé l'outil fourni avec le ssd : [pdf] Samsung Data Migration v3.0

 

ça ne m'a fait que le clonage du système windows et des partition de boot (le minimum syndicale :p)

Au démarrage du système cloné, j'ai une erreur grub ... arf normal, le système debian n'est pas encore installé

obligé de passer par le bios, en remettant le secure-boot j'ai aussi une grosse erreur ... ça commence sérieusement à me faire peur :|

 

dans le bios je désactive le sécure boot et dans la séquence de boot je choisi windows et là miracle, tout passe super bien :)

 

appel à windows pour faire l'activation (ce qui me prend moins de 10 minutes) et tout est bon ... hooo joie !!!

 

maintenant il me faut réinstaller debian ...

ça m'ennuie de tout refaire l'installation et la configuration, avec openbox je vais en avoir pour quelques jours ...

 

du coup je retire le ssd, je le met dans la tour ainsi que l'ancien système

je créé sur le ssd les partitions system, home et swap de la même taille que l'ancien système

et j'utilise la commande dd (man dd)

et je copie une par une mes partitions.

je remets le ssd en place dans le portable

je lance ... erreur de grub ... grrrrrrrrr

 

un coup de grub repair

 

reboot et

YESSSS tout fonctionne à merveille

 

que ça soit windows, ou debian, je retrouve mes environnements et mes configurations

 

bref que d'aventures pour en faire un pc potable :p


ob3-de10.pngbanner98x30.png


#9 Tchim

Tchim

    A vos souhaits !

  • Administrateur
  • PipPipPipPipPipPipPipPipPip
  • 4 279 Messages :
  • Gender:Male
  • Location:Valles Marineris.

Posté 21 avril 2016 - 05:27

Bien vu  :reflechis:

 

Pas encore essayé le dual-boot, mais vu comme ça, avec cette commande "dd" que je connaissais pas, ça devient intéressant, parce que tout configurer à nouveau ça peut freiner un peu quand même.

 

Merci pour ce retour d'installation en dual-boot avec le diable  :siffle:


Que la paix vous accompagne !


#10 Severian

Severian

    Plus riant que sévère

  • Eminence Verte
  • PipPipPipPipPipPipPip
  • 747 Messages :
  • Gender:Male

Posté 21 avril 2016 - 07:36

petite précision, le fait d'avoir utilisé dd pour copier mes partition, ça me permet de garder la même uuid pour celle-ci

c'est donc un clonage :)

 

le tuto dont je me suis servi / inspiré -> http://sysadmin.llis...dmin/cloner.php


ob3-de10.pngbanner98x30.png




0 utilisateur(s) en train de lire ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)